Home » Sharepoint 2010

503 Service Error and Cannot connect to configuration database.

We have a brand new installation of Windows Server 2008 R2, SQL Server 2008 R2, and SharePoint 2010, and configuration of SharePoint 2010 at end of installation.

So far after all of this was installed the only thing we've accomplished so far is this:

Accessing the website:  503 Service Unavailable.
Accessing admin site:  503 Service Unavailable and/or Cannot connect to configuation database.

I've installed teh recommended hotfixes.  I've rebooted.  I've reconfigured to ensure it was hitting the right database and everything else.  Googled and searched here, ALL to no avail.

Suggestions?  I'm at my wits end and won't spend another second on what, but all appearances, is turning out to be a crappy product that our company spent thousands on.  I've had better luck (100% success) running just the services.



1 Answer Found


Answer 1


Need more information in terms of the installation.


Did you run the Setup Configuration Wizard?

Can you open Central Administration?

Can you make sure that SQL Server is running?






System: Server 2008 R2 Ent all patched up, SharePoint 2010 Ent with 2 web applications installed and no other sites.

The SharePoint Web Services Site in IIS 7.0 has a question mark on its icon. Whe I browse the site either from IIS or my PC I get a generic white Service Unavailable - HTTP Error 503. The service is unavailable.

All other sites including Central Administration are good. 


I am setting up a new TFS 2010 instance on a Windows Server 2008 R2 box.  I am un-installed the previous instance and ran the install again in order to change system account, database settings, etc.  The installation ran through correctly with no errors.  My domain account is a local admin on the server, and a serveradmin in the SQL Server instance.  We are not running Reporting Services or Sharepoint.  Following the installation, I was able to create 3 Project Collections with no errors.

Now, when I try to connect to TFS through Visual Studio or the web client, I receive an error Service Unavailable 503.  In looking at IIS on the server, I can see that the Application Pools for TFS have been stopped.  The Event Viewer shows me that WAS has run into the following error:

Event ID 5059 - Application pool Microsoft Team Foundation Server Web Access Application Pool has been disabled. Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool.

In the details of the Application Pools, I can see that I'm the account that they are running under.  I tried changing to one of the system accounts, but this didn't change the behavior.  Am I missing a step during the setup?  Please help, thanks.


Todd Larson

I am running a MOSS 2007 server in a test environment. I have been off building other aspects of the environment, but I come back today and notice that SharePoint is no longer working. Whenver I try to access it or the Central Administration area I recieve a "503: Service Unavailable" error.

I have also notice that after an IISRESET that the applications pools that are associated with the SharePoint sites (Extranet, Intranet, Sharepoint - 21075, and Central Administration fail to start on their own. I can start the manually. They are all running under the DOMAIN\Administrator account (as are ALL of the SharePoint related features. I know, I know, but that is what the requestor of this test environment requested).

Additionally the following error codes are logged (NOTE: These are translated from German):

Event ID: 6641
Source: Office Sharepoint Server
The SSP timer Mandate for import distribution lists did not execute.

Reason: Registration failed: The user does not have the required logon on this computer.

Event ID: 2424
Source: Office Server Search
The update cannot be started because there is no access to the content sources. To correct the mistakes and start updating again.

Context: Application 'SharedServices1' Catalog 'Portal_Content'

Also, I am seeing in the security log:

Event ID: 4625
Source: Microsoft Windows Security Auditing
Basically this shows that there was a logon failure for account "DOMAIN\Administrator" from process C:\Programme\Common Files\Microsoft Shared\Web Server Extensions\12\BIN\OWSTIMER.EXE

Event ID: 5059
Source: System
The application pool "Sharepoint - Intranet80" has been disabled. Error in the Windows Activation Process Service (WAS) at the start of a working process for the application pool.

I get one of the above errors for each of the pools associated with SharePoint.

The SharePoint server is also a DC.

I have also noticed that after I manually restart the Application Pools, if I then try to visit "Intranet" (for example) that the application pool associated with that site immediatly stops.


On occasion, our SQL server becomes unavailable and I'd like to display a user friendly error page instead of the plain vanilla "Cannot connect to configuration database" page. Is this possible? I don't think that this page throws an HTTP exception so I'm not sure if IIS's customError config section will handle this condition or not. Any ideas?


Hey Everyone,

An interesting warning which has stumped me,

The identity of application pool SharePoint Central Administration v4 is invalid. The user name or password that is specified for the identity may be incorrect, or the user may not have batch logon rights. If the identity is not corrected, the application pool will be disabled when the application pool receives its first request. If batch logon rights are causing the problem, the identity in the IIS configuration store must be changed after rights have been granted before Windows Process Activation Service (WAS) can retry the logon. If the identity remains invalid after the first request for the application pool is processed, the application pool will be disabled. The data field contains the error number.

This is the error that follows, which makes sense given the above right?

Application pool SharePoint Central Administration v4 has been disabled. Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool.

Steps I have checked, Spfarm install account is part of the local admin group, password is correct has access in IIS_IUSRS, has access to database,runs the securiyttoken service which has started ok, still not sure what I am missing. It points to a problem with the account but cant figure it out.

Please can anyone help?

Thanks Matt


I'm receiving a 503 Service unavailable -error from a webservice when calling client is on WinServer 2003.

Scenario: Windows Forms (.NET 4) application calls remote webservice on windows server 2003 to fetch information.
In some cases it takes a long time for the WebService to get the informationa (long running database procedure) so the client waits for the response.
WebService timeouts are set at +30min.

The setup has worked fine for some time now but recently we discored that a particular long running request began to fail.
The Windows Forms client fails with a 503: Service Unavailable -error and ProtocolError after just a couple of minutes into waiting for the response.

We did some testing and this error occurs if the client application is installed on a Windows Server 2003 box.
If we do the same test with the client application installed on a Windows 7 box it works without errors.

It seems that it has something to do with Windows 2003 but how to debug this?
Anyone have any ideas what could be the problem?




Im having problems with my WSS. After installing it I'm not able to access the central admin and when I try to do so I get a 503 - service unavail. When I check the event log I get this message

"Programpoolen SharePoint Central Administration v3 har inaktiverats. Ett fel uppstod när tjänsten Windows Process Activation (WAS) startade den arbetarprocess som betjänar programpoolen SharePoint Central Administration v3." (loosely transelated; The Programpool in SharePoint C.A v3 has been disabled. An error occured when the service Windows Process Activation (WAS) started the workprocess that serves the programpool SharePoint C.A v3.)

With event id: 5059 and source: WAS.

I've already seen a few posts on the subject and what I've tried so far is:
* Disabled IPv6 and removed its hostfile entry
* Tripple checked the password and tried diffrent users under "Programpool - SharePoint C.A - advanced - identity"
* Reboot of machine and IIS7

I'm currently running Windows Server 2008 SP2 (32-bit) with WSS3 SP2.
I can start the programpool, but everytime I try to access SP C.A the pool stops and I get the "503".

Has any one got any suggestions?
Any help is welcome


I get this error when I attempt to access TFS from VS2010 or run http://localhost:8080/tfs/web 

#Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename
2011-01-09 05:36:03 ::1%0 2583 ::1%0 8080 HTTP/1.1 POST /tfs/TeamFoundation/Administration/v3.0/LocationService.asmx 503 - N/A -
2011-01-09 05:36:07 ::1%0 2584 ::1%0 8080 HTTP/1.1 POST /tfs/TeamFoundation/Administration/v3.0/LocationService.asmx 503 - N/A -
2011-01-09 05:42:58 ::1%0 2633 ::1%0 8080 HTTP/1.1 GET /tfs/web 503 - N/A -
2011-01-09 05:51:54 ::1%0 2739 ::1%0 8080 HTTP/1.1 GET / 503 - N/A -

I've pretty much gone through the blogs and configuration settings including the application pool, but have not been able to resolve this problem. Any suggestions would be greatly appreciated. From the numerous similar issues, it would be helpful to have a troubleshooting flowchart for TFS. Thanks.


In the SharePoint 2010 Central Administration I changed a service account and now I can't get back into the Central Admin site or the SharePoint site.  I get 503 Service Unavailable.

I ran the PSCONFIGUI but it did not fix the problem.

Is there a way to manually reset the services to default so I can get my site back up?


In the SharePoint 2010 Central Administration I changed a service account and now I can't get back into the Central Admin site or the SharePoint site.  I get 503 Service Unavailable.

I ran the PSCONFIGUI but it did not fix the problem.

Is there a way to manually reset the services to default so I can get my site back up?


Hello All,

I am very new to MDS world. Recently i have installed SQL Server 2008 R2 and configured MDS. But whenever i try to open MDS portal it giving error

'Cannot connect to the configuration database' and some times it giving error 'An unexpected error occured'.

I have logged in with Administrator account and i have admin access over MDS Configuration data base.

Please help me in this regard.


I know this has been a common issue in the past after updates, patches, SPs etc. Tried several of the online "cures" no luck. I've got a standalone instance of WSS 3.0. Anyone else with this issue after yesterday's updates? If so, any luck?




I tried re-running the configuration Wizard to no avail.  I can't even get to the Central Admin page.  When running the config wizard it tells me that it can't connect to the farm (it's a standalone install) and to disconnect from the farm to continue.  I disconnected from the farm and now it says that it can't get to the config database. 

Running psconfig -cmd upgrade -inplace b2b  and I get this error message:

No connection string to a WSS configuration database detected. 

I'm at a loss. 



I am very new to streaminsight. I have installed the streaminsight in my machine and I am trying to open evnts in event flow debugger. But I am getting following error. The remote server returned an error: (503) Server Unavailable ERROR.

Even if I refresh my server then also I am getting the same. Please can any one help me to resolve this issue.

Thanks & Regards,




I have a single-server server farm (WSS 3.0 and SQL Server 2005 on Windows Server 2008 R2). All 64-bit. We purchased a second server with much more storage with the intention of moving the SQL installation to the new server. I followed the instructions in the Move All Databases article (cc512723). After creating the SQL alias on the old server, restarting the WSS services and performing iisreset /start (and stopping the SQL services on the old server), I get a "Cannot Connect to Configuration Database" error in the browser.

The site is accessible again if I restarting the SQL services on the old server and removing the SQL alias (but of course, WSS is still pointed to the old SQL Server).

Researching this problem suggests that this is either security related or related to the SQL alias. With respect to the latter, there appears to be lots of confusion as to whether the alias should be set up using SQL Server Configuration Manager, cliconfg.exe, the 32-bit or 64-bit section of either utility, and where the setting is stored in the Registry. But if I use SQL Server Configuration Manager on the old server, configure the alias in the 64-bit section, and then test whether the redirection to the new server works by setting up an ODBC connection using the old server's name, the ODBC connection correctly points to the new SQL Server (the alias works). So I assume that the problem isn't with the alias.

That leaves security. I followed the instructions in the Move All Databases article and have verified that all the SQL logins exist on the new server and that the database permissions and fixed server roles are the same on both the old and new server. So I don't think the problem is with SQL security. That leaves WSS and IIS security. During the initial installation, I took mostly default settings during WSS setup--that resulted in using a domain account for the Central Administration Application Pool identity, but the NETWORK SERVICE for the SharePoint - 80 identity. That seems like it would work fine if the SQL Server is on the same machine as WSS, but not if they are on two different machines, which they would be after the move. But I don't have enough knowledge/experience to know whether that's even relevant with respect to the current problem.

The site is heavily used, so I can't afford to blindly change settings and hope the problem gets fixed. Any ideas?


Hi team,

I need to call SSRS 2008 via a web service in java, 

the report manager and report server is availible under IE, I can see my different reports and all, deduction that is the service is AVAILABLE!!

but when i call it from my ws the response is (503)Service Unavailable ... what means? is there some parameter to do?

my SSRS is local installation.

many thaks for any help or suggestion to fix this.




this question relates to using the Microsoft Translator Web Service (SOAP) API in a .NET application.

The application may perform a lot (possibly hundreds) of small translations in quick succession. In some cases, it aborts with:
Exception = System.Net.WebException
Description = The request failed with HTTP status 503: Service Unavailable.

Could this be the result of performing many requests in quick succession?

If so, is there a way to prevent it?

What is the best way to handle it?

By the way, my application is the Multi-Language Add-In for Visual Studio .NET. This is an Add-In to aid localization of .NET projects. I am using the Microsoft Translator to translate the texts in an application.

Thanks in advance,


The question says the default behavior for instancing service object is that each instance is associated with one user-defined service object, but in the book, 'MCTS Self Training Kit', it is said that the default behavior is PerCall.

Is this a bug in the practice exam?


I'm running a windows 2008 server with SP2007 and keep receiving 503 errors. I've tried a lot of the tricks reported on the site - app pools. However I have 0 luck. Everything was working fine until this morning and now it doesn't work. Any other suggestions?



I'm trying to connect to the PSI using wcf. I'm following the  Walkthrough: Developing PSI Applications Using WCF at http://msdn.microsoft.com/en-us/library/ee767691.aspx#pj14_DevelopingUsingWCF_CompleteCode and the "How to: Create a Proxy Assembly for WCF Services" at http://msdn.microsoft.com/en-us/library/ff621594.aspx#pj14_CreateProxyAssembly_Changes and "Prerequisites for WCF-Based Code Samples" at http://msdn.microsoft.com/en-us/library/ee872368.aspx.

In all cases when I use the psi url to add a reference to the wcf I get the following error:

There was an error downloading 'http://localhost:32843/psi/project.svc'.
The request failed with HTTP status 503: Service Unavailable.
Metadata contains a reference that cannot be resolved: 'http://localhost:32843/psi/project.svc'.
The HTTP service located at http://localhost:32843/psi/project.svc is too busy.
The remote server returned an error: (503) Server Unavailable.
If the service is defined in the current solution, try building the solution and adding the service reference again."

I've tried iisreset again, checking permissions (I'm using the administrator), using the asmx url but nothing helps.

What am I doing wrong?





<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure