Home » Microsoft TechnologiesRSS

Appfabric Caching Service fails to start

I've gone through the wizard to configure Appfabric caching.  I selected XML file and pointed to a share on the network.  The ClusterConfig.xml is created in the share and I see the first Node in there.  However, the Service itself never starts.  It is set to manual and fails to start with this error:

The AppFabric Caching Service service failed to start due to the following error:

A privilege that the service requires to function properly does not exist in the service account configuration. You may use the Services Microsoft Management Console (MMC) snap-in (services.msc) and the Local Security Settings MMC snap-in (secpol.msc) to view the service configuration and the account configuration.

This is the username that was logged on when the wizard ran.  it is an administrator and has 'Log On As A Service'.  I cannot use Network Service, which is the default because these nodes are not members of any domain.

 

7 Answers Found

 

Answer 1

Is this forum moderated or visited by the Appfabric team?  I can't believe that there are so many unanswered questions here.
 

Answer 2

I have the same issue over here.  I tried with my own administrator account  and it doesn't work.  Can we get the list of local  privileges the account must be granted to start  the service?
 

Answer 3

I can get the service  to start.  I had to add 'Act As Part Of Operating System' 'Generate Security Audits' and 'Bypass Traverse Checking'

 

Answer 4

Von,

Its good that you figured out the solution. This was mentioned in installation guide. Some details are here.

If your cluster machines are in workgroup you need to use Local User account  and this account must have the folliwing permisstions:

 Generate Security Audits, Bypass traverse checking, and Logon as a service

Grant the account this permission by using the Local Security Policy (Secpol.msc) tool, and moving to the following path: Secpol.msc, Security Settings, LocalPolicies, and User Rights Assignment. Add the account to each of the policies listed above.

Please refer to Installation Guide for more details.

Thanks

Shankar

 

Answer 5

I ve NetwrokService alreayd have all these perms in secpol .All I can see is this:-The AppFabric Caching service  service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service

 

Answer 6

Hi Shankar,

 

I am running cluster machine in Virtual Box in domain, by default service  is running under Network service , i am also receiving  same error

please find the error  details from error log  below. any help will be great.

 

Log Name:   System
Source:    Service Control Manager
Date:     21-07-2010 16:42:07
Event ID:   7034
Task Category: None
Level:     Error
Keywords:   Classic
User:     N/A
Computer:   
Description:
The AppFabric Caching Service service terminated unexpectedly. It has done this 5 time(s).
Event Xml:
<Eventxmlns="http://schemas.microsoft.com/win/2004/08/events/event"><System><ProviderName="Service Control Manager"Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}"EventSourceName="Service Control Manager"/><EventIDQualifiers="49152">7034</EventID><Version>0</Version><Level>2</Level><Task>0</Task><Opcode>0</Opcode><Keywords>0x80000000000000</Keywords><TimeCreatedSystemTime="2010-07-21T14:42:07.000Z"/><EventRecordID>13342</EventRecordID><Correlation/><ExecutionProcessID="0"ThreadID="0"/><Channel>System</Channel><Computer><Security/></System><EventData><DataName="param1">AppFabric Caching Service</Data><DataName="param2">5</Data></EventData></Event>

thanks

kazim

 

Answer 7

Can you also provide the event logs from the following location in the EventViewer?:

Application and services  logs -> Microsoft -> Application Server-System services

Thanks

Shankar

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter