Home » Windows OSRSS

Application File ADODB Version 7.0.3300.0

 

Unable to install or run the application. The application requires that assembly ADODB Version 7.0.3300.0 be installed in the Global Assembly Cache (GAC) first.  Please contact your system administrator.

 

I see a lot of traffic on this error message.  This file is included in my Application Files as Prerequisite Auto.  I guess lots of people get the above message. I got it in vs08 with the old report viewer control.

 

From what I read this file gets added to the Application Files list when you add the Report Viewer control. 

Does this problem still exist in the 2010 Report Viewer install?

 

I saw in some of the posts people started referencing this file in there applications and changing the  Publish Status to Include so it would show up with the other dlls and get installed as part of the app (http://nickmasao.wordpress.com/2008/12/11/reportviewercontrol-clickonce-deployment/).

 

What is the recommend approach for ClickOnce apps that use the 2010 Report Viewer control?

 

9 Answers Found

 

Answer 1

Hi chuck,

 

The error is caused by necessary prerequisite not get installed in the target machine. Please double check the prerequisite list. Is the “Microsoft Visual Studio 2010 Report Viewer” selected? If it is select, the proper reason might be it is installed failed on the target computer. Does the error occur on a special computer?

 

You can try to copy the bootstrapper package from “C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bootstrapper\Packages\ReportViewer” to the target computer to perform a manual install.

 

Please feel free to tell me if you meet any difficulties.

 

Sincerely,

Kira Qian

MSDN Subscriber Support in Forum

If you have any feedback on our support, please contact msdnmg@microsoft.com
 

Answer 2

So does the report viewer control install now properly install assembly ADODB Version 7.0.3300.0?   Or this still a bug?  From my reading seems that the full .net install would install it but the client install would not.  Seems weird that it still comes up as a Prerequisite Auto.


 

Answer 3

I have installed the full package of .NET Framework so ADODB.dll 7.0.3300.0 can be found in the GAC (C:\Windows\assembly). I don’t know if client profile will contain that.

 

Sincerely,

Kira Qian

MSDN Subscriber Support in Forum

If you have any feedback on our support, please contact msdnmg@microsoft.com

 

Answer 4

Yes that was the old issue I described earlier. I was hoping to know the root cause for the problem and whether it has been resolved in 2010
 

Answer 5

I don’t have clean machine to install .NET Framework client profile to see if the ADODB.dll 7.0.3300.0 is included. So if it is missing based on your test, what about select Microsoft Visual Studio 2010 Report Viewer? Does the dll get installed? If it is still missing, that seems to be an unfixed issue. You can submit Microsoft Connect to report it.

 

Sincerely,

Kira Qian

MSDN Subscriber Support in Forum

If you have any feedback on our support, please contact msdnmg@microsoft.com
 

Answer 6

Was this problem fixed in 2010?
 

Answer 7

What is fixed mean? Do you mean the .NET 4.0 Client Profile should contain “ADODB.dll 7.0.3300.0”? I am sure .NET 4.0 Framework contains ADODB.dll 7.0.3300.0. But I don’t have XP to do the test. Sorry for the inconvenience.

 

Sincerely,

Kira Qian

MSDN Subscriber Support in Forum

If you have any feedback on our support, please contact msdnmg@microsoft.com
 

Answer 8

Sorry to have wasted your time.

 

 

Answer 9

http://social.msdn.microsoft.com/Forums/en-US/vsreportcontrols/thread/00c89a1c-1fcc-49a0-932a-29b2428b2ad4

http://joewirtley.blogspot.com/2007/07/clickonce-and-bogus-required-assemblies.html

 

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter