Home » Microsoft Technologies

Where to complain for Microsoft support?

I've been tired of a technical support case. The case opened in November last year. The issue never been resolved because of the lack of knowledge of the support technicians (related Certificate Authority and EFS). They hardly answer my qurey of status. They hardly kept their promiss to call me back. There were no any improvement after complaining to their manager. Microsoft support has been getting worse after offshore. Most of support technicians have no hands-on experiences. I really stuck in the paid support case. Anyone know where should I go? Great appreciate for any information.


11 Answers Found


Answer 1

Hi Halchen.  Do you have an SRX number for your case?




Answer 2


Eventually, someone called me back  last week. He sent me an article, that seemed explaining the issue  I had very clearly. Now, I started a new question. Why so many support  engineers (they stated they were top level Microsoft support engineers when I asked to escalate the case) were not be able to tell me at first place? Although I had opened  my environment to let them access anything here to get information  needed, it took months to find out something simply on Microsoft article.


Answer 3

since november  2006 when my xbox first stopped working i have been trying to deal with the australian service centre with no result it is now 2008 and still i dont have a working xbox, i have sent it to the service centre 5 times and still they can't give me a working model, i have had 2 B grade replacement's which dont work longer than 2 week's.

i am fed up and dissapointed that a microsoft  company could display this level of failure to a customer, please foward this message to whoever you can in the hope that some one will listen and fix these problem's in australia.


Answer 4

if ur xbox has been sent for repair 5 or more time, u can get a free xbox 360 elite. thats what happened to my friend

Answer 5

Do you have an SRX number?


Answer 6

halchen wrote:

I've been tired  of a technical support  case. The case  opened in November last year. The issue  never been resolved  because of the lack  of knowledge  of the support technicians (related Certificate Authority and EFS). They hardly answer  my qurey of status. They hardly kept their promiss to call  me back. There were no any improvement  after complaining to their manager. microsoft  support has been getting worse after offshore. Most of support technicians have no hands-on  experiences. I really stuck  in the paid  support case. Anyone know where should I go? Great appreciate for any information.

Don't let this get you down, You can get what you want.


cute kitten names | black cat names


Answer 7

hey Kim that's really good (not)

How about advising on 2 things, namely

1: What the hell an SRX number is

2: Where do you go about getting one ?

Whatever the MS product, if the comsumer has a grievance or complaint for a multi national organization it MUST have a clear & transparent complaints process. And regulated by an independant arbitrator should the parties fail to resolve their differences.

It's no good sending out emails with loaded footers advising "please do not reply to the sender" and the like.

Not good enough. Sort it out MS, and you too KW


Answer 8

well i have never imagined waiting for a year  for a working 360,that deserves a lawsuit or something extravigant like that, but i sent in mine and have been waiting over a month. I called them a few days ago and they said that they cant find my 360, but 2 weeks before that, a foreigner that barely knew English told me that they have already received my 360. i'm hoping to expect it in the mail soon but i think that with all the ____ that bill gates has (money), that he should at least hire some Americans who know what their doing at an office desk and can handle people and a cheap, China-made product made by microsoft  themselves. appearantly they lost mine completely because their sending me a brand knew one. I am afraid to send in anything to them now........this is sad. They give you a "complimentary gift with it supposabley, a one month free trial, and ive lost out on about 9 days. I should be getting more for my hard times, like some microsoft points or something, but obviousely a lot of people seem to be having even more difficult issues with microsoft which is completely obsurd. Thank you for reading and i hope microsoft does something about these fatile errors in their system.

Answer 9

juggalo 330 said:

... i think that with all the ____ that bill gates has (money)

To be fair, Bill retired from microsoft  and Steve Ballmer is the CEO.

dejavu59 said:

1: What the hell an SRX number is

2: Where do you go about getting one ?

1: An SRX number is the Service Request Number assigned to your support  incident.

2: It is assigned immediately after you file a complaint/incident. Typically the support representative gives it to you while on the phone. You can also call  and get it if you do not have it or have forgotten it.

dejavu59 said:

Whatever the MS product, if the comsumer has a grievance or complaint for a multi national organization it MUST have a clear & transparent complaints process. And regulated by an independant arbitrator should the parties fail to resolve their differences.

It's no good sending out emails with loaded footers advising "please do not reply to the sender" and the like.

Not good enough. Sort it out MS, and you too KW

As for the complaint process, you can always let them know.

For sending out emails with the disclaimer to not reply is a part of the complaints process. Even in a clear and transparent complaint process, you cannot have the customer contacting whom ever they please. Typcially there is a structured/tiered approach to solving the issue  that you must go through.

Also, don't hate on Kim for trying to help. This is the MSDN forum for support on the MSDN website itself. This request doesn't even belong here. It would typcially be posted here or here.



Answer 10

i dont think whether Bill has retired and Balmer has taken over, the crux remains that the problem is not being solved...it is difficult to understand that you are facing this problem from Microsoft!!! which has best of the team and staff from all over the world
Local Search

Answer 11

You can go to http://microsoftshit.com to complain


Is Microsoft Windows 2008 R2 supported Operating Systems for application written using Microsoft Unified Communications Managed API 2.0.?





when I do

select * from document

where contains(text,'joeblow(atsign)yahoo.com') is complains about the first left parenthesis.





My debug engine seems to be installed because when I open Attach to Process I see my engine in the list of engines available. I've followed this post and all the registry entries are there: http://social.msdn.microsoft.com/Forums/en-US/vsx/thread/11a3fb55-f3bc-45b2-a5c0-d80c69846802/

I think my engine is registered via COM correctly but it appears in the 64 bit registry. Does it need to be in the Wow3264Node?

I never hit a break point in my debug engine so I think I must be missing a registration detail. Any ideas?

i installed the newest Windows Live Sync beta suite, when i tried to run window live messenger ,it tells me ”The program can't start because wlidcli.dll is missing from your compuer!", then i tried to restort to the old version ,but it can't run either now . my system is windows 7 x64 EN, does anyone know how to resolve this problem?


I keep getting the following a couple times when I am running the emulator is there a fix for this? (Configuration: Windows 7 Professional / Visual Studio 2010 Professional) Note: the emulator does infact run and work it is more of an annoyance than anything but would love to know a fix thanks.


Target:  C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe
Event Info:  Set Information Process
Action Taken:  Logged
Actor Process:  C:\Program Files\Microsoft XDE\1.0\XDE.exe (PID 2688)




Pex keeps flunking out methods as not checking for null values for parameters when Code Contracts are employed to check for null parameter values.


  /// <summary>
  /// Bit shifts the enum bit pattern leftward.
  /// </summary>
  /// <param name="bitPattern"></param>
  /// <param name="timesToShift">The number of times to shift the bit pattern.</param>
  /// <returns></returns>
  /// <seealso cref="http&#58;//msdn.microsoft.com/en-us/library/a1sway8w.aspx"/>
  public static Enum
  BitShiftLeft(this Enum bitPattern, int timesToShift) {
   Contract.Requires(bitPattern != default(Enum));
   Contract.Requires(EnumFlagsUtilities.DoesEnumHaveFlagsAttribute(bitPattern), ErrorMessageUtils.EnumNotAFlagsEnumMessage);

   int enumAsAnInt = Convert.ToInt32(bitPattern);
   enumAsAnInt <<= timesToShift;
   Enum result = (Enum)Convert.ChangeType(enumAsAnInt, bitPattern.GetType());

   return result;

When run on the project containing this example code, Pex will complain that it can generate a ContractException by sending in a null value for the bitPattern parameter. The thing is, I declare this to be exactly what will happen if a user attempts to do this by declaring a Contract requiring that bitpattern != default(Enum)!
I want to alter the column which is returned as [value] during the stored procedure call.

        CASE @name_bpd
            WHEN 'STRING' THEN [value_string_bpb]
            WHEN 'INTEGER' THEN [value_int_bpb]
            WHEN 'BOOLEAN' THEN [value_bool_bpb]
        END [value],
        @name_bpd as [type],
        [id_bpb] as [id]
        [idbpc_bpb] = @property_id
        [sort_index_bpb] ASC;

I am getting the following error:

Conversion failed when converting the varchar value 'test' to data type int.



In november i was attending a 5 day system center course in Manhattan.

The facillities was used by other training companies, and my impression of the place was that it was very filty and low budget. The course administration was placed another state. I know that we all have different ideas of good standard but in my 18 years professional IT i have not seen anything like this. I have even attended 2 courses in Thailand, and the standard here was ten times better.

See the facillities here  http://www.youtube.com/watch?v=_e0OsRyniRk

There was hardly any heat in the room We where located on the 29th floor but the traffic noice was so loud. Even though the windows was closed the curtains was moving due to bad isolations. First when i arrived into the room i thought the windows was open - that much noice was there from the street. The "official" course material was missing so we had to use a copied version. After continius complains to the main office we got our own personal pdf file. (i think that the training provider tried to save the money by letting us use a copied version) We found it very irritatin that the classroom computer where we did the LAB exercise and the course material was on the same computer. - we had to toggle back and forth every time we did a LAB exercise. The internet connection, was a shared < 1-2 mbit line and was very unstable. We had often no connectivities. And all LAB servers was located in the administration building in another state. It was so annoying and tome consuming that we simply gave up doing some of the LABS. We did not get our course diploma at the end (i have yet not recieved it). We did not get one single demonstration - as according to course material. We where not provided with any coffee snack or water - we had to pay for coffee since it was a shared facillity. The instructor was basiclly chanting directly from the course material

I did compain to the instructor, and he said that he was a freelancer, and he knew about the bad standard, but he could not do anything. I allso complian to the main office, and they said the noice was to expect in manhattan and the internet they replied :

"As far as the internet connections are concerned, we are at the mercy of the landlord and internet providers. In Secaucus, NJ the landlord does not allow telephone poles, and we are 11,000 feet from the central office, so DSL is our only connectivity alternative and it is unstable based on the distance from the CO"

Now the question, is it me who demads to much or should i complain to Microsoft and does this help, should i demand a refund?

I certainly have never tried anything like this, and i hope that no one would experience the same.



I'm installing the VS2010 Test Agent on a clean Win7 Enterprise x64 VM. There is no VS2010 IDE SKU installed. During the Agent Configuration Wizard (which runs as Admin by default), no matter if I choose Service or Interactive, set my settings and Apply... I get the following error:


[ok] Validated user name and password

[err] Failed to open the Visual Studio v10.0 registry key. Ensure that test agent is installed that the config utility has the required permissions to access and modify the registry


E, 2011/01/18, 09:44:43.832, Got Exception : Microsoft.VisualStudio.TestTools.ConfigCore.ConfigToolException: Failed to open the Visual Studio v10.0 registry key. Ensure that test agent is installed that the config utility has the required permissions to access and modify the registry.
   at Microsoft.VisualStudio.TestTools.ConfigCore.TestAgentHelper.AddSetting(RegistryKey registryHive, String settingName, String settingValue)
   at Microsoft.VisualStudio.TestTools.ConfigCore.TestAgentHelper.AddSetting(String settingName, String settingValue)
   at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.Configure(AgentConfigurationUpdatePack updatePack, DelegateStatusUpdate statusListener)
   at Microsoft.VisualStudio.TestTools.AgentConfigUI.AgentConfigUI.ConfigureWorker_DoWork(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
I, 2011/01/18, 09:44:43.832, Work completed for GetConfiguration() call : got out of turn error
E, 2011/01/18, 09:44:43.833, Failed to open the Visual Studio v10.0 registry key. Ensure that test agent is installed that the config utility has the required permissions to access and modify the registry.


I've searched MSDN articles, the net, this forum and cannot find a reference to this particular issue. Can anyone tell me what the problem is? Thanks!

UPDATE : I used ProcessMon to watch what was happening at the moment I clicked "Apply Settings" and found this: 
RegOpenKey     HKLM\Software\Microsoft\VisualStudio\10.0    NAME NOT FOUND   Desired Access: Read/Write

It is indeed not there, but where it DOES exist is  HKLM\Software\Wow6432Node\Microsoft\VisualStudio\10.0


I know Frontpage went away years ago replaced by Expression Web, but now my main hosting company claims no more new websites with Frontpage Extensions, even if on a Windows Server. I like to use Visual Web Developer 2008 but wonder now what do I do?

Go back to FTP and keep a local copy and upload/dowload? I hope not...that's why I started to use Frontpage 97 years ago. The guy at Network Solutions suggested I use Dreamweaver and I laughed and don't want to change or use anything else except Microsoft products.

What are my options to edit live and connect to websites with no Frontpage extensions? Is Network Solutions nuts? I see a lot of new Windows 2008 servers out there advertising with Frontpage extensions on them for new hosting.


I would like to explore the options available for setting up the DR solution for very Large SQL Server databases. We are thinking of configuring the EMC SRDF replication OR Netapp  replication in synchronize mode by using DWDM link. One of our biggest databases is running on Netapp snap mirror in asynchronous mode with 15 minute delays of transferring the data.

My question is to find out, is the synchronous Netapp or SRDF replication supported by Microsoft SQL server 2008? If yes, could you please provide me more details about the articles or any other relevant documents?




There are some pre-built Robot Support for Robotic studio  , As Some books mentioned ,

we may use other Robotic hardware by Designing An interface for that hardware in MSRDS .

what kind of hardwares Microsoft Robotic Studio Can support ? Can We Use our own Robot

Hardware with Robotic Studio ?

This hack does not work. I made the changes as identified and the system will still accept the a PW of less than 8 char.

Please provide a suggestion

Microsoft doc
Setup strong password policy in Windows XP

Windows Registry Editor Version 5.00



We are a Microsoft Gold ISV Partner and wanted to know, is it possible to obtain paid support direct from microsoft to help us identify a memory issue with our Windows Mobile 6.1 application?




I created a WCF Service Library and added some functionality to access my SharePoint site and edit a list. The project framework is set to .NET 3.5 and the target platform is x64. I'm able to start the Service Library and the WCF Test Client starts just fine. When I invoke my need method I get the following errormessage:

Microsoft SharePoint is not supported by .NET Runtime 4.0.30319.1.

I don't have a clue where .NET 4 is activated!? As I already mentioned the WCF Service Library is .NET 3.5 (not client profile, the real one). Thanks in advance


The Visual C++ 2005 Service Pack 1 Redistributable Package list windows 7 as a supported OS.


The updated version of this package "Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update" does not.


Was support for Win 7 dropped or is this a documentation oversight? I find it hard to belive that the updated version released a year later no longer supports Win 7. Company policy does not allow installation of unsupported software and this package is required. Who would I contact to get the download page updated with a listing for Win 7 support(if it is indeed supported)? 





I wanted to establish a SVC service quickly without setting and configuring all of the bindings.  So I found a website which recommended me to use the


In other words: If a place this command in the .svc file.  I do not have to setup the webconfig file or any wiring (and my jquery web service call works perfectly).  But If I go and test the client in the Microsoft WCF client it does not work.

HERE IS THE COMMAND in the .svc file.


<%@ ServiceHost Language="VB" Debug="true" Service="ScormTest" CodeBehind="~/App_Code/ScormTest.vb" Factory="System.ServiceModel.Activation.WebScriptServiceHostFactory"%>


When I take out [Factory="System.ServiceModel.Activation.WebScriptServiceHostFactory] the WCF client picks it up but my jquery breaks.

When i place it back in Factory="System.ServiceModel.Activation.WebScriptServiceHostFactory the WCF CLIENT SAYS IT SUCCESSFULLY ADDED THE SERVICE BUT NOTHING APPEARS. 








MICROSOFT WCF TEST CLIENT VERSION 10.0.30319.1 (RTMRel.030319-0100)

MICROSOFT WCF TEST CLIENT VERSION 9.0.622.1152 (SP.030729-0100)





wcf test client .net framework 4 2010




If you have an Access 2007 database that's been split into a front-end and back-end design, what OS does Microsoft support for "hosting" the back-end database file?  The system is very small with two Windows 7 PC's on a hard-wired GigE network. 


Hi all,

I cannot find the details about the support life cycle of Microsoft .Net Framework 3.5 SP1 on Microsoft Support web site.  Please help.  Thanks.


Microsoft SQL Server 2005 Express
Windows XP service pack 3

When trying to install Microsoft SQL server 2005 Express following error keeps coming up:
Error 1603 installing Microsoft SQL Server 2005 Setup Support Files

Below is from the log:
MSI (s) (98:F8) [15:11:00:015]: Note: 1: 1708
MSI (s) (98:F8) [15:11:00:015]: Product: Microsoft SQL Server Setup Support Files (English) -- Installation failed.

MSI (s) (98:F8) [15:11:00:015]: Cleaning up uninstalled install packages, if any exist
MSI (s) (98:F8) [15:11:00:015]: MainEngineThread is returning 1603
MSI (s) (98:9C) [15:11:00:125]: Destroying RemoteAPI object.
MSI (s) (98:D0) [15:11:00:125]: Custom Action Manager thread ending.
=== Logging stopped: 18/08/2010  15:11:00 ===
MSI (c) (B8:10) [15:11:00:125]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (B8:10) [15:11:00:125]: MainEngineThread is returning 1603
=== Verbose logging stopped: 18/08/2010  15:11:00 ===

Looks like some entries in the registry database are left even after uninstalling using the Add/Remove programs. so I have tried to remove the following manually after having used Addemove software:
* C:\Program Files\Microsoft SQL Server
* "The Microsoft SQL Server" key (and all its sub-keys) under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
* All keys related to SQL Server under HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001
* All keys related to SQL Server under HKEY_LOCAL_MACHINE\SYSTEM\ControlSet004

Still get the error.

I know that Error 1603 has been posted before in this forum but I don't seem to find the solution for this problem in the answers (maybe I am missing something).

Any suggestions will be very much appreciated.

Thanks in advance


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure