Home » Visual Studio

connection problem SCVMM Admin Console with Virtual Machine Manager

Hi, on virtual machine where is installed TFS 2010 rtm I've installed SCVMM and Admin Console as shown in the video: Video 1 - Setup and Configure Lab Managementfrom http://blogs.msdn.com/b/lab_management/archive/2010/02/11/visual-studio-lab-management-videos.aspx .But when after installaion I'm running SCVMM Admin Console, enter: "labvmm:8100" always I have got:

"VMM is unable to connect to the Virtual Machine Manager server labvmm because the specified computer name could not be resolved.

Close and then reopen the Virtual Machine Manager Administrator Console, and then try the operation again. If the problem persists, contact your network administrator.

ID: 1601"

What could be a problem?


7 Answers Found


Answer 1


Here are a couple of things to try:

Make sure the SCVMM Service is running on the SVCMM host Make sure that the machine  named labvmm can be resolved correctly (try running nslookup labvmm from a command prompt) If you are running the SCVMM client locally try using localhost and see if that works If you are running the SCVMM client remotely make sure that there's no firewall blocking port 8100 on the SCVMM server



Answer 2

After some time, "localhost" started work (with labvmm still doesn't work). So, now, when I configuring Lab Manager. What I have to write down in "SCVMM Server Name (FQDN)"?  labvmm.lab.cos.it doesn't work. What should I do now?

Answer 3

It sounds like an issue with the DNS settings. Have you tried running nslookup?

Answer 4

What I verify by this? And how can I check it?

Otherwise, the following error occerred when I enter full comuter name in SCVMM Server Name (FQDN): "TF255848: You have chosen to configure 'Full name' as your Team Foundation Server and System center Virtual Machine Manager Server. To enable Lab Manager on this setup you need  to change the Team Foundation Server's service account from 'NT AUTHORITY\NETWORK SERVICE' to valid domain account"


Answer 5

I've read that the first step after configured SCVMM is to grant the TFS service user permissions to administer VMM (the TFS service account should be NT Authority\NetworkService). But in my case in VMM Administrator -> Administration -> User Roles -> Admnistrator I connot add new members 'TFSService'. there is not it..

Answer 6

What I was after was to verify that you have connectivity between the machines and that the name lookup works properly. As for the account you can change the TFS service account in the Team Foundation Admin Console.

Have you gone through the setup guide: http://msdn.microsoft.com/en-us/library/dd380687.aspx? If not I recommend you step through it and see if there's something you missed.


Answer 7

Yes, but I installed  SCVMM on virtual  macheine so I connont Set Up and Configure Hyper-V Hosts there. I thought besides this, installation SCVMMM on virtual machine  is the same. Whether there areother steps??


HI, I've installed SCVMM on virtual machine (where is installed and configured tfs 2010 rtm) then I've installed there SCVMM Admin Console, added host and now I connot configure Lab manage in TFS Configuration Console. When I enter full comuter name in SCVMM Server Name (FQDN) I get the following error:

"TF255848: You have chosen to configure 'Full name' as your Team Foundation Server and System center Virtual Machine Manager Server. To enable Lab Manager on this setup you need  to change the Team Foundation Server's service account from 'NT AUTHORITY\NETWORK SERVICE' to valid domain account"

What is wrong? Maybe I need to do other custom steps when install SCVMM on Virtual Machine?




we have tfs instaled in our domain. tfs is installled inside virtual maschin. on this tfs is installed SCVMM and configured lab manager. all work ok.

now we have task to install second TFS for testing purposes in the same configuration. (tfs_server,SCVMM,Lab manager). i wonder if we can do this? New SCVMM is also integrating with domain. I dont want to make any poroblems in our network and look for advise. all tfs servers are in thesame domain.

we use tfs 2010 rtm.

Does anyone know how to resolve this?  I've installed and reinstalled Virtual PC 2007 SP 1` multiple times.  The result is always the same.

The settings for virtual machine "VisualStudio2010CTP" can't be opened because the virtual machine is in-use by another program, or marked as read-only.

Neither case is true.

OS is Windows Server 2008 Standard SP1.  Virtual PC does not recognize the OS.
Is it possible to installation SCVMM and configuration Lab Management if my TFS is installed on virtual machine. How can I do it?
Hi, I think I have a problem, because during I was installing Virtual Machine Manager Server (on the same machine where is installed TFS and SQL Server 2008) to configure the MS Lab Manager, in tab "SQL Server settings" I chose SQL Express version, as below:

and now I think it could be problem if, for example, added videos by Lab Manager will exceed the amount of space as is available in the SQL Express database.

So, canI nowchangeto the existingdatabase (used by TFS)? And whatwith already addedattachments,is away tomove them?


Thank you in advanced for any help!



I have a SQL Server 2005 box that was moved from a domain environment to a non-domain environment and was never dropped from its original domain before moving over.  Subsequently a new domain was created at the data center this SQL Server box now resides in.  The machine was dropped from its old domain and joined to the new one.

All the while the service accounts were set to the local admin account.  When I tried to start the Configuration Manager I got the message "Connection to target machine could not be made in a timely fashion.".  I read some blog entries and tried changing all the service accounts to Local System and the error message still came up.

All of the SQL Server services run fine.  It is just this management console that I cannot open.  I wasn't with this employer when this box was moved to the data center so I do not know if it worked prior and there isn't anyone here that could give me its history.

Any help would be appreciated.


I have deployed my packages into Sql Server and I am using Configuration File. As my Data Source is Excel, I have changed the connection string during deployment with Server Path. But I am getting the following errors. Actually the File Exist in Path. May I know What is cause of the issue? Do I need to give any permission to execute the package.

SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER.  The AcquireConnection method call to the connection manager "Excel Connection Manager" failed with error code 0xC0202009.  There may be error messages posted before this with more information on why the AcquireConnection method call failed. 

component "Excel Source Service Contract Upload" (1) failed validation and returned error code 0xC020801C. 

One or more component failed validation. 

There were errors during task validation. 

DTS_E_OLEDBERROR, Error Code: 0x80004005 Source: "MS JET DB Engine" Description : Path is not valid


I've done a search and the only thread I found that contained this error code was for a demo setup. Anyway, I'm trying to use Lab Center (bundled with Test Manager 2010) to create a new Environment that contains a single Hyper-V machine and deploy that Environment to a Host. I've got the environment setup and in a "Stored" status, but when I go to deploy the environment, I get the following error message:

TF259115: Team Foundation Server could not find any suitable host to deploy the virtual machine: [VIRTUAL MACHINE NAME].

Contact your administrator to fix the issues on the hosts below. (Hosts are listed in brackets)

1. Unable to find a suitable host to place virtual machine(s). SCVMM returned the following error code: 1059610, and detailed message: The network adapter associated with network location VSLM Network Location on host [HOST MACHINE NAME] is not connected. ([HOST MACHINE NAME])

This is not for a demo/test set up. I've looked at the network adapters, in SCVMM, and it looks to be ok, but something just isn't lining up and doesn't allow the Hyper-V machine to be deployed. 

Any ideas would be helpful.

I have a problem where I open an HTTP connection to listen to messages as they are published on Twitter. However, when I call HttpWebResponse.Close() to disconnect, the method will not return and the application freezes. Any input on what the reason for this behaviour might be or suggestions on how to debug this problem would be most helpful.

I am running Visual Studio 2010 under Windows 7 hosted in a virtual machine (VMWare) running on Mac OSX. When I run the same code directly in OSX (using Mono) it works perfectly, but with Mono under Windows (still the virtual machine) the problem remains. This leads me to believe that the problem is somehow related to the virtual machine, but I have no idea how to approach it.

string track = "track=stuff,to,track";

HttpWebRequest webRequest = (HttpWebRequest)WebRequest.Create("http://stream.twitter.com/1/statuses/filter.json");
webRequest.Method = "POST";
webRequest.Credentials = new NetworkCredential("username", "password");
webRequest.ContentType = "application/x-www-form-urlencoded";
webRequest.ContentLength = track.Length;

using (StreamWriter sw = new StreamWriter(webRequest.GetRequestStream(), System.Text.Encoding.ASCII))

HttpWebResponse webResponse = (HttpWebResponse)webRequest.GetResponse();
StreamReader streamReader = new StreamReader(webResponse.GetResponseStream());
DateTime startTime = DateTime.Now;
Char[] readChars = new Char[256];
while ((DateTime.Now - startTime).TotalSeconds < 30) //listen for 30 seconds
  string streamContent = streamReader.ReadLine();
  //do stuff

//streamReader.Close(); //also freezes

I have a working Linux Virtual Machine but when I try to use it with Lab Centre it is complaining that the virtual machine does not meet networking requirements.


I'm trying to write a package that imports a bunch of Excel files into a sql server table. My import routine works fine when I do not use a foreach loop container. I then add a Foreach Loop Container with a Foreach File Enumerator and create a variable to store all of the excel file names to use with my excel connection manager in the connection string property.

 When I run the debugger I get the following error:

TITLE: Package Validation Error


Package Validation Error



Error at Import New Data [My Data (Excel) [4234]]: The AcquireConnection method call to the connection manager "Excel Connection Manager" failed with error code 0xC0202009.

Error at Import New Data [DTS.Pipeline]: component "My Data (Excel)" (4234) failed validation and returned error code 0xC020801C.

Error at Import New Data [DTS.Pipeline]: One or more component failed validation.

Error at Import New Data: There were errors during task validation.

Error at ImportMyData [Connection manager "Excel Connection Manager"]: An OLE DB error has occurred. Error code: 0x80040E4D.


I've read the varous posts on this forum and others with people having this problem and nothing that was recommended to them works for me. I've also read the  Msdn article 'How to:Loop through Excel files and Tables' and followed the directions there without success. I've tried the following with no success:

I've tried to create first a hard coded connection string in the excel conn. manager which works but as soon as I set the experessions: connection string property = my file enumerator variable it breaks.

Turned the Delay Validation to True for the package as well as the task

Set the Connection string equal to not just the variable coming from the file enumerator but to the full connection string : "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + @[User::excel_filename]  + ";Extended Properties=\"Excel 8.0;HDR=YES\";"

I've also tried to set the excel filepath property instead of the connection string and this didn't work either.

I'm getting really frustrated. Any advice on why something so simple doesn't work for me would be appreciated.




I am building a package that has 2 tasks that need to use the same excel connection manager. I use a execute sql task to dynamically build a table from the headers of the excel sheet  ,then I use an excel source component to load the data from the sheet. However when I try to edit the excel source and switch the data access mode to a variable and select the variable(for the path), when I try to close the editor I get this message

'S:\myfolder'.  It is already opened exclusively by another user, or you need permission to view its data.

I need this package to access the same folder each time because the files will be placed in that folder.

This package also has a branch for loading a text file into sql server. It access the same folder but uses a flatfile connection manager

It looks like permissions on the folder are correct


I'm having an issue with the EnterpriseOne adapter in Biztalk 2009 - I'm getting error when I send a message to JDE.

The error is: Error transmitting message: No connection could be made because the target machine actively refused it

This seems to be the same error described in these topics:



Neither of them have been solved

Any one have any ideas?




Hi need help is there any connection manager in SSIS to connect to Report manger URL..

For example if i upload a Excel file in Report Manger..is there any way to connect the SSIS package to that Excel file in Report Mnager



I've had the misfortunate to install .Net 3.5 SP1, due to a requirement of another product, on our CCF server which is running CCF 2009 SP 1 and now I'm struggling to get the admin console to load up again.

I'm following the advice in the KB 969803, but

a) its a bit wooly, like update your CCFInstructure database, table names would be nice :)

b) I've already done a lot of the steps in the first place. When I built the machine I created an alias for the CCF Server and I setup the SPN using this alias, and installed using this Alias. So everything I have already done already points to an alias.

Do I just need to create another alias and change everything to use that instead (I don't really want 2 alias to the one machine)? Or is there something that I have missed?

I'm pulling my hair out here.




Hi gang,

I've got a BizTalk Server 2009 production server running on Windows 2008 in a virtual environment (VMWare ESX) with SCOM 2007 installed. A strange MMC quirk has recently started happening on the environment. When I try to access the environment through the Admin Console, the snap-in appears to hang when I try to expand the BizTalk Group root node. CPU resources aren't getting consumed, at least on the server, and the database server appears normal (though I've done nothing to look for database locks or anything else). This is a single-server environment, with one BizTalk server talking to one SQL Server database instance. The only other thing that seems abnormal is that one of the SCOM 2007 scripts (BizTalkObjectMonitor.vbs) is giving repeated warnings that it's timing out in the Event Log.

Anyone run into this before?



Hi everyone,

For some weeks my admin console has become slower and slower to open, the last days it took up to 2 minutes. Actually, the console opens very fast, this was the first connection to a group that was very slow. Another symptom of this problem was a CPU close to 95% and variations of memory from 70'000 to 125'000 K during this time.

The issue was that the Console config file was probably corrupted. It is stored in C:\Documents and Settings\%username%\Local Settings\Application Data\Microsoft Corporation\Microsoft BizTalk Server 2006 ; the path is probably similar for other versions of Biztalk. In my context, Microsoft.BizTalk.Administration.SnapIn.dll.config was >1.5MB, and there were a few other files in there, some of them larger than 1 MB. These files were named some.newcfg and somecode.tmp, e.g. o7fweuub.newcfg and o7fweuub.tmp.

I have no idea where these files come from (import, export, deployment ?). But when I droped the folder and reopened the console, then it took less than 2 seconds to connect to the group.

Hope this tip will be useful for someone.



I'm trying to give some users read rights on the central admin console but they do always have the Access Denied. I already gave them full control on their web app but now they need only to look on the settings in the central admin console.



I have defined GPRS, 3G connection in Windows Mobile 6.1 Professional (HTC Touch HD T8282). When I turn on this connection using Windows Communication Manager , connection subtype returned by ConnMgrQueryDetailedStatus() function is CM_CONNSUBTYPE_CELLULAR_UMTS . When I turn on this connection using Connection Manager in my WM5 C++ application, connection subtype returned by ConnMgrQueryDetailedStatus() function is CM_CONNSUBTYPE_CELLULAR_HSDPA . Could you tell me how to connect using Connection Manager , to get UMTS connection?


I am setting up a new installation of TFS 2010. When I attempt to add a SharePoint application I get an error message; on checking the logs the following exception is detailed "TF30063: You are not authorized to access http://my.site.com/_vti_bin/TeamFoundationIntegrationService.asmx".

I have two separate servers; both running Windows Server 2008 R2. One hosts SharePoint Foundation 2010, the other TFS 2010. The SP server has TFS Extension installed and configured. I have also added the TFS Service account as a site collection administrator.

I have seen numerous posts detailing similar issues, none of the solutions have sufficed.

I am able to browse to the TeamFoundationIntegrationService.asmx definition using either the TFS service account or my logged in administrator account from the TFS box.

Obviously I am missing something?




<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure