Home » Microsoft TechnologiesRSS

crash: clr20r3 system.invalidoperationexception

Hello!

I've got some trouble running my application on other computers. On my own it works fine (no errors while Debug or Build/Publish) but if I install it on other computers (with .NET Framework 2.0 installed on them, but no Visual Studio) it crashes after the splash screen and gives the following error:

EventType : clr20r3     P1 : winlab.exe     P2 : 1.0.0.0     P3 : 44ce7687    
P4 : winlab     P5 : 1.0.0.0     P6 : 44ce7687     P7 : d     P8 : c6    
P9 : system.invalidoperationexception

My application uses a 3rd party user control (I dont't have the source code), I think it might cause the crash, but I'm not quite sure.

Can anyone help me with this? Thanks!

 

7 Answers Found

 

Answer 1

Is it possible to create a simple windows application - create a deployment package and try this to determine if its any .NET 2.0 application that wont work, or just this one....

Then simply add the suspect 3rd party control into this project and try again and see if this works.

 

Answer 2

So here it is - i've been using a "scientific method" :-) to exclude all the other possibilities: I have

1) created a simple application using just one form with a TextBox, a Label and a Button -
It worked fine on another computer

2) created a simple application wich includes the UserControl in question -
worked fine on mine, but it crahed on another computer

3) created a simple application using a simple User Control (I've got the source - it does't do anything complicated) -
worked fine on mine, and on the other computer.

Now we can say that the User Control in question is responsible for my hedache. But what could explain, that it works flawless on my computer but not on another?

Is there a way I can bypass this error?

 

Answer 3

is it an ActiveX control (COM)? If so, it may not be registered. I guess you may need to go to the supplier of the control with a big stick.
 

Answer 4

Yeah, it is an AciveX control allright... Guess I'll have to try to reproduce its functions with a replacement code of my own... That's going to take some time... but... such is life.

But if anyone knows any better and be so kind to share...

 

Answer 5

Not necssarily (but it probably would be a good idea ). It is likely that the control is not registered on the target system  (use Regsvr32 to register it).

OneClick distribution doesn't give you the option of registering additional controls this way. But you first need to prove the concept - i.e. that your program will work by manually copying/registering eveything. Then, if you still want to use the control, either use a third party installer or upgrae to Visual Studio and use the Setup projects (I don't really have a lot of experience with those - personally I use a no-cost installer).

 

Answer 6

Hi,
I have exactly the same error message.  Could you explain me what do you mean by "User Control" and how to use regsvr32 to register it ?  I've tried to register DLL in the project with regsvr32 and it didn't work.  Any help would be appreciated.

Error Signature:

EventType : clr20r3     P1 : prog.exe     P2 : 1.0.0.0     P3 : 4ae9f2c9  
P4 : prog     P5 : 1.0.0.0     P6 : 4ae9f2c9    P7 : d     P8 : c6    
P9 : system.invalidoperationexception

Thank you.
 

Answer 7

Hate to see posts without a possible solution.

In my case it was all related to Crystal Reports (shitty SAP support)...

I've had this (clr20r3) system.invalidoperationexception error twice on my deployment pc's, first time the solution was to include the:
C:\Program Files\Common Files\Merge Modules\CrystalReports11_5_NET_2005.msm (:\Program Files\Common Files\Crystal Decisions\2.5\bin was missing on the deploy pc).

The second time I had upgraded my project to VS2010, project included references to the 11.5.37 dll's:
Crystaldecisions.Crystalreports.Engine
Crystaldecisions.Shared
Crystaldecisions.Windows.forms

Once upgraded VS changed those references to 14.0.2000.0

The apps all immediately crashed on startup with invalidoperationexception!

G'luck all!

Michael

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter