Home » Windows OS

Destination Folder Access Denied

Just purchased  a vista business HP machine. Machine is part of an internal network. If I try to copy file from any other machine on the network from the VISTA machine, it gives me message "Destination Folder Access Denied" "You Need Permission to Perform this action".  But I can copy the files from other machines on the network to the VISTA machine?????????

24 Answers Found


Answer 1

I have run into the same issue. I'm sure I was able to do this in the past. I am running under non-privileged account and cannot copy  files from a network  share to my own workstation. The network share is mapped using alternate credentials. I can see the file  but I cannot open it directly or copy it to my local harddrives. I've also tried this from a command shell running as admin with no success.

I've tried turning on Network Discovery and File Sharing with no success.

I can't really see anything in the event logs either.

I share your frustration.


Answer 2

The problem in my case was permissions on the source file  (Duh!).

Unknown to me, Administrator access  had been limited to listing the files  in that folder. Once I set the permissions correctly, the file copied as expected. This was not done intentially by the user but something happened to the permissions when the files were copied from a unix-based file source.

I'm somewhat embarrassed but wonder why the error message  said "destination folder  access denied" when it was clearly the source folder that had issues.


Answer 3

I had the same exact problem occur on seemingly random files, when copying from my old PC (running XP) to my new PC running Vista.

I was confounded why it way saying "Destination folder  Access Denied", and nearly threw the new PC out the window, until I thought maybe it's a permission  problem from the source.  Indeed, some of the files  on my original PC didn't have proper permssions set to allow access  from the network.  I wasted at least 8 hours trying to figure this out. 

The error message  is extremely misleasing.  Why would the copy  indicate the "Destination" folder has access denied?  If the copy can't determine where the access denied  is occurring (which seems very unlikely), then they should change the wording to something like "Access denied due to source or destination", so I could more easily figure out what the problem is.

Microsoft, are you listening?


Answer 4

I have a similiar problem but no exactly what your experiencing. I am trying to delete a folder  with files  that i have to delete to get halo to work. As like you it brings up the access  denied message  when im an admin. any solutions to this?

Answer 5

i've read deleting individual files  within the folder
 first will enable you to delete the folder.

my problem is there are 150+ .tmp files and folders directly under my c:\ directory (both files and folders on the same "level") and i get the dfad error when trying to kill them. i cannot change permissions for the drive so i may commit filecide (my word), but i instead have to change the permissions for each file  and folder, one at a time, so they can be trashed.

in the meantime, the drive is still "locked down," so i don't have full access  to the machine  i bought and paid for...

Answer 6

I'm experiencing a similar problem ... I'm transferring files  from my old XP laptop to new Vista laptop and need to access  data files under the >local settings>application data>Microsoft directory, however, when I try and access the 'local settings' folder, I get an "Access is Denied" error message  ... I thought it was a permissions issue, but I my user account is set up as 'Administrator' ... just curious if you had any suggestions.  thx.


Answer 7

Had same problems when moving files to trash bin. Just stick to XP. At least it works.


Answer 8

Just share the root folder  or drive and delete the file  from a computer with xp. I just ran into the same problem, tried to change permissions and no luck. I was able to get rid of the folder from another pc however!


Answer 9

Simple but effective.   I tried changing permissions etc. to no avail.

Right clicked on offending folder  (or file) and selected 'cut', paste onto desktop.   Then right click and 'cut' again and paste onto memory stick.    Then delete from memory stick.   Voila


Answer 10

The problem being a source thing is correct.

If you want to copy  files from an XP machine  to a Vista machine over your local network, you have to grant the "Guest" account on the XP machine rights to work with that directory.  Since the operation is controlled, I grant the Guest account full control, copy the stuff I need, then imediately remove the Guest accounts rights.

It's working as designed, just might not be the way you want it.

BTW - Just giving the Guest account full access  of the share DOES NOT grant the Guest account the rights to the individual folders, you will still have to grant the rights.  I know, troublesome at least but it will get you past your issue.


Answer 11

Are you running VirusScan 8.5i on the target computer?

VirusScan 8.5 by default blocks other computers from droping autorun.inf files  in your system.

Make sure you uncheck the blocking of "prevent creation of remote autorun files" in the Access Control panel in the target computer.  That should take care of your problem. 


Alaska, USA


Answer 12

I am encountering this same error, "Destination folder  Access denied"  I encounter the error primarily when I try saving files  off the web.   I think I have also encountered it when moving file  from one folder to another.  Two conditions that might be of note in my situation are 1.  I have two versions of XP installed on this Machine being 32-bit and 64-bit versions, which have permissions for the XP userprofiles and directories already defined.  2. Mcafee Virus Scan 8.5i is installed, I am wondering as well if Mcafee is the problem.   

This issue with Destination Folder Access denied  is quite annoying.  I had never experienced this error in XP so was pointing at Vista as the problem.  I will have to try uninstalling or disabling McAfee and trying again.  If McAfee is not at fault than I will reinstall it.  On another note I have been running this OS as a limited user because I felt that it was more secure that way and I have been elevating myself to admin to do admin tasks, in this case only to get the same error message  again as Admin.  I have even tried logging in as Admin to perform  the task and still been presented with the error in question.

If this is a Vista flaw than I hope that it is fixed in Service Pack 1 as this is a definite killer of the usefullness of this operating system to me, that is if it is going to be giving me problems like this. 


Answer 13

Interestingly if I disable the on access  scanner of McAfee and the on access protection I still get the error message, but the system is saving the file, this is downloading an attachment from a web page where this problem is occuring in this case.  After saving the file  and getting the error message  I am prompted to save again with a SAVE / CANCEL button, at which point if I don't change the file name the system prompts me to overwrite.  If I overwrite the previously saved file than no problem, it just overwrites it this time.  I say Microsoft needs to fix this mechanism in Vista!

Answer 14


  i ran into the same problem.  I uninstallled McAfee VirusScan 8.5i. Then I was able to successfully download files  off the Internet.  I am gonna try installing another virus scanner and see if the problem repeats.  Hope this helps. 


Answer 15

Just as a note there is a good free alternative Virus scanner out there --- free for home users, not free for businesses.  The one that I like so far is Avast, it even has it own firewall built into it.  It is manufactured by a Czechoslovakian company, as stated  on their web site, which is www.avast.com.

Let me know if this helps you.



Answer 16

You're dealing with permission  issues.  Here is the easy way I got around the same problem.

ON SOURCE machine  (presumably the non vista  one)

a) Copy the folder  or the files  that you want to transfer to the new PC to a root directory (outide of your My Documents or Desktop).  For me, the eas thing to do was create a folder on the c:\ and put everything in there.  This gets the files out of the protected USER ACCOUNTS on the XP machine

b) Make sure you share the folder so it can be accessed on the network



b) Copy to wherever you would like

Hope this helps!




Answer 17

Vista is so retarded.  I copied a folder  containing some files  from an external hard drive on to my desktop (as a quick place to store them) then I decided I wanted to move them to "Documents" and I kept getting the error "Destination Folder Access Denied" with the stupid-*** options to "try again" or "cancel" WTF? I am the only user on this PC, and I am an administrator.  This frustrated the *** out of me.  Eventually I was able to copy/paste this folder into "Documents" and then delete it.  but isn't that the same thing as moving? Yet another reason Vista sucks balls.  Here's a couple more:

The network  and Sharing center sucks - what happened to "My network places" and "Network connections" everything you needed was there, and it was simple.

Defragmenter - what happened to the graphical display? It was neat seeing the before and after of my file  system.  Also, the percentage complete was kind of nice.

Try changing your encryption key to your WLAN.  What a pain in the ***! In XP you could simply disconnect from the network, and then reconnect, re-enter the new key and BAM you were back online.  Not in Vista, you have to go to the stupid *** "Network and Sharing  center" and then go to "manage network connections" remove the network from your list, then go back and re-join the wireless network. what a pain in the ***!

I truly hope this OS we all know as "Vista" doesn't make it.  In my opinion it sucks! *AND* I have technical data to back my opinion. 

Thanks for letting me vent Smile

-=Matthew L=-

A+, Net+, i+, Sec+, MCP, CIW, Wireless#


Answer 18

Yes!!..,, this STUPID Vista really SUCKS !!!!!!...,, I've got the same problems as yours..,, even if I am the Administrator, the ONLY user in my computer!!...,, DENIED me to access  control MY folders...

I've tried to delete a damn folder  that is completely rubbish on the Program Files folder because I tried to uninstall it but It fails, because this Vista CRASHED Suddenly with the BLUE SCREEN OF DEATH!!...., and so I tried to delete this manually but I can't remove this rubbish, because......

It DENIES me to control access in THIS folder.....,, "Destination Folder Access Denied" WHAT A STUPID THING!!!!

I am the ADMINISTRATOR and the only OWNER of my computer but it keeps DENYING me to grant permission!! and I continued it by pressing the button but It keeps telling me this STUPID THING
"Destination Folder Access Denied"!!....

"TRY AGAIN, CANCEL"... then I tried again but until the END OF THE WORLD! It REPEATS!!!!! And because of this,
I can't reinstall the program because this Vista CRASHED when I uninstall this!!!

ERrRrrrr.....!!! I feel that I can even throw my computer JUST BECAUSE OF THIS!!... DENYING THE OWNER!!

OF COURSE !!!!!!..,, I tried the WHOLE thing that I commonly read on the forums..

"Properties -> Security Tab -> Edit Permissions ->"  but NON of this thing Works!!!....,,

It keeps DENYING THE ADMINISTRATOR!!!!!!!.... even I've disabled UAC (User Account Control).....
just the same STUPID THING HAPPENS!!!

I'm REALLY REALLY losing my patience with the Customer Services of Microsoft!!.... because Microsoft still have NO answers in this STUPID problem even this MSDN Forums DON'T Answers!!!

HEY!!...,, MICROSOFT!! Do we need to ASK BILL GATES to give us just a STUPID permission  to


Answer 19

Lol.  The person who suggested using the memory stick, I'm gonna remember that.  It resolved the issue for me just fine, although that's a pretty silly thing to have to do.  I need to talk to my brother who was able to "fix" his vista  machine to eliminate "permissions" altogether.

Answer 20

I vehemently agree with grungegirl84 and Ken above. This "permissions" business  is a incredible design blunder and indicates unspeakable cluelessness on the part  of the designers. If Shadohpanther's brother was able to eliminate permissions I'd really like to know how it was done.

Incidentally, I came on this forum because Vista wasn't letting me copy  music files  from a root directory (to which they had come via repeated trips with memory sticks, since Vista does not allow sharing of "shared" network  folders) to my official "music" folder. I hit the "skip" option and found that Vista had arbitrarily transfered two out of seven folders. Without changing any settings, I tried again, and this time it worked. Vista isn't just illogical, it's imposition of permission  rules is basically random.

Any operating system that fails to allow the owner of a computer to transfer files from one folder  to another on that same computer is a badly designed system. There's simply no excuse for making a system that doesn't allow file  transfers.


Answer 21

 >Any operating system that fails to allow the owner of a computer to transfer files  from one folder  to another on that same computer is a badly designed system. There's simply no excuse for making a system that doesn't allow file  transfers.

Actually, that's what is called discretionary access  control.  You should check the permissions on the source and destination  files and directories.

Some basic information on ACLs:


Answer 22

I am having the same problem. i am copying 700+ pics from XP to Vista SP1 over my network. Probably 20% failed to copy  with the dreaded DFAD error. All of the files  were loaded onto the XP machine  the same way, transferred from my camera using Nikon's PictureProject. The difference seems to be that the pics I didn't subsequently edit and save using PictureProject are the ones that failed to copy.

Granting read access  to those files for the Guest account worked. I was then able to copy those files.

It is unclear to me why Nikon's PictureProject would apply different sharing permissions in creating and saving files.

My account names on the two machines  don't match. I wonder what would have happened if they had matched?

BTW, this was after 3 unsuccessful attempts to use Microsoft's "Easy Transfer" utility. The instance on the destination  Vista machine just stopped with no error message. Eventually the instance on the source XP machine stopped to with a network  disconnected icon flashing. I guess it ran out of space.

All the way through this I kept muttering "I wish I had bought a MAC".


Answer 23

ETB_UW, thank you for posting your solution. This turned out to be my issue, and it looks like, two years on, Microsoft has not fixed this very deceptive error message.

Answer 24

Let's call it three years. I have a brand new Windows 7 machine. I'm trying to access  a $ share on my XP machine. I have set permissions for EVERYONE to FULL CONTROL on the drive and all the folders. I don't remember having this problem with Vista (don't know why I didn't), but it is aggravating nonetheless.

When I map, I map using the XP login credentials on the XP machine, making me the "actual" owner of the files. On the local XP machine, I can right-click and create a new folder  in any location on the drive. On Windows 7, mapped using the same account that I just did that with locally, I get the ridiculous DFAD error. I have tried granting every permission  in the world. It is not permissions based on the XP share.

It has something to do with accessing the $ share via a drive map. To top it off, I'm running Windows 7 Pro. Supposed to be the "cream of the crop", right?

Anyone have any ideas? Anyone? Buehler? Buehler?





I'm designing a task that requires Administrator"s" permission.

I'd like to recognize if the user running my app is belong to "administrators" and show up below dialog and run the task.

The dialog is like the system dialog on Windows while you're copying the file:

        Title: Destination folder Access Denied
        Message: "You'll need to provide administrator permission to copy to this folder"

I'm wondering if there is any API or framework that can fire this dialog. Or Should I design by my self.

Moreover, how can I detect the current user is in Administrators group?



Hello all,

I am trying to figure out how I can deny access to a particular person on all the reports in report manager at once.

Right now, I am going to each and every individual report and deleting the role assignment from the security tab.


Can I do it in some other way, that I do not have to go to each and individual report and remove the user from there?


Thanks in advance.



Developing a C# Web application in Windows Server 2003, with IIS6.0 to read a excel file, perform some calculations and write it to a new Excel file, where the file available to be read is in shared folder, and it is to be written in the shared folder. When i debug the application from VS 2005 IDE, everything works fine - I can read the file from share and write it back successfully. When i deploy the application in IIS, I get Access Denied error. Any ideas for solving the problem?

Note: As the shared file is in local lan, i am not interested in using impersonation. As a matter of fact, the shared folder am trying to write to has full control to everyone. As it is in Lan I dont care about security. I just want to write the file in the shared location.



I am trying to export the Bug template from a project , but when I run the command witadmin exportwitd /collection:http://servername:8080/tfs/Collection /p:project /n:typename /f:filename from C:\ProgramFiles<x86>\Microsoft Visual Studio 10.0\VC, it gives me  "Access to the path C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\Bug.xml is denied". If I try to export the template from the Process Editor under Tools menu in Visual Studio, then also it gives me the same error. I am running TFS2010 on Win 2008 R2 . Please help me with this issue.


Hi All,

We are facing this issue in one of our site, when accessing the folder from Manage content structure. Folder is inside a list which uses a folder content type. When we try to open this folder use manage content and structure it throws access denied.

any idea how we can check this as we the permissions are properly inherited and all the folders are checked in .

Please update what else we can check.



Jasjeet SIngh



I am 13, and I am experimenting with visual basic. My current project is to search the computer for exe files, I managed to do that easily with a for...each statement. It ran well, but it came to a adminstrator folder, then it said "Access Denied".

I understand that you cant access these folders, but i was wondering how to exclude certain directories that the user can't access, like UAC or something...

Imports System.Collections.ObjectModel

Public Class Form1
    Dim files As String
    Dim pro As String = My.Computer.FileSystem.SpecialDirectories.ProgramFiles
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Debug.WriteLine("Me.text was ' " & Me.Text & " ' at design")
        Me.Text = "Choose a program"
        Debug.WriteLine("Declaring neccessary variables...")
        Debug.WriteLine("ExeLister Finder routine started...")
            ' This will call the ExeLister_Routine
            Call ExeLister_Routine()
            Debug.WriteLine("Caught an error from the Application in runtime...")

            MsgBox("You were not able to access all folders,  " & vbCrLf & _
                   Err.Description & " ,using physically " & vbCrLf & _
                   "registered programs instead... ", _
                   MsgBoxStyle.Information, _
            MsgBox("Searching is complete!", MsgBoxStyle.Information, "YAY")
        End Try
    End Sub

    Private Sub ExeLister_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ExeLister.SelectedValueChanged
        ' This gets the chosen application selected, and runs it
        Microsoft.VisualBasic.Shell(ExeLister.SelectedItem, _
                                    AppWinStyle.NormalFocus, False, -1)

    End Sub
    Private Sub ExeLister_Routine()
        Debug.WriteLine("So far, so good... :-)")
        ' This is a trick to find the root directory,
        'by using the program files parent path!
        For Each Me.files In (My.Computer.FileSystem.FindInFiles _
                              (FileIO.FileSystem.GetParentPath(pro), _
                                                   "*", _
                                                   True, _
' When I mean programs I mean not just executable data programs!!
FileIO.SearchOption.SearchAllSubDirectories, _
                                                   "*.exe", "*.bat", "*.com", "*.pif", "*.cmd", "*.vb"))

    End Sub
End Class

Thanks, by the way, you can email me at

ben... @windowslive.com

(Click on the 3 dots, to see my email address. Security Reasons!)


i am trying to use a fileopen dialog to select an image and copy it to my project folder .

i have used this code to do that.

OpenFileDialog ofd = new OpenFileDialog();
      ofd.Filter = "All Image Files| *.*";
          imgImagePath.Source=new BitmapImage(new Uri(ofd.FileName,UriKind.RelativeOrAbsolute));
          FileStream fs = new FileStream(ofd.FileName,FileMode.Open,FileAccess.Read);
          FileStream copyfs = new FileStream(@"../../Themes/Images", FileMode.CreateNew, FileAccess.Write);

The Error i am gettin is The so and so folder access is denied.

I have check that the folder is not read only. and its in d:

Any suggestions?




I have a web site that has a folder called Files that contains PDF files.  These PDF files should not be accessible to people who have not signed in to the web site. 

The login URL is www.mysite.com/Account/Login.aspx and the register URL is www.mysite.com/Account/Register.aspx. 

Once the person is signed in they can go to www.mysite.com/Documents/Documents.aspx.  This page has a gridview that lists the PDF files in the Files folder with a link to them.  If the person is not signed in, he/she can't view this Documents.aspx page.  However, if anyone has the URL to the PDF files, they can view those files without having to sign in.

How can I prevent someone from accessing the PDF files in this folder?

The site is hosted on GoDaddy using IIS 6.0.

Thanks in advance.

I have the following code works fine in Windows 2000, after i moved to Windows Server 2003, it shows "Permission denied"...

strExecFunction = "fso.CreateFolder";
       if ((fso.FolderExists(strUplProPath)) == false)
var strReturnVal = objDataFile.DelDataFile(strUplProPath, strUplProDatFile)

strUplProPath  = a share path, like //ServerName/Upload/Username

strExecFunction = "fso.CreateFolder";
       if ((fso.FolderExists(strUplProPath)) == false)
var strReturnVal = objDataFile.DelDataFile(strUplProPath, strUplProDatFile)

strUplProPath  = a share path, like //ServerName/Upload/Username

I'm trying to backup to a network drive, but I keep getting the message below:
Cannot open backup device '\\Server\Projects\Exodus\Backup_Banco'. Operating system error 5(Access is denied.).
The weird thing is that if I use xp_cmdshell on the same folder, I can dir, copy files, etc...  Why is that?
Below is by backup command code that I get the Access Denied:
  TO DISK = '\\Server\Projects\Exodus\Backup_Banco'
And both xp_cmdshell commands below works without a glitch:
exec xp_cmdshell 'dir \\Server\Projects\Exodus\Backup_Banco'
exec xp_cmdshell 'copy \\Server\Projects\Exodus\Backup_Banco\text.txt \\Server\Projects\Exodus\Backup_Banco\text4.txt'
Both SQL Server and SQL Agent are running on domain accounts, and I gave Modify rights on the \\Server\Projects\Exodus\Backup_Banco folder to the Domain Local Group that holds both accounts, as the copy commands shows.
Both commands use SQL Server's service account rights, so I should get the same treatment for both commands. But that's not what is happening.
Any ideas why?

My 2007 site has been upgraded to 2010.  When clicking the upload button for Document/Picture Libraries that existed before the upgrade, the upload dialog shows the “Destination folder” field.  This field is not display in the upload dialog of Libraries created after the upgrade.  Is there a setting I haven’t found yet that will remove the “Destination folder” field from the upload dialog for my older Libraries?  It doesn’t appear to be related to the ‘Make “New Folder” command available?’ setting.

I am testing an application that does a one-way sync.  If I exclude a folder that exists on both the source and destination - it deletes the folder on the destination. This is not the behaviour I need. I simply want to exclude folders from sync - and not delete them on the destination.



BizTalk 2006 with base EDI subsystem.

I have outbound 997 using a local folder as target. It worked fine for several weeks. Last week the server ran out of disk space, which was quickly fixed (It is a VM) . Since then the ACK files were not sent out to the target folder. I can see that ACK files were created in the EDI System\External\Outbox folder. But that's it. The files are not send to the configured folder.

I am not sure the 997 issue related to the disk issue or not.

I checked the ACK configuration, no changes; Checked security, no changes (the EDI subsystem/BizTalk service account is a member of local admin group)

Any one experieced this before? What else (configurations, logs, traces) should I check?





I have build an ASP.NET Web Application using Visual Studio 2010. I build a Deployment Package and move the resulting files to the web server. On the web server I execute the generated .cmd file. The install package correctly creates a new Virtual Directory under the Default Web Site and everything seems to work.

The problem is that the deployment creates the virtual directory underneath directory C:\inetpub\wwwroot on the web server. I need to instead have it create the virtual directory under D:\WebsiteApplications (due to company policy).

How do I configure the deployment package to install the virtual directory in the directory that I specify and not in the default directory?


I am trying to get a silverlight application which uses the client object model to work with anonymous access.  I have found the following msdn article.
however on the beta there does not appear to be any authenticationmode method to use.

Does anyone know if they have removed this from the beta dll?  or does anyone have any idea how you can get the client object model to work over anonymous access.



Client failing to access the SSRS 2008 Report manager URL with Access Denied error 401.3:


When our user tries to connect through browser or application from the client machine to SSRS 2008 report manager URL, the user gets the following error:


Access is denied.

Description: An error occurred while accessing the resources required to serve this request. You might not have permission to view the requested resources.

Error message 401.3: You do not have permission to view this directory or page using the credentials you supplied (access denied due to Access Control Lists). Ask the Web server's administrator to give you access.


Environment Information:

SQL Server 2008 (64 bit) along with SSRS and SSIS is installed on a 64 bit machine Running Windows Server 2003 R2 Standard, 64 Edition, SP 2

Reporting services is running under a domain account and the browser service is running under the LocalSystem


The AD domain groups have been added at the Home folder in SSRS report manager to have “Browse”, “Publisher” and “Report Builder” access.


Any idea, what could be the issue? Thanks.


I'm experiencing a strange problem when trying to access various properties and other SPWeb's when running with Elevate Privileges and a user who is a visitor.  Here's a snippet of code:

  SPWeb spWeb = SPContext.Current.Web;  
  spWeb.Site.CatchAccessDeniedException = false;  

I am getting an Access Denied error for visitors which is odd as RunWithElevatedPrivileges should give the code access.  It only works if the user has some higher level permissions assigned.

I have added the CatchAccessDeniedException temporarily to prevent the access denied errors halting the code.  If I examine spWeb in the debugger and drill down into the Webs to read the Name and Count properties I see this 'spWeb.Webs.Count' threw an exception of type 'System.UnauthorizedAccessException'.

The ListUsers method recursively traverses the Webs in each sub-web and it is here where the code starts to fall over (on the oWeb.Webs.Count line - same exception as I see in the debugger as mentioned above).  Here's a cut down snippet of that function...

privatevoid ListUsers(SPWeb oWeb)  
if ( oWeb.Webs.Count > 0 )  
foreach ( SPWeb oSubWeb in oWeb.Webs )  
using ( oSubWeb )  
                    ListUsers( oSubWeb );  
// some functionality
catch (Exception)  

It seems I am only able to read the properties of the current site when the user is a visitor.  A Site Owner or Member (contribute permissions etc) seem to work ok.  Have I missed something critical here or is there a problem with my installation of SharePoint?  The same occurs on our development and test servers.

Hello all.

I am using Access 2010 and SQL Server 2008 (locally). I can easily connect to server using SSMS and it works excellent. But when I want to import a table to Access 2010 using ODBC, it says that "SQL Server doesn't exist or access denied". It worked previously - almost 3 days ago, but now, it doesn't!

Please help!

Mohammad Javahery

Hello All,

This problem has me stumped.

We are trying out CRM 4.0 and did a fresh install. We have setup CRM on two machines, one is the web server and the other acts as the SQL server. For the purposes of testing we setup AD on the SQL server.

During the installation we tried to use the domain administrator account to run the app pool but we kept getting a Verify Domain user account SPN for the Microsoft Dynamics CRM ASP.NET application pool. We looked around the forums and found a lot of posts talking about setting the SPN for the installation account so we ran the setspn tool for the <Domain Name>\administrator account (The account we were trying to use) but that did not work

So we went and set the app pool to use the Network account and the installation completed sucessfully. We used a typical setup during the installtion. So I guess all the other settings are standard.

We opened the CRM web page on the server and everything looks good. But a problem arises when we try to access the URL from a client machine (The client was joined to the CRM domain and added to CRM as a system admin). we get the following error
HTTP Error 401.1 - Unauthorized: Access is denied

The event logs do not seem to have any error reports regarding CRM.

But the wierd thing is that if we use the servers IP address we can access the server. We just can't get it. How are we able
to access the server using the ip address with out any problems
but when we try to use the computer name/ FQDN we get the above errors

Any Help would be greatly appreciated



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure