Home » .Net Framework

How to download crystal Report 10.5

____ sir/Mam

This is Himanshu Kumar Pant. I want to install crystal report in my server, I want to know that, is Crystal Report 10.5 is free, if yes then please provide the link from where I can download it. 
I gone through a link to download it the link is as:


but this didn't resolve my issue. I am still getting error in my site. Please provide any link from where I can download the msi/exe file, and able to run it in my server. 

if possible then please mail me  at himanshukumarpant{at}hotmail.com

Himanshu Kumar Pant.

1 Answer Found


Answer 1

____ sir/Mam

This is Himanshu Kumar Pant. I want to install crystal  report in my server, I want to know that, is Crystal report  10.5 is free, if yes then please provide  the link  from where I can download  it. 
I gone through a link to download it the link is as:


but this didn't resolve  my issue. I am still getting error  in my site. Please provide any link from where I can download the msi/exe file, and able to run  it in my server. 

if possible then please mail  me  at himanshukumarpant{at}hotmail.com

Himanshu Kumar Pant.

I think it's not the right forum for your question. You can ask the administrator to learn which is the right forum.



Can anybody please let me know the compatibility of crystal reports 10 with Visual Studio 2010. Will it create any run time issues?

Thanks in Advance!!


Manesh Joseph


Hi all,

Scenario of my issue goes like below:

I have to develop a report for bill printing where a bill with duplicate copy should get printed below the main bill and the stationary is A4 size sheet.

I have solved it like below:

I have created a report called BillPrint.rpt which prints the single bill for a given Bill No. Now since duplicate is required, I'll go for creation of another report called BillPrintMain.rpt which contains only 2 page footer sections of 4.5" hight each called PF-a and PF-b. Each of these sections contain a subreport, which is nothing but BillPrint.rpt.

Issue with the given solution:

Above provided solution works fine if my bill contains only few items, say, max of 15 items per bill. If a bill crosses 15 items in it, only 15 items would be printed in the main and duplicate copy of the bill and rest would not be printed at all. But if I try to print from the BillPrint.rpt, it would be able to print the bill in multiple pages. BillPrintMain.rpt prints the bill in multiple pages. But when the same is used as a subreport in BillPrintMain.rpt, Main/Sub report would not render the report to multiple pages.


How do I solve this?


Thanks in advance for everyone who would try to solve this for me.


Jagadeesh Aithal


We are trying to run crystal reports from web application which uses .net 2.0 framework. But I am getting below exception when I try to run a report  

Query Engine Error: 'ADO Error Code: 0x80040e14
Source: Microsoft OLE DB Provider for ODBC Drivers

Description: [Microsoft][ODBC SQL Server Driver][SQL Server] Procedure 'x' expects parameter that was not supplied.
SQL State: 37000

Native Error: 201'

We did lot of googling and even installed the below patch suggested by many people in forums:


That didnot help either. Would greatly appreciate if someone can provide any input?



I have a project I moved from Vis Studio 5 to Vis Studio 10, Web application, C#, ASP.NET 2.  The project converted to Vis Studio 10 OK, and the rdlc reports worked. As soon as I opened a report to modify it, it asked me if I wanted to convert it to version 10.  I said OK.

Next time I ran the report in the browser, I received an error, rather vague, on the line:

byte[] pdfContent = reportViewer.LocalReport.Render(

            "PDF", null, out mimeType, out encoding, out fileNameExtension,

             out streams, out warnings);

I found a somewhat similar topic here where the writer said he solved the problem by changing the report reference from version 8 to version 10.

There was no explanation, though.  

Can anyone explain which reference this is and how this is done?


Mike Thomas




i was trying print pages records total  in sub reports e.g
pages no     total
1                10000
2                50000
3               8000.

so on.........

i wrote code in crystal reports to get record sum 

Global NumberVar total;

after try to ...

Shared stringVar Array UserNames;
redim UserNames[100];

NumberVar i; 
For i := 1 To 100 Do 
    if ( PagesNo < PagCnt) then  
   UserNames[ i ] := cstr(total)+cstr(i)

how to paas array to sub reports  and print in report
l've search all over the web for any info 
i get info but not  work fine 
Plz help me.....................................

____ sir/Mam

This is Himanshu Kumar Pant. I want to install crystal report in my server, I want to know that, is Crystal Report 10.5 is free, if yes then please provide the link from where I can download it. 
I gone through a link to download it the link is as:


but this didn't resolve my issue. I am still getting error in my site. Please provide any link from where I can download the msi/exe file, and able to run it in my server. 

if possible then please mail me  at himanshukumarpant{at}hotmail.com

Himanshu Kumar Pant.


My VS 2005 standard edition does not come out with crystal report, may i know where can i download crystal report and install for VS 2005?



I received the following error message, when downloading file of 10 MB. Please let me know the solution. I already configured the httpRuntime value to
<httpRuntime maxRequestLength="10250 " executionTimeout="1000". Still I am getting the error message.

The description for Event ID ( 0 ) in Source (XXXXX) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Unable to read data from the transport connection: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full.
 Source: mscorlib
 TargetSite: Void HandleReturnMessage(System.Runtime.Remoting.FileUploading.IFileUpload, System.Runtime.Remoting.FileUploading.IFileUpload)
Server stack trace:
   at System.Net.ConnectStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   at System.IO.BufferedStream.Read(Byte[] array, Int32 offset, Int32 count)
   at System.IO.BinaryReader.ReadBytes(Int32 count)
   at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.ReadArrayAsBytes(ParseRecord pr)
   at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.ReadArray(BinaryHeaderEnum binaryHeaderEnum)
   at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.Run()
   at System.Runtime.Serialization.Formatters.Binary.ObjectReader.Deserialize(HeaderHandler handler, __BinaryParser serParser, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
   at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Deserialize(Stream serializationStream, HeaderHandler handler, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
   at System.Runtime.Remoting.Channels.CoreChannel.DeserializeBinaryResponseMessage(Stream inputStream, IMethodCallMessage reqMsg, Boolean bStrictBinding)
   at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.DeserializeMessage(IMethodCallMessage mcm, ITransportHeaders headers, Stream stream)
   at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(FileUploads & msgData, Int32 type)
 Inner ExceptionSystem.Net.Sockets.SocketException: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full
   at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size).

Hi there,
I am using WebRequest/WebResponse/and Stream to download a file in a backgroundworker so I can provide a progress indicator. The download works fine except the last read always takes about 10 seconds no matter what I set the WebRequest.Timeout to. I've also tried changing the Stream.ReadTimeout property with no effect. I don't think it's a network issue. 

Any ideas would be appreciated

Here's my code:
        private void DownloadWorker_DoWork(object sender, DoWorkEventArgs e)
            BackgroundWorker MyWorker = sender as BackgroundWorker;
            FWDownloadWorkerPackage Package = (FWDownloadWorkerPackage)e.Argument;
            int iByteCount = 0;
            int iProgress = 0;

            WebRequest MyWebRequest;
            WebResponse MyWebResponse = null;
            Stream ReceivedStream;

            // Build the filename to download
            string sFileName = Package.Device.Model + "_" + Package.Device.NewFWVersion + ".S19";
            string sDestination = Environment.GetFolderPath(Environment.SpecialFolder.Personal).ToString() + "\\CoolIT\\Maestro\\Downloads\\" + sFileName;

            // Calculate the block size
            int iBlockSize = 1024;

                // Setup the connection
                MyWebRequest = WebRequest.Create(ROOT_WEB_ADDRESS + sFileName);
                MyWebRequest.Timeout = 3000;

                // Create the connection
                MyWebResponse = MyWebRequest.GetResponse();
                ReceivedStream = MyWebResponse.GetResponseStream();
                ReceivedStream.ReadTimeout = 3000;
                ReceivedStream.WriteTimeout = 3000;

                Byte[] aBuffer = new Byte[iBlockSize];
                FileStream MyWriter = new FileStream(sDestination, FileMode.Create);

                // Read the data
                int iBytesRead = ReceivedStream.Read(aBuffer, 0, iBlockSize);
                while (iBytesRead > 0)
                    // Check for a cancel
                    if (MyWorker.CancellationPending)
                        e.Cancel = true;

                    iByteCount += iBytesRead;
                    MyWriter.Write(aBuffer, 0, iBytesRead);
                    iBytesRead = ReceivedStream.Read(aBuffer, 0, iBlockSize);

                    // Update progress
                    iProgress = (int)(((double)iByteCount / (double)Package.FileSize) * 100);

                    if (iProgress <= 100)   // Just in case we go over slightly

                // Clean up streams
                e.Result = false;

            e.Result = true;




I have decided to take interest in VSE  again and i decided to download the iso file for Visual studio express 2010.

i tried to download it in the usual way but my download appeared to get 'stuck' at 10 %. This hapopened to me 3 times over 2 evenings.

On the 2nd evening of my attempts, after the 3rd attempt i gave up and tried to download the 2008 version of the iso file.

This happened in one go and without fault. I was also able to do this with the assistance of free download manager,

I managed to burn an installation CD with the 2008 iso file i downloaded and installed the software without problem.

Can any one possibly explain this problem with 2010 at all ?


Hi all - I'm trying to use the Crystal Report Viewer for Visual Studio 2010 with Crystal Reports Server 2008, and I'm not having much success.  I'm attempting to view the report from an ASP.Net page.

I have this code in an ASP.Net Page:

string serverName = "MyServer";

SessionMgr sessionMgr = new SessionMgr();
EnterpriseSession enterpriseSession = sessionMgr.Logon("User", "Password", serverName, "secEnterprise");

EnterpriseService enterpriseService = eterpriseSession.GetService("InfoStore");
InfoStore infoStore = new InfoStore(enterpriseService);
InfoObjects infoObjects = infoStore.Query("SELECT * FROM CI_INFOOBJECTS WHERE SI_PROGID='CrystalEnterprise.Report' AND SI_NAME LIKE 'MyReportName%' AND SI_INSTANCE=0");

InfoObject infoObject = infoObjects[1];
enterpriseService = enterpriseSession.GetService("RASReportFactory");
Object rrfObject = enterpriseService.Interface;
ReportAppFactory reportAppFactory = (ReportAppFactory)rrfObject;

ReportClientDocument reportClientDocument = reportAppFactory.OpenDocument(infoObjects[1]);
CrystalReportViewer1.ReportSource = reportClientDocument;

When the OpenDocument call is made, I get an exception: "The parameter was incorrect".  Note that most of the sample code that I've found passes the ID property of the InfoObject, but that gives me another exception: "No such interface supported". 

I've also tried to use the DSWSPortal sample from BusinessObjects to access the report via a web service, but drilldown doesn't work: the javascript to do a drilldown doesn't exist on my system.  I've installed both the Crystel Reports Viewer 2010 and the .NET SDK from Crystal Reports Server 2008.

Am I just missing something really obvious?





I plan to use the Report Viewer 10 release candidate (the ReportViewer.exe redistributable) in my new developed web application.
The deployment involves me installing the Report Viewer 10 release candidate on a web server in a server farm.
Due to the fact that it is a release candidate I am not allowed to do that by my network administrator because of the potential security risk.
The release is not due until sometime in April and I can not wait that long unfortunately.
My questions are therefore:
What are the security risk in using the release candidate vs. the actual released version ?
At what level is the release candidate tested against e.g. virus attacks ?

Kind regards

Report Viewer 10 in local mode only supports RDLC formats 2008. 

Anyone knows when there will be an upgrade to Report Viewer to support RDLC 2010 in local mode?


Thank you



Hi everyone,

I got a strange problem: I got a project VS2005 (i know..sounds old but...that's it) with an rdlc file and some code using reportviewer 8.0; I have to check the migration to 10 but...surprise after I removed from GAC the 8.0 leaving just the 10 version I had (so far) no problem with the code but I'm not able to build anymore my solution.

The point is I don't even receive from VS an error...just a fail on build (in verbose mode not a single information about error...everything successfully done but build failed); in the search of problem I saw that all build ok if I just remove the rdlc from the project!!!!!

So, I have to do any conversione migrating from reporting 8 to 10? (notice I can still open rdlc in the editor without any problem, the point its just the build!)

Any clue?





I have writen a site using VS2010 and all was working well until I create some reports.  

I then got the below error message when I moved the site to my production server.

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Microsoft.ReportViewer.WebForms, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 15:     <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
Line 16:       <assemblies>
Line 17:         <add assembly="Microsoft.ReportViewer.WebForms, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 18:         <add assembly="Microsoft.ReportViewer.Common, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 19:         <add assembly="Microsoft.Build.Framework, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />

Source File: C:\inetpub\BlazeBillz\web.config    Line: 17

I looked this up on a few websites and a few people suggested chageing the to in the web.config file.  This does allow the site to be loaded, but the reports page still does not work.

I would much prefer to just get version to work on my production server.

Does any one know wher I can get this version from?





We updated our application to VS2010 / .NET 4.0. We are using the WinForms Report Viewer control to display .rdlc files. Some of the files reference framework DLLs (System.Core, System.Drawing, System.Xml)

*If* I use the deprecated methods, everything works. 

Set the CAS policy to legacy in the app.config:

<NetFx40_LegacySecurityPolicy enabled="true" />

Trust the assembly:

_reportViewer.LocalReport.AddTrustedCodeModuleInCurrentAppDomain("System.Drawing, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a");

HOWEVER: I would like to not depend on the deprecated method. If I do this, instead:

            PermissionSet permissions = new PermissionSet(PermissionState.None);

            permissions.AddPermission(new FileIOPermission(PermissionState.Unrestricted));

            permissions.AddPermission(new SecurityPermission(SecurityPermissionFlag.Execution));


            Assembly asmSystemDrawing = Assembly.Load("System.Drawing, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a");

            AssemblyName asmNameSystemDrawing = asmSystemDrawing.GetName();

            _reportViewer.LocalReport.AddFullTrustModuleInSandboxAppDomain(new StrongName(new StrongNamePublicKeyBlob(asmNameSystemDrawing.GetPublicKeyToken()), asmNameSystemDrawing.Name, asmNameSystemDrawing.Version));

I get the following error:

The report references the code module "System.Drawing, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", which is not a trusted assembly

Any advice on this issue?

Thanks in advance,



I'm converting my Windows Form projects from 2008 to 2010, and this includes upgrading reports from 2008 to the 2010 and using the latest ReportViewer component ( to

The problem I now have is the new ReportViewer control now wants to inspect all properties of an object entity passed as a datasource, not just those used by the report. With Linq to Sql entities this causes ObjectDisposedException as not all child object are loaded since they’re not required.

Is there any way to stop the Report Viewer doing this? The previous viewer ( didn’t do it.




Hi All,

Is there free software that converts Crystal Reports .rpt files to SQL Reporting 2008 .rdl files?




im new to crystal report .please help me in this.i have charts in main report.i want to do onclick of chart i want to pass parameter to subreport which has detailed view of records at micro level.i need to do at short period.please help what are step to be done in

step by step format.if it can be done programmatically please help me in that


Greetings All!

I have used the Crystal Reports Runtime (x86 and x64) for the last couple of years simply by deploying my application and installing the Run Time separate from my application. It hasn't given me any issues...until now. If I try to run a crystal report that has a non-standard Crystal DLL in it I receive a message during the report load that it can't find a specific DLL. In this case its a u2ltdate.dll which is used in a lot of the Crystal Reports we have designed over the last several years. One of the formula functions this DLL uses is the "NumberToDate" function, since much of the date data that we work with is stored as an integer value "YYYYMMDD" format it's much simpler to call this function in a Crystal Formula than do the Mid/Left/Right string manipulation. Most of the reports are designed in Crystal 10, and some are in 8.5

I first noticed an issue when I upgraded my development PC to Windows 7 x64. When I design reports in Crystal 10 I am able to use the u2ltdate.dll with no issues, but if I try to call that same report from my application using the Run Time I receive a missing DLL error. I assumed this was an issue related to being on a 64-bit platform, and since most of our clients weren't even on Windows 7, or 64 bit systems I didn't have any issues deploying my applications the usual way. Well the inevitable has now happened so it's time for me to get a solution for this. I suspected that I would get the same message on my client's 64 bit W7 PC and that is exactly the case.

Here is the exact error message: "UFL 'u2ltdate.dll' that implements this function is missing. Error in File C:\Users\username\AppData\Local\Temp\Report Name{GUID}.rpt: Error in formula <date>. 'NumberToDate({Table.Field})' UFL 'u2ltdate.dll' that implements this function is missing."

I have tried putting the DLL into the following folders with no success. 'C:\Windows\Crystal', 'C:\Program Files\Business Objects\Common\2.8\bin', 'C:\Program Files (x86)\Business Objects\Common\2.8\bin', 'C:\Windows\system32\', 'C:\Windows\SysWOW64'

I have tried registering the DLL using regsvr32 <dll path> and that has not worked either. Anybody have any ideas on how I can use this u2ltdate.dll in the Run Time on a 64 bit system? Any and all information will be appreciated!


Jeremy Wolverton


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure