Home » Visual StudioRSS

DSL: Is "Microsoft Visual Studio 2010 DSL SDK Beta2" compatible with Visual Studio 2010 Beta 2 Ultim

Is "Microsoft Visual Studio 2010 DSL SDK Beta2" compatible with;
- Visual Studio 2010 Beta 2 Ultimate and
- Windows-7 Enterpise 64-bit?

When I tried to create a new Domain Specific Language Designer project, I receive an error pop-up message.
"Object reference not set to an instance of an object".

Is this a bug or an incompatible tool stack?
 

6 Answers Found

 

Answer 1

Feels like an issue with the DSL tools, but your description is not clear enough. I suggest that you can give more specific details and repro steps.
 

Answer 2

Repro Steps
1) DELL Latitude D830 (64-bit, Intel(R) Core(TM) Duo CPU T7100, 4 GB RAM)
2) Installed Windows 7 Enterprise 64-bit (English) as Bootable VHD and added boot-screen using BCDEdit
3) Installed Visual Studio 2010 Beta 2 Ultimate (from Gold Partner MSDN)
3) Installed Visual Studio 2010 Beta 2 SDK
4) Installed Visual Studio 2010 Beta 2 DSL SDK
5) Start VS and create new project Domain Specific Language Designer

Results
The project/solution is not created.
Instead I receive a pop-up message:
"Object reference not set to an instance of an object".
Quick glance at the event-viewer did not show an appropriate error message.

Workaround Attempts (without luck)
Repair Visual Studio
Deinstall/Reinstall SDK
Deinstall/Reinstall DSL SDK
The error remains!

Note: The VS 2008 DSL fuctionality without problems.

 

Answer 3

Hello
Apart from the hardware, I was using:
- Windows 7 Enterprise 64 bits (but not as a bootable VHD)
- VS 2010 Ultimate
- VSSDK 2010 Beta2
- DSL SDK 2010 Beta2
And everything used to work fine for me (I'm now using a later version)

The only problem we are aware of is an incompatibility with ASP.NET MVC post Beta2. Did you happen to install it?

Thanks
Best regards
 

Answer 4

Hi Tjerk,

Can you answer Jean-Marc's question so he can help you resolve this issue?

Thanks!

 

Answer 5

Esther and Jean-Marc,
I did not install ASP.NET MVC post Beta2.
However, I believe my problem was caused by a technical hick-up I experienced during my install of VS 2010.
I will simply reinstall everything.
 

Answer 6

Esther and Jean-Marc,
I did not install ASP.NET MVC post Beta2.
However, I believe my problem was caused by a technical hick-up I experienced during my install of VS 2010.
I will simply reinstall everything.

I have the issue which is similar to what you have faced, I've tried it and it works.
 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter