Home » .Net Framework

Error 11009: Property is not mapped

Greetings! Please keep in mind; I'm just beginning to learn and program the Entity Framework in .NET 4.

In my Entity Model, I have added a custom property on a table which does not have a corresponding database column.

I intend to use this custom property to contain a concatinated string returned from a stored procedure. I have imported the stored procedure using the "Add Function Import" wizard and designated the return collection as a set of Entities derived from my table. Everything looks good here, but the field on the table is throwing the error: Error 11009: Property 'FullName' is not mapped.

I understand the property is not mapped because there is nothing in the database that represents a FullName. Can anyone help me to understand and resolve this problem?


2 Answers Found


Answer 1


My understanding is that you are trying to add the new property to the entity in the designer (for example by right-clicking on the entity, and choosing add -> scalar property). Using this approach will not work for what you are trying to achieve, since any properties added this way MUST be mapped to a table column. 

Fortunately, there is another way you can add a property to an entity. It involves defining a partial class for the entity and adding the property or function to that partial class. I found a couple of blog entries that show how to do it:






Answer 2


 right click on EDMX design view there is an option "Generate Database from Model" . select "Generate Database from Model" it will generate a sql script . Copy generated script and paste in your sql query window and run. Now it will work fine.




Hey All,

   I have  SQL Server 2005 Enterprise SP2 running in a 32Bit Server 2008 Active / Passive Cluster (not R2).  Recently just upgraded to SQL Server SP3 however ran into Numerous issues trying to update due to either Error 29512 or 11009.  Here's what I did to Resolve the issue and get SP3 updated Successfully on my Cluster: 

Step 1: Download SQL Server Enterprise SP3 update for SQL 2005.

Step 2: Make sure your (SQLSERVER instance, SQL Server Agent, and SQL Server Full Text Search) Services are set to "Log On As" your Domain Admin Account that is setup for the Cluster. It has to be configured as DOMAIN\USER ACCOUNT. NOT as Useraccount@domain.com Otherwise you will receive the 29512 Error when attempting to install. 

Step 3. Ensure you are logged onto your Passive Node with the Domain Admin Account.

Step 4. Go to DOS and execute the SP3.exe update with the "/passive" command.  - This will launch the installation and should now by-pass the Cluster check and you shouldn't receive the 11009 Error message.  

Step 5. Once the Installation is completed your passive node should re-boot, now go to your Active Node. 

Step 6. On the Active Node - open failover clustering and Pause the Passive Node and stop the SQL Services on the Active node. 

Step 7. Ensure your Services are configured in Step 2.  and launch the SP3 Update.exe. - Allow the installation to complete (it will probably ask for a reboot do not reboot yet).

Step 8. Un-Pause the Passive Node in the cluster, restart your SQL Services. then Reboot the Active Node.

Everything should failover to your Passive Node and all your SQL Services should now be update to SP3.  These are the steps I went through to resolve the issues but unfortunately could not find any solid answers. I hope this helps.


I've been trying to install SP4 and even SP3 and receive the Error 11009. No passive nodes were successfully patched

I've paused the passive node and installed on the active and it installed.

I've tried installing both as passive using the /passive and also as active with passive node paused.

However when I tried to install on the passive node it errors with this.

Unexpected Error Occured.

The Hotfix Installer Crashes

Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    hotfix.exe
  Application Version:    1.4.1581.0
  Application Timestamp:    4a44d1d7
  Fault Module Name:    hotfix.exe
  Fault Module Version:    1.4.1581.0
  Fault Module Timestamp:    4a44d1d7
  Exception Code:    c0000005
  Exception Offset:    000000000003cfdc
  OS Version:    6.0.6002.
  Locale ID:    1033
  Additional Information 1:    deec
  Additional Information 2:    601b7899f22fa8952a10ccb8ff42853e
  Additional Information 3:    b2ce
  Additional Information 4:    4624f576650d42293d0f513f059b4f13

I'm trying to map a profile property that i created to a property in the BCS Entity but i can't. I'm able to click on the "Add" button for the mapping, but when i click on "ok" to update the profile property i get an error saying 
"An error occurred when updating a property."

The property was created the first time, but the mapping is not being created. 
Bug? or im missing something?


Hi, I've changed the a user profile settings in CA (see below) so it is no longer mapped to AD, but when I edit the user profile in SharePoint MySite I have a yellow triangle with an exclaimation mark that states "indicated a filed that is updated automatically from the corporate directory. Changes to these properties may be lost. But I have removed the mapping as above. Am I missing some thing or is there a job that I need to run to carry the update through.   

I made the change in  - "user profile service application - manage user properties - Work phone" I have removed the "property mapping for Synchronization" so it now displays "There are no items to show in this view" - Do I need to make further changes to carry this through? 


Hi to all.
I am trying to use EDMS with POCO entities manual created. (Entities created manually, re-designed in EDMX and mapped to DB tables).

I have this two cases where i have to use not mapped properties.

-Class Party. Have a Enum property PartyType. This is an enum so i have created a property Int32 TypeWrapper that is used for wrap Enum and map it to DB. So i have already mapped this TypeWrapper (Int32) i cant set mapping also for PartyType (that is the enum). I would like to use this as not mapped property.

-Class Abstract Party. I have a class ABSTRACT party with a protected string property (protected string Description1...) . Company is a new type derived from Party where i hawe a Name property that wrap the Description1 defined on base class. So... Party hase been already configured for his mapping. In my test company has no other property to map so i just would like to set Name property to "not mapped" because Description1 is already mapped on Party mapping.

I am trying with  StorGeneretedPattern=Computed but still receive error 3004.
what can I do?



Is that possible to get more details instead of this message: "The mapping of type 'CodeFirstModel.Client' to table 'Account.Client' did not map all key properties."

A field list or at least the first missing property name should be helpful in a lot of cases during development.





I have a SharePoint site in which I have a photo database (picture library). The photographs are of different types of signs and each have metadata stored about them (for example, what type of materials were used, if the photo is interior or exterior, what type of sign it is, etc. Almost all of these columns are multiple selection fields). I want to be able to search this library by each of these metadata fields in the advanced search as a property restriction. (so look for an exterior monument sign for example).

I have been doing research and know that I need to perform a crawl of this metadata and then create a managed property. I have not been able to find a good step by step description of how to do this and I am looking for some help. I dont have a strong coding background or much familiarity with the sharepoint central administration site. Please help!

I have a “Pane” ControlType in my UI Control Map (in Test Builder) with a TagInstance of 189.  I clicked the Refresh Properties button in test builder and the TagInstance was updated to 190.  When I regenerate the code (“Generate Code” button -> “Generate” button) the TagInstance is still = 189 in the UIMap.designer.cs file.  Is this the correct way to update control properties?

Hi, I'm trying to display records from two different document lists in 1 result grid.

I have one managed property caled customernumber and the mapping has the customer numbers from the two different doc libs,

like: customernumber =  customnumdoclib1;customnumdoclib2

now, if there is a record match on both crawled properties, and my webpart has a grid field set to 'customernumber', shoul it return two rows?

one for each mapping? or will that merge the results in 1 row?


SQL Server 2005 SP3 32bit server
Connecting to an Oracle 10g server
Loaded OracleClient 10g

I'm able to ping the Oracle Server, and ODBC connect and able to run an open query with a single remote user id.

Issue: When I use the security context "Be made using this security context" it connects.
When I choose the "Not Be Made" WITH THE SAME USER ID & PASSWORD, I get the mapping error.




I am trying to create a utility to create a set of profile profile properties and map it to AD properties. It works fine when i create a property, but i am having issues mapping these properties to AD. if anyone had done similar to this thing, please help me with this issue.






When i open properties of a login and click user mapping tab it gets hanged. Even after 30 mins there is no response. How to resolve this issue. I am using SQL Server 2008 R2 + CU1.

This is happenning for 3 serevrs



Let's say I have two tables in the database: Vehicle and Document.

The tables and the data they contain are not related in any way.

I update my entity model and Vehicle and Document entities are shown. I then create a DataItem entity which has two properties: Id (int) and IsNew (boolean).

Have made Vehicle and Document inherit from DataItem following the instructions in this article:http://weblogs.asp.net/zeeshanhirani/archive/2010/05/24/how-to-share-common-fields-between-two-entities-that-map-to-different-tables.aspx

My problem is, the IsNew property in the DataItem entity does not map to any database column. It is only used by the business logic. However, I receive the following error stating that I have not mapped IsNew to any column.

Error 3 Error 3004: Problem in mapping fragments starting at lines 746, 761:No mapping specified for properties DataItem.IsNew in Set Documents.
An Entity with Key (PK) will not round-trip when:

My DataItem looks like this in the CSDL:


and the Document mapping section in C-S mapping looks like this:

Any thoughts?



I've setup the User Profile Service and synchronisation with AD works fine. Except for the Picture property. Our sys admins have setup the URL to the staff picture to be in extensionAttribute1 in AD, I can't change this, but I could map to it easily in MOSS 2007.

In SP 2010, I click on the "Picture" property in Edit User profile property, then click on the "Attribute" drop down list in the "Add New Mapping" Section. This list only contains a limited number of attributes and does not contain any extensionAttributes. Most other User Properties seem to have a full list of AD attributes to choose from, but not "Picture". Why??????

It seems very strange that extensionAttibute1 shows up in all the other property pages I have tried, even ones of type "URL".

Any tips would br GREATLY appreciated!!



Hi, I am trying to map a master connection property in MOSS 2007. And the Data source field to map box just isnt there for the master connection. What do I need to do to add this?

Here's a pic: http://imgur.com/sQ8rl.jpg 


I am using SharePoint 2010 and Office 2010.  I have promoted a couple fields as properties in a very simple excel document and created a document library with the document as the template. I have added fields to the library with the same name/data type as the promoted properties.   If I upload a local copy of the document to the library everything works as expected.  The values from the document end up populating in the appropriate fields of the document library item.  However, when I edit the document and save it, the properties do not update.  Additionally, if I click add document, select my template, fill it out and save it, the values do not map correctly. It instead uses the initial values in the template.  It seems the only time it works is on an upload.

I am trying to map the Job Title attribute to the AD Description attribute, I didn't find anything in the Attribute Mapping section that said Description, instead I found adminDescription (are they the same). Any help in accomplishing this would be appreciated. I can't use the default Job Title section as we have job titles in both English and French and some job titles don't fit due to their length, instead the Description field can fit more character.




Been looking online this morning for a method to bring part of how 2007 mapped user profile properties worked back in to 2010, or at least allow for manually setting the mapped attribute for a profile property.

So the problem is, I already have an AD field with everyone's picture as a URL (all good since the picture property in 2007 and 2010 by default is a URL field). In 2007 however I could manually type in this field, with 2010 it gives me a truncated list of properties it's seen and unfortunately has not seen the field that I have everyone's picture url in. Is their any method in 2010 to manually set a mapped attribute field? I've looked through stsadm and powershell commands with no luck. And so far everything I've read this morning is if I want to sync pictures back to AD from 2010.


In my example I have two classes like those:

public abstract class Party
        public Int64 Id { get; set; }
        protected PartyType Type { get; set; }  //This enum prop is wrapped by TypeWrapper
        protected string Description1 { get; set; }
        private Int32 TypeWrapper
            get { return (Int32)Type; }
            set { Type = (PartyType)value; }

public class Company : Party
        public Company()
            Type = PartyType.LegalPerson;
        public string Name { get { return Description1; } set { Description1 = value; } }
        protected string Code {get;set;}

Party class is used also for other extended classes (Person...) i would like to map this base class to db plus Company specific mapping inheriting mapping of base class DbSet<Company>. So... Party mapped to PartySet table and Company mapped to Companies table (only for those properties that extend base class)
Is it possible? how can i map protected properties of base class? Did i have to map also derived classes with specific configuration file and redirect new properties to correct column also if those are property that wrap property of base class (ex:Name  that wrap Description1 of inherited class)?



Hi All,

In my application I have defined three entities person, student and instructor. In person entity I have made some properties common for both student and instructor entities like id, name etc. Student and instructor entity have some properties which are specific only to them. In vs2010 when I try to map my student and instructor entity to their respective table (Student entity --> Student table in db and Instructor entity --> Instructor table in db) the properties of base class i.e. id and name are not available/visible in mapping details tab

In database I have three table’s person, student and instructor. I want to map all this tables to their respective entities but I also want to segregate and keep common properties in one base class i.e. person. 

I am implementing this in VS 2010 framework 4.0

Any help will be appreciated.




<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure