Home » Visual StudioRSS

Fail to install Microsoft Visual Studio 2010 Professional on Windows 7 Professional

I have tried to install Microsoft Visual Studio 2010 Professional several times without any success.
My computer is a 32 bit DELL Precision M4400 and my operative system is Windows 7 Professional (x86).

On the computer is Visual Studio Professional 2005 (SP1 + SP1 Update for Windows Vista) and Visual Studio Professional 2008 (SP1) already installed. I have a MSDN subscription license. I have tried to install Visual Studio 2010 from both the shipped DVD and an iso-image which I have downloaded from the MSDN web. The result is the same: “Unknown Error”.

When I uninstall Visual Studio 2010 then Visual Studio 2005 and 2008 fail to start. I have to do a repair to get them to work.

Om my computer I also have Windows XP mode installed as a virtual PC. In the XP mode I also have Visual Studio Professional 2005 (SP1 + SP1 Update for Windows Vista) and Visual Studio Professional 2008 (SP1) installed. When running XP mode there was no problem at all to install Visual Studio 2010 Professional. My conclusion of this is that my installation files must be alright.

On theWeb , I havenotfound anysolution tothe installation problem.

I have used the .NET Framework Setup Verification Tool and don’t find anything strange.

I have also used Microsoft Visual Studio and .NET Framework Log Collection Tool to create vslogs.cab file.

I don’t know how to get Microsoft Visual Studio 2010 to be successfully installed and urgently need you help to success.

Log-files and a PDF-document with screen dumps from the installation is available at http://www.iat.inadire.se/VS2010Problem.zip

Thanks in advance for help.

 

10 Answers Found

 

Answer 1

Hi jc02970,

Thank you for posting.

First of all, can you reproduce this issue on other windows 7 machines?

From your description and log files, I found some error information as follows.

[12/30/10,22:21:44] Microsoft Visual Studio 2010 Professional - ENU: CMSIDirectory::EnumerateVIProducts: Error enumerating Vertical Integration clients

I suggest you to disable UAC and try to reinstall it again. How to disable UAC?

In addition, I found a similar thread like yours. Please check it.

http://social.msdn.microsoft.com/Forums/en/vsexpress2008installationandsetup/thread/ee878641-4db6-44c4-9aac-85b4ca35de41

Best Regards,

Larcolais

 

Answer 2

Hi Larcolais,

Thanks for your reply.

I don't have another windows 7 machine so therefore I can't reproduce this issuse on another computer.

I have dissabled the UAC and I also have dissabled my virus protection software (Symantec Norton Internet Security version 17.8.0.5).

Then I have uninstalled Visual Studio 2010 Professional and Visual Studio 2008 Professtional.

After that I have to repair my Visual Studio 2005 Professional to get it able to run again.

Then I installed Visual Studio 2008 + SP1 without any problem.

Finally I tried to once again install Visual Studio 2010 Professional but it failed with the same result "Unknown Error".

When I type ‘Devenv.exe /SafeMode’ I only get a message box saying 'Unknown Error'

When I type ‘Devenv.exe /Log’ I only get a message box saying 'Unknown Error' but I can't find any log file.

I have also used Microsoft Visual Studio and .NET Framework Log Collection Tool to create a new vslogs.cab file which can be found at    http://www.iat.inadire.se/vslogs-2.cab

Best regards,

Janne



 

Answer 3

Hi jc02970,

Thank you for your feedback.

Regarding ‘Devenv.exe /Log’ command, it can generator a ActivityLog.xml on your machine. The file’s path is: %APPDATA%\Roaming\Microsoft\VisualStudio\<version>\ActivityLog.xml.

Please see: http://msdn.microsoft.com/en-us/library/ms241272.aspx for more detailed information.

If you have any concern, please feel free to let me know.

Best Regards,

Larcolais

 

Answer 4

Hi Larcolais,

The result of ‘Devenv.exe /Log' is now available at http://www.iat.inadire.se/ActivityLog-1.zip

Best regards,

Janne
 

Answer 5

Hi Janne,

I’m checking your installation log file and if I have any finding, I’ll let you know as soon as possible.

Thank you for your patient.

Best Regards,

Larcolais

 

Answer 6

Hi Janne,

Sorry for the late reply.

After I checked your log file, I found the following information. It looks that this issue might be related with license.

  <entry>

    <record>7</record>

    <time>2011/01/13 00:19:51.523</time>

    <type>Information</type>

    <source>VisualStudio</source>

    <description>AppId stopped registry detouring</description>

</entry>

First of all, I suggest you to download Visual Studio 2010 Professional Trial and install it on your Windows 7. Does it work?

If you have any finding, please feel free to let me know.

Best Regards,

Larcolais

 

Answer 7

Hi Janne,

Any update?

Best Regards,

Larcolais

 

Answer 8

Hi Larcolais,

No success so far.

To get as god resultat as possible I have:
+ Dissabled my anti-virus software
+ Dissabled the UAC
+ Uninstalled all previous versions of Visual Studio (2005+2008)
+ Uninstalled Visual Studio 2010 from the virtual XP-mode
+ Uninstalled Microsoft Office Professional 2010

This is what is left after I have removed 'as much as possible'

Then I install by using Visual Studio 2010 Professional Trial as you suggested but I got the same result as earlier (Unknown Error).
I have tried to install from the shipped  MSDN subscription DVD, the downloaded iso image from MSDN and finally Visual Studio 2010 Professional Trial version. All of them give the result and the installation fail to success although the setup program says that installation was successful. The setup.exe seem not to be aware of that a message with 'unknown error' was showed.
In a desperate attempt I also downloaded the en_ja_visual_studio_2010_sp1_beta_x86_x64_611999.exe it didn't solve my initial problem.

The "Unknown Error" allways occurs in VsaEnv_Setup_x86_enu. What is VsaEnv_Setup_x86_enu? Registry setup? Environment setup?

What is 'AppId stopped registry detouring'?

I have used CCleaner from www.piriform.com to scan for issues (not to fix issues) in the registry. It reports some missing shared DLL but I don't know if Visual Studio 2010 is dependent of any of thoose. See http://www.iat.inadire.se/VS2010/3/CCleanRegistryReport.pdf


I have once again used Microsoft Visual Studio and .NET Framework Log Collection Tool to create a new vslogs.cab file which can be found at http://www.iat.inadire.se/VS2010/3/vslogs-3.cab

 

 

I'm trying to install a Microsoft product (Visual Studio 2010 Professional) which I have licens to use, on an operative system from Microsoft. Is this really so impossible ? I have put an enormous amount of time to get this to work. And sometimes I have to reinstall earlier versions of Visual Studio to get them to work after I have uninstalled Visual Studio 2010. This is very annoying and time consuming.

What to do next?

Best regards,

Janne

 

 

Answer 9

Hi Janne,

Thank you for your detailed feedback.

Based on your description, did you use one license to active two VS product? I think you might consult license question to license experts.

Since the question is a license issue, you can call 1-800-426-9400, Monday through Friday, 6:00 A.M. to 6:00 P.M. (Pacific Time) to speak directly to a Microsoft licensing specialist, and you can get more detail information from there. Worldwide customers can use the Guide to Worldwide Microsoft Licensing Sites to find contact information in their locations: http://www.microsoft.com/licensing/

Best Regards,

Larcolais

 

Answer 10

Hi Larcolais,

I'mnot sureIunderstandwhat you intend.

Is thisreally alicenseproblem ?
Is notVisualStudio 2010ProfessionalTrial to beinstalledcorrectly inallsituations?
However , the program should notbe ableto start,if
the trial periodhas expiredand no valid licenseinformation exist.
 
During installationof Visual Studio2010ProfessionalTrial, Ihave neverbeen requested toenterany licenseinformation. Iassume thatit will function for severaldaysand thenclosed off whenthe trial periodends unlessIenter thecorrectlicense information .

Not onasingle occasion, the installationof Visual Studio2010 Professionalsucceeded onWindows 7.Not eventhe first timeI triedtoinstall VisualStudio 2010.
At that timethere wereno licenseratelimit thatallowedthe installationfailed.All installation attemptsgavethe same message'unknown error'.
Can itreallyaffect that Imanagedto installXPagain infashionon the same computer? ThattimeI used DVDfromthe MSDNsubscriptionthat Ihaveand I had allready done several attempt to install on Windows 7.

Furthermore: IfIhave avalid licenseof aprogram, I must be allowed to uninstallthe program andlater installitagain withoutgettingany kind of licenseproblem .

Someone whohasbeen creatingthe installationfile should be able toseethe specificlinethat is executed when the'unknown error'occurs ?Shouldnot someonebe able toprovide a moredetailed hintofwhat itisto be performed when theerroroccurs ?

Best regards,

Janne


 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter