Home » Visual StudioRSS

fresh install of vs c# express 2010. Error writing project file. Class not registered.

I've developed a wpf application on my laptop that I am now trying to move onto the production server so I can configure and deploy with clickonce.

I can open my solution, I can build it. And I can run it.

I cannot create a new project. When I provide a name/location and click ok I am given a dialog that states "Error writing project file"

And if I try to make any solution changes (rename assembly, modify application icon, assembly info data, etc) it tries to save a new copy of my csproj file. But it fails to do so and gives me a dialog box that says "An error occurred saving the project file 'wpfmodelviewapplication1.csproj'. Class not registered. Looking for object with clsid: {D9B3211D-E57F-4426-AAEF-30A806ADD397}.

 

I've looked around on these forums and this is a somewhat regular issue. I can't seem to find an exact fix for the solution however. Someone posted links to a Microsoft Connect support thread but it is currently unavailable so I have no clue what the fix is for it. I have read a couple of places that installing sql 2008 express sp1 will register this clsid for me. However, our customer's corporate software policies only allow for the existing sql installation that is already on the server which is sql 2000. Another copy, even of express, is not permitted.

Can anyone explain to me how to fix this? Was there not a hotfix for this, or a patch of some sort? For me, this is an out of the box failure. That's not good. And this is a dinky proof of concept demo so it doesn't need a "real" copy of visual studio hanging around so the express build seemed a perfect fit until I tried to use it.

one failed fix attempt i've tried is re-registering shell32.dll

the server which is running this software is running Windows Server 2003, sql server 2000, and visual studio 2003, service packs and hotfixes are up to date on everything installed.

Installation of vs2010 c# express was made with the All-In-One disc image downloaded from the express site.

 

7 Answers Found

 

Answer 1

Anyone who can help? Not being able to save changes to my csproj file really makes this whole IDE unusable.

I can't even increment a version number so that I can do a 2nd publish of my application through clickonce because it cant save edits to csproj.

So basically the "project" I drop onto this server with the corrupted install has to be 100% correct to build and publish even once. This ultimately forces me to make these changes back on the development machine and bring them back over to the server and hope the configuration is perfect.  I dont know if any of you can imagine how counter-productive that whole scenario is.

I simply wanted a local copy of vs2010 on the server so that simple last minute edits can be made without doing all this extra work. I really find it hard to believe that csproj is not supported since that configuration file has existed for many versions of visual studio now.

I've done a repair install. The problem persists. I'm going to uninstall it entirely and reinstall (but this time I am doing a web install instead) but if that does not fix it I am not sure what to do. The software development charges for this application did not include costs for a version of visual studio 2010 because we planned to use express for minor edits to this simple app. Never in a million years would I have thought that the express edition of vs2010 would not be able to work with my project which was developed in VS2010 Professional.

I had actually planned to do a lot of VS2010 professional development and deploy/run with vs2010 express in the future so this whole issue really creates a big problem for me and my future plans for deployment. Any help/advice would be appreciated...

edit: uninstalled and reinstalled using web installer. The issue persists. Unfortunately I do not have any more time to spend with the problem. The server will have to run without vs2010 express and we will have to do things the hard way. So much for relying on the express edition, I couldn't even reproduce a demo with it! I had a much better experience with the 08 express version when doing this same kinda stuff unfortunately for me the project relies on .net 4.0 components so 2008 express wont work here.

 

Answer 2

FWIW I'm having the exact same issue. This seems to happen on and off and I can't find a reason either.
 

Answer 3

Anyone?
 

Answer 4

I never reached a solution. At the last minute I had to purchase a copy of vs2010 professional to use on the machine.

I replicated the environment into a virtual  so that I could continue troubleshooting later if someone cares to have me try some things. We really need this version of express to work like the previous versions we grew to love. Little dinky one-off solutions shouldn't require a full license to use the environment effectively. I couldn't even rename the "windowsapplicationX" default name my solution was developed under without carrying the whole solution to another pc which had vs2010 pro on it. I couldn't edit a variable, save, and compile. Because the save failed to write the project file.

Nobody hits a home run first time up to bat even if they are a coding superstar so source code changes are going to happen during testing. The issues I have described here create a zero usability envrionment for myself and my coworkers.  I am not sure what other info I can provide but I'm not understanding how anyone can effectively work with express if their installs go like mine did.

I need to look at submission to Microsoft Connect. I've not done that before. Wasn't sure if Express was even a platform of support for that portal. Can someone confirm that for me?

 

Answer 5

I'm getting this problem when doing a "Save As" to a network drive in VS2010, professional.  HELP!

 

Answer 6

Encountered the same problem, was able to (at least appearantly) resolve it by copying a part of the registry of another machine.  Save the text between lines in a .reg file, and import it using regedit:

---------------

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{d9b3211d-e57f-4426-aaef-30a806add397}]
@="Shell Library API"

[HKEY_CLASSES_ROOT\CLSID\{d9b3211d-e57f-4426-aaef-30a806add397}\InProcServer32]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\
65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,00,00
"ThreadingModel"="Both"

  ---------------

EDIT: this didn't work... server install takes a month sysadmin waiting time.  Pretty screwed up.

 

Answer 7

This issue will come up when you dont run VS 2010 as an administrator.

So right click on VS 2010 express and select run as an administrator

Hope this will help.

 

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter