Home » Windows OS

Help: Setting up a VPC on Windows 7 machine

I've seen some articles on creating a VPC on Windows 7 and there seems to be different ways of doing this. One way is to use VPC 2007. There might be something special for Windows 7 that was not available for earlier OS'es (My host OS is therefore Windows 7 and my guest OS will be Windows Server 2008 R2). At work we have Windows 7 Professional. What I would like to find out is:
1. Should I use VPC 2007 on a Windows 7 machine? I want to install Windows 2008 R2, SQL Server 2008, and then TFS2010.
2. Is there a special VPC mode on a Windows 7 machine that I should use instead?
3. Once I get my VPC set up, can that virtual machine be connected to from other machines on our work network? I want to be able to have others machines connect to the TFS2010 on this VPC.
4. Are there any good documents that I could follow to set up this VPC?
5. Is there an existing VPC with TFS2010 RTM?
thanks in advance!
Bill Campbell

6 Answers Found


Answer 1

There's no way to install a 64-bit OS on either VPC2007 or Windows VPC, you'll have to use some other virtualization software.  (And Win2008 R2 is, I believe, 64-bit only)

Answer 2

Hi Bob,

Thanks much! You are correct - I cannot use Windows Server 2008 R2 as it is only 64bit. Looks like I'll have to go back to Windows Server 2003.

Did you have any ideas about the other questions? I have been reading more and it appears that I could use Windows Virtual PC if my processor has hardware virtualization. Otherwise it appears that there is something that I can install if it doesn't have it and still use the Windows Virtual PC. And I could as well just use VPC 2007. I don't know the benefits of one solution vs the other.


Bill Campbell


Answer 3

As long as you don't need 64-bit with Win2003, you can use either VPC2007 or Windows virtual PC (the new one), but I'd suggest the latter.  It has the ability to use more than one core if you are running more than 1 VM unlike VPC2007 (still only 1 core per VM), and it has the ability to use some USB devices.
2. is the Windows VPC I was talking about, and XP Mode is a downloadable VM if you have the proper version of Windows 7 that contains a license for it.
I don't really know about the rest.

Answer 4

Thanks Again. That's a good start for sure. I'll keep looking for the others.


Bill Campbell


Answer 5

1. Should I use VPC 2007 on a windows  7 machine? I want to install Windows 2008 R2, SQL Server 2008, and then TFS2010.
For a server operating system, you should be considering Virtual  Server rather than Virtual PC. However, Virtual Server 2005 R2 SP1 supports only 32-bit guest OS. Windows 7 does not allow Virtual Server to install or run. You will have to use this work around http://tfl09.blogspot.com/2009/08/windows-7-and-virtual-server.html inorder to run virtual server on your machine. 
2. Is there a special VPC mode on a Windows 7 machine  that I should use instead?
Windows 7 will not allow you to install Virtual PC. When the compatibility warning pops up, continue with the installation.
3. Once I get my VPC set up, can that virtual machine be connected to from other machines on our work network? I want to be able to have others machines connect to the TFS2010 on this VPC.
Yes, you can. IN the VPC settings dialog box, select one of the physical network adapters as an adapter for your VPC. Your VPC machine will be in your network like any other machine.
4. Are there any good documents that I could follow to set up this VPC?
Google was my documentation when I had to install VPC and Virtual Server on my Windows 7 machine.
5. Is there an existing VPC with TFS2010 RTM?
I am sorry, I don't know this one.

Answer 6

Check out http://www.virtualbox.org - VirtualBox supports Windows Server 2008 R2.

-Moiz Tankiwala PMP


Does anyone know how to resolve this?  I've installed and reinstalled Virtual PC 2007 SP 1` multiple times.  The result is always the same.

The settings for virtual machine "VisualStudio2010CTP" can't be opened because the virtual machine is in-use by another program, or marked as read-only.

Neither case is true.

OS is Windows Server 2008 Standard SP1.  Virtual PC does not recognize the OS.
Hi is there anyone who has try to install Virtual Machine Addition  on the image of Windows 7 inside Virtual PC?
I have managed to install all the Windows 7 SDK and all the Visual Studio 2008 + SP1 very well. But when it comes to Virtual Machine Addition for VPC it keeps on crashing and says it will restore my Windows 7 to the time where the windows 7 works. Anyone has encountered the same problem and have found the answer yet?

I have successfully built a Windows Embedded Standard 2009 image using the Target Designer.  The problem is, when I place the image files into an empty VPC and try and boot the VPC, an error message 'ntldr is missing' is shown.

The strange thing is, I have created an image which has previously worked, but now it fails to work and the error message above is shown instead.    It seems to the VPC is quite 'random' in deciding whether it works or not.  Every now and then, a different message appers (even though it's the same image) such as 'hard drive is corrupt' or a black blank screen appears forever.  I have tried creating another VPC but the same thing occurred.

Any idea on what could possibly be happening??

I am getting the below error when running a MSI on windows server 2003 VPC ,SP1 and sql server 2005.  Any help on this will be highly appreciated.

"The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2869. The arguments are: ErrorDlg"

The error log entry is as below

"The description for Event ID ( 11001 ) in Source ( MsiInstaller ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Product: Motorola PremierOne CommonServices Database -- Error 1001. Error installing database. See event viewer for details., (NULL), (NULL), (NULL)."


I'm sorry, but I didn't find better forum for my Virtualization question. I have image created in VPC 2007 SP1. I used this image in Windows Virtual PC 7 (Windows 7), and now it's not possible to use this image back in Virtual PC 2007 - the VPC completely crashes afdy knowter login into virtual image. Does anybody know how to solve it?



Hi all, 


Source machine is running Windows XP , PHP 5.3 and apache .

Destination machine is also a windows machine. 


I need to set date and time on the destination machine , using a php script. 

I searched online and could find nothing to help me. Could anyone of you please help me with this ?






Hi all,

I compiled the IFilter example from the Windows Search Sample Code Gallery (http://code.msdn.microsoft.com/windowssearch) on my Windows 7 x64 machine. The registration of the filter works fine - the properties created by the filter are searchable locally. When, I created a network share and connected a Library on an other Windows 7 PC to it. Again, the catalog can be searched by content even for the *.filtersample files. So far so good.

Then I installed Windows Search 4.0 on a Windows XP SP3 PC. I added the UNC path of the Windows 7 share to the XP machine. Then, it's possible to search for the name of the *.filtersample files. But it's not possible to use the file content as search-expressions. It seems, that the filled shell properties are not used.

Have anyone an idea why it's not possible to search a shared Windows 7 catalog for files which are index using the sample IFilter? The content of other file formats,  like *.txt, is searchable!

Best regards,


We have an application that is connecting to the remote registry via Winbatch. We have noticed that since running this application on all of our machines that have been upgraded to Windows 7 the application does not read certain registry entries on 64bit machines.

The registry path in question is HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon. It is missing about 5 values that when scanned from a Windows XP 32bit machine the application works correctly.

We've tried running the application under different compatilbility modes and nothing works. Any assistance would be greatly appreciated.

Here is my scenario:
1. I create a licence to be machine specific (locking->Machine)
2. I do an online activation of the licence on machine A: activation is successful (so far so good)
3. I do an online activation of the same licence on machine B: activation is successful and when I check the licence status on system B (using SLM.Licenses.GetLicenses), the licence state is valid.

For step 3, I was expecting either the activation to fail (as the machine B is not the same as Machine A) or the licence state to be StoreIdMismatch.

Am I wrong in my assumptions? If so, how should I lock a licence to a machine (one licence can be activated - as many time as the number of activations - on the first machine which activates it)

Hope I am clear enough.

Looking forward your swift answer,




I installed VS Professional 2010 on a Win 7 Ultimate computer.  Whenever I click on 'View Help' or 'Manage Help Settings' nothing happens...nada...zip...just sits there.  IE does not open up with a link to Help content.  I did a complete install of VS 2010...even F#.  Were there some additional steps I left out?  Anyonw else ever have this experiences? I've checked for updates and have the latest.



Hi there everybody,

today it's a quick question. I have to build (quite fast) a Volume Control Application and have problems with some of the Volume Properties thing.


I have the following:

A highly complex Visual appearance (too much to describe) 2 Buttons (Two of many)

My application should do the following at one stage:



1) Check if the Volume is muted or unmuted.

2) If the Volume is muted, mute it.

3) If the Volume is unmuted, set the volume percentage to 100%


1) Set the master volume to 0%.

2) Check if the volume is muted or unmuted.

3) If volume is unmuted, mute it.


These two options are only two of hundreds more. I do not have any 'Volume' related source code yet and Google only gives 1/5 of the information or the found code is in C++/C#. I do not have the time to convert those now.


A big thank you for all the (speedy) answers in advance.





how can i put the wss 3 i made on a clients machine?

is there e tutorial for this?


Hello everyone.

I have the need to increase the maxTimeout setting available in system.transactions section on the machine config. The default value of 10 minutes in not appropriate for my application and I wish to change it. The problem is that this cannot be done manually in a few hundred installations that we have. I would like to release a new version of our software that resolves this automatically. Any ideas on how to do this will be appreciated. I tried using the System.Configuration namespace without any success because the setting is "locked".

Hi guys!

Let me explain our situation. I do web development at a university at which we have to meet strict accessibility guidelines. I've specially modified the adapters (as well as extended CompositeDataBoundControlAdapter to include GridView) for use on our site and to use with our global stylesheets as well as compiled the control adapters into a DLL.

The control adapters now all reside in the WebServices.CssFriendlyAdapters DLL.  (For example, WebServices.CssFriendlyAdapters.GridViewAdapter).

Currently, when someone drops an App_Browsers folder in to their site with the adapters specified, the adapters work. However, we'd like to be able to specify this in the C:\WINDOWS\Microsoft.NET\Framework\(version number)\CONFIG\Browsers directory so that the adapters work automatically without anyone having to move anything into App_Browsers for every site. To ensure that someone can still use the "old way" or will not be confused by their controls being adapted, I've written in code that uses the base rendering methods unless xhtmlConformance is set to "Strict" in the site's web.config file.

Anyway, on to the problem. When trying to compile the controlAdapters into the C:\WINDOWS\Microsoft.NET\Framework\(version number)\CONFIG\Browsers directory using aspnet_regbrowsers.exe (see http://msdn2.microsoft.com/en-us/library/ms229858.aspx for documentation), aspnet_regbrowsers throws back an error saying that it can't find the adapter in the System.Web namespace.

Here's the controlAdapters section we're trying to add (I'm guessing the Default.browser file would work best, but we could add this to every browser definition file if we had to):

      <adapter controlType="System.Web.UI.WebControls.Menu"               adapterType="WebServices.CssFriendlyAdapters.MenuAdapter" />
      <adapter controlType="System.Web.UI.WebControls.TreeView"               adapterType="WebServices.CssFriendlyAdapters.TreeViewAdapter" />
      <adapter controlType="System.Web.UI.WebControls.DetailsView"               adapterType="WebServices.CssFriendlyAdapters.DetailsViewAdapter" />
      <adapter controlType="System.Web.UI.WebControls.FormView"               adapterType="WebServices.CssFriendlyAdapters.FormViewAdapter" />
      <adapter controlType="System.Web.UI.WebControls.DataList"               adapterType="WebServices.CssFriendlyAdapters.DataListAdapter" />
      <adapter controlType="System.Web.UI.WebControls.GridView"               adapterType="WebServices.CssFriendlyAdapters.GridViewAdapter" />
Note that when the App_Browsers folder with the control adapters is created in any site locally, the adapters work, so the adapters are indeed installed in the global assembly cache correctly. I have no idea why the adapters would be looking in the System.Web namespace.

Russ, I thought with as much contact as you've had with the developers you may be able to answer this one, or perhaps someone else with much more .NET experience than I have. I've been working with .NET for around 3 weeks, so I'm still a bit green, but I'm already excited about the time savings while still be able to adhere to good standards and accessibility practices!



from the moment i installed the agent on specific machine and run the test the IE6 is stuck and when i close it and reopen it the page cannot be display, even if i delete cookies and temp files from the browser. only after restarting the machine the site is loading again.

after investigating it i see that the IIS is down from some reason.

what is the problem here?



I have deployed a Web application on IIS 6. I want to prevent my server from setting cookie on the client browser. I am using the following setting on the web.config file.

< sessionStatemode="InProc"cookieless="false" />

 <authentication mode="Forms">
   <forms loginUrl="login.aspx">

However, it looks like its creating a default cookie named ".ASPXAUTH" in the client machine. I dont want my application to create any sort of cookie.

Is there anything specific I need to do in web.config?

Please help.

Thanks in Advance


When I have VS2010 help configured for offline, or local, help and my computer is connected to my local network, any attempt to get help through the Help Library Agent fails. If I'm using a browser, after a few seconds I get an error that a web page couldn't be found. If I'm using H3Viewer, it just hangs.

My computer is connected to my LAN which is connected to the Internet through a router.

When the attempt to lookup local help from the browser fails, the address that it claims it can't find is the IP address assigned to my router. That means, for some reason, Help Library Agent has bothered to go out on the net and hit a site that has tried to redirect it back to my computer which it *thinks* is at the address of my route...which, of course, it's not.

Everything works fine if I disconnect the computer from the LAN.

So, what I want to know is why the ____ is the stupid Help Library Agent hitting the net at all when I specifically told it to use offline help. No doubt someone at Microsoft considers themselves better informed about my intentions than I am and has it going out to look for updates or something annoying. *And* doing it wrong.

Of course, there's some tiny chance that it's just some obscure and undocumented configuration problem since nobody else seems to be complaining about this particular symptom.

It's completely unacceptable that my computer *HAS* to be offline to use offline help. It prevents me from getting other important stuff from the net like, oh, email. But I absolutely don't want this piece of trash hitting my network connection unless I specifically tell it to (I'm on a satellite and my data usage is already way too restricted without garbage software hitting it for the same info over and over.)

So...anyone have any thoughts on how this might be fixed?

Thanks for any help,



I tried to set a Cookies by Response.Chookies("chookie1") into a user's machine and found difficult to get the Cookies by Request.Chookies("chookie1"). I think that is because the person used various cs(User-Agent) (browser names?). Here are some of them:


In such case, how can I set Cookies to identify that machine?

Thanks a lot for any suggestions.

I think my title covers the high level, but for indepth; i need to be able to connect to a machine through and ip and set a enviroment variable, i have over 60 machines in different states all on one network that i need to do this for as well as someother things for the machine. currently this is being done through a PCEXEC command in a batch file they want more control on how this operates. I just really have no idea where to even start looking for the enviroment variable change(setting one on a machine that the app is running is simple we all know that. but on a external machine im lost) on a remote machine. any one have any ideas.

I have an event receiver hooked up to a custom document set.  In the ItemAdded event, I try to set a few columns.  This works on my dev machine, but doesn't work on my clients machine.  I first try to run it normally, then try to elevate permissions if it doesn't work.  I thought it was a permissions issue, but I am not entirely sure.  The worst part is that the behavior is not consistent.  If I create the doc set multiple times in a row, I get different results.  Sometimes I get an error on the doc set creation phase and it looks like it fails, but when I go back to the doc library it exists.  Sometimes the doc set is created but the columns are not set.



        public override void ItemAdded(SPItemEventProperties properties)
            Logger.Log("ItemAdded:Doc Set:ENTER");

            if (properties.EventType != SPEventReceiverType.ItemAdded) return;

            EventFiringEnabled = false;
        SPListItem listItem = properties.ListItem;

        bool elevateTITLE = false;
        Logger.Log(string.Format("ItemAdded:Doc Set:NormalPriv:Title, rev date"));
        listItem["Title"] = listItem.Fields["Name"];
        listItem["Experiment Review Date"] = System.DateTime.Now;
        catch (Exception ex)
        Logger.Log(string.Format("ItemAdded:Doc Set:NormalPriv:ERROR Title, rev date"));
        elevateTITLE = true;
        if (elevateTITLE == true)
            Logger.Log(string.Format("ItemAdded:Doc Set:ELEVATED:Title, rev date"));
            listItem["Title"] = listItem.Fields["Name"];
            listItem["Experiment Review Date"] = System.DateTime.Now;
        catch (Exception ex)
            Logger.Log(string.Format("ItemAdded:Doc Set:ELEVATED:ERROR Title, rev date"));
            elevateTITLE = true;


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure