Home » SharepointRSS

Http 500 Internal server error for all sharepoint site

Hi,

I am having a problem browsing to all sharepoint sites except Central Administration.  I create a few sites using the default template but same error when try browsing to it.  I have even run the "configuration wizard" to detach the database, delete all database, rerun "configuration wizard" but still, the issue is still there.

This is the error Iam getting:

MODULE_SET_RESPONSE_ERROR_STATUS

ModuleName

IsapiModule

Notification

128

HttpStatus

500

HttpReason

Internal Server Error

HttpSubStatus

0

ErrorCode

0

ConfigExceptionInfo

Notification

EXECUTE_REQUEST_HANDLER

ErrorCode

The operation completed successfully. (0x0)



Please help!
 

5 Answers Found

 

Answer 1

Whe you detached the DB's from the farm did you clean out IIS and other SharePoint folders before your ran the config wizzard?  
 

Answer 2

Hi Kris,

Do you mean delete the port number folder under IIS directory? and which sharepoint  folders?  Please let me know.
 

Answer 3

Hi Myworkxp,

The error  message is too general and there are many reasons which may cause this error. What’s the version of your WSS or MOSS? If you are using WSS 3.0 or MOSS, I strongly suggest you install SP2 first and run post configuration wizard. At the same time, check the event viewer to find more detailed error message and paste it here.

Let me know the result if possible, thanks.

Lu Zou

 

Answer 4

Hi Lu Zou,

Sorry for the delay reply.  The server  has sp2 installed.  Version 12.0.6425.100.  There is no error  in the event viewer or the log file when I try to browsing to the page.  However, there's a consistence error in the event viewer happen throughout the day:

The description for Event ID 27745 from source Windows sharepoint  Services 3 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

#50071: Unable to connect to the database SharePoint_Config on ******. Check the database connection information and make sure that the database server is running.

the message resource is present but the message is not found in the string/message table.


Again, none of the sharepoint site  is woking, but sharepoint central administration is.




The database is running fine.
 

Answer 5

1) Does these account's  have access to central admin root folder??

wss_wpg

wss_admin_wpg

2) In order to change the Central Administration Application Pool account we have to go to the Command Prompt(with Administrative credentials) and issue the following statement from the 12 hive (which is under C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin) :

stsadm -o updatefarmcredentials -userlogin <DOMAIN>\useraccount -password <password>

After that we must issue the iisreset /noforce command.

Try changing the app pool identity using above command and see if it works for you

Also refer this link

http://weblogs.asp.net/erobillard/archive/2007/07/06/how-to-change-service-accounts-and-their-passwords-in-moss-and-wss-3-0.aspx

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter