Home » Windows OS

install dll into windows/SysWOW64 windows/system32 on Windows 7

In order for the 3rd party graphing component to work (Gigasoft ProEssentials), it requires that a dll be installed in windows/system32 and/or windows/sysWOW64.

Manual installation of this dll into either of these folders on Windows 7 didn't work. I had to:

go to Control Panel/Action Center click on 'Change User Account Control settings' Move slider to bottom 'Do not notify me when I make Changes to Windows Settings'

How can I achieve the installation of this dependency dll using Setup Deployment. NOTE: this is not a project dependency in Visual Studio and I don't believe this dll (PEGRPDL.DLL) is a .NET component.

Thank you,



4 Answers Found


Answer 1

Getting it installed  into the SysWOW64 folder needs a setup  project targting an x86 platform, and in the File System view right-click on File System on Target Machine will let you choose the System folder for the Dll.

I'm not sure why you're worried about the Dll being .NET. MSI-based setups have been installing apps since before .NET existed - it's not a .NET thing at all.


Answer 2

For MSI, I don't think your MSI package specifically has to be set up to target an x86 platform.  Rather, the MSI component  (with your file as the component's keypath) must NOT be set up as a 64-bit component (must not have the msidbComponentAttributes64bit bit flag set in the component attributes).  If that attribute is not set for the component, then you can include the component in an MSI package that targets x86 or one that targets x64 (or in both).

As long as the target directory defined for the component uses the [SystemFolder] property, then the file will get installed  to %windir%\system32\ when the package is installed on x86 systems and to the %windir%\SysWow64\ location when the package is run on x64 systems.

P.S. I'm not sure about security though.  You may have to require you're users to run the installation  with elevated priviledges on Windows 7 systems ('Run as Administrator') in order  to install  files to the system folder.  You'll need to check that.


Answer 3

Hi hazz,


VS setup  project’s special folder System Folder refers to System32 while System (64-bit) Folder refers to SysWOW64. On the contrary, getting it installed  into the SysWOW64 folder needs a setup project  targting an x64 platform. If the setup target x86, you will see error message “The destination path of folder 'System (64-bit) Folder' is not compatible with the project's target platform 'x86'” when building.



Kira Qian

MSDN Subscriber Support in Forum

If you have any feedback on our support, please contact msdnmg@microsoft.com

Answer 4

I am writing to check the status of the issue on your side. Could you please let me know if the suggestion works for you? If you have any questions or concerns, please feel free to let me know. I will be more than happy to be of assistance.


I  just setup VisualStudio 2010 and tried to debug my program, It runs very very slow at the first time.

So I watched output window, and figured out this is the reason slows my application down.

'myApplication.exe' : Unloaded 'C:\Windows\SysWOW64\wbemcomn.dll'

At this point, it takes about a minute.

I can not see if that dll file is loaded in visual studio 2005 cause I've already deleted VS2005, but at that time(when I was using VS2005) I had no problem with loading speed.

Can anyone help me with what that is and how can I fix it?

I'm not a tech person.  I have Windows XP Professional on a Dell Optiplex 170L.

Powering up Wednesday, I received the message, "Windows could not start because the following file is missing or corrupt: \WINDOWS\SYSTEM32\CONFIG\SYSTEM."

I've done the Internet search for answers, trying every possible solution that I could find.

I printed Microsoft Support Article 307545 and have tried to work my way through it using Windows Recovery Console and my system's Windows XP Reinstallation CD, changing BIOS to start up from the CD ROM drive, etc.

First, using another computer, I downloaded Guided Help both to a CD and to a flash drive and tried to upload that to my computer but the file would not read.

Then, I followed the "manual steps to recover a corrupted registry" (referred to by 307545).  I was unable to copy the first file ( c:\windows\system32\config\systemc:\windows\tmp\system.bak ) which is mentioned.   The system told me that the file could not be copied.  I did successfully copy the remaining four files which I was directed to copy.  However, after being unable to copy the one, I did not proceed with deleting/copying the other files as instructed.

I have even tried some other suggested steps, including opening the casing, disconnecting the hard-drive cables from the motherboard and waiting a couple of minutes to see if the system would reset -- all to no avail.

Am I doomed to reloading Windows and wiping out all of the data on my hard drive?


I need to know what the performance bottlenecks are, and what the functions are trying to do, within an IE 8 instance.

I can attach to the process successfully, and generate a performance report successfully, however the resolution stops at mshtml.dll.

After ceasing data collection, I get the following in the output tab within VS. I believe it is related:

Symbol Engine: Failed to load matching symbols for module 'C:\WINDOWS\Symbols\dll\mshtml.pdb'

I am using IE8 on Windows XP Professional with SP 3. It is not the check/debug version.
I am running VS Team System 2008, Development Edition.
I have downloaded and installed symbols from here: http://www.microsoft.com/whdc/devtools/debugging/symbolpkg.mspx
I tried running an instance after this and it still gave the failed to load symbols output.

Within VS I have gone into Tools>Options>Debugging>Symbols and added the following three symbol files locations:

Note: the buttons 'Load symbols using above locations' and 'Load symbols from Microsoft symbol servers' are greyed out.
In the textbox 'Cache symbols from symbol servers to this directory' I put c:\SymbolCache
I tried running an instance after this and it still gave the failed to load symbols output.

Note: I don't know if the 'debug' option area even applies, however there is no symbol setting interface within the Performance Tools option section.

Following this thread: http://social.msdn.microsoft.com/Forums/en/vstsprofiler/thread/db1e2ad9-3161-4f67-b781-6e7b83273c2d
I saved the performance .psess file to a static location and copied mshtml.pdb from c:\windows\system\mshtml.pdb to the same location.
Re-running a capture resulted in the same output:
Symbol Engine: Failed to load matching symbols for module 'C:\WINDOWS\system32\mshtml.dll'

To reiterate; performance explorer is working fine... I just need it to be able to 'dig in' to mshtml.dll.

I think the underlying questions are simple: Why can't it do so, and how do I get it to?

This comes up as a prefix when searching, whether it's bing, yahoo, google, anything. It even happens in other browsers like firefox.  It's only when typing something to search.  What display is "Server not found".
How can I get rid of this without dumping and reloading my whole WinXP pro SP3 system?
This comes up as a prefix when searching, whether it's bing, yahoo, google, anything. It even happens in other browsers like firefox.  It's only when typing something to search.  What display is "Server not found".
How can I get rid of this without dumping and reloading my whole WinXP pro SP3 system?

My setup project has a registry key



these needs to be 


when installing on 64 bit windows.

Is there a macro I can use or will this have to be done in a custom action?



I have reference of iTextSharp.dll files required to create pdf files on Windows XP Pro and Visual Studio 2008, which when deployed runs fine. If I run using ASP.NET Development server in Visual studio 2008 / windows 7 it works fine too.

But if I try to deploy the application on IIS 7 and use Visual Studio 2008 to publish it. After I open it in web browser, I get this error.

Please help me here. Thanks.

Could not load file or assembly 'iText' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.BadImageFormatException: Could not load file or assembly 'iText' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Assembly Load Trace: The following information can be helpful to determine why the assembly 'iText' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Stack Trace:

[BadImageFormatException: Could not load file or assembly 'iText' or one of its dependencies. An attempt was made to load a program with an incorrect format.]
   System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0
   System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +416
   System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +166
   System.Reflection.Assembly.Load(String assemblyString) +35
   System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +190

[ConfigurationErrorsException: Could not load file or assembly 'iText' or one of its dependencies. An attempt was made to load a program with an incorrect format.]
   System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +11207304
   System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +388
   System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +232
   System.Web.Configuration.AssemblyInfo.get_AssemblyInternal() +48
   System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +210
   System.Web.Compilation.BuildProvidersCompiler..ctor(VirtualPath configPath, Boolean supportLocalization, String outputAssemblyName) +76
   System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(Boolean isPrecompiledApp) +283
   System.Web.Compilation.BuildManager.CompileGlobalAsax() +50
   System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +676

[HttpException (0x80004005): Could not load file or assembly 'iText' or one of its dependencies. An attempt was made to load a program with an incorrect format.]
   System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() +76
   System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +1012
   System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) +1025

[HttpException (0x80004005): Could not load file or assembly 'iText' or one of its dependencies. An attempt was made to load a program with an incorrect format.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11301302
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +88
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +11174792



Hi Folks,


I’m working on upgrading Commerce Server 2000 to Commerce Server 2009 and facing issues with the out-of-box DLL (CatalogCS2000XmlImport.dll) to import catalogs from an XML file using the following code snippet


CatalogCS2000XmlImportClass cs200Obj = new CatalogCS2000XmlImportClass();

catalogCS2000XmlImportClass.ImportXml(strCS2009SiteName, fileName, false, true);


This code works fine in Win Server 2003(32 bit) machines and importing the file in couple of seconds. But, when the same ran on Win Server 2008 (32/64 bit), it is taking nearly 50min to import the catalog.


Highly appreciate your help in resolving this.





I needed to install IdentityTrainingKitApril2020.VS2010, it made me install WindowsIdentityFoundation-SDK-4.0.

But setup WIF SDK fails with this message :

  "Setup has detected that .NET Framework 4.0 is not installed on the system. Please choose the correct WIF SDK(3.5/4.0) installer based on the version of 

   the .NET Framework you intend to use."

My Machine : Windows 7 Enterprise, VS2010 Professional RTMRel Version :10.0.30319.1 . NET Version:4.0.30319 RTMRel.

 I have installed : Windows6.1-KB974405-x86 (WIF Runtime)



Here's the most straightforward way to set up SS for WM.  Reply if you have any installation hiccups.

Download and run WindowsSideShowForWindowsMobile.exe on your PC, and open the folder it was installed to.

Connect your phone to your computer over USB and select "Open device to view files".

If the .NET Compact Framework 2.0 or later is not installed on your device (it is not on most Windows Mobile 5 devices), install it:

Copy NETCFv2.wm.armv4i from the installation folder to the My Documents folder on your device.

On the phone, open File Explorer.

Open NETCFv2.wm.armv4i in File Explorer, and follow the instructions to restart the device.

Connect your PC to the Internet if it is not already connected.

Drag WindowsSideShowForWindowsMobile.CAB to the My Documents folder on the Windows Mobile device.

On the phone, open File Explorer.

In File Explorer, select WindowsSideShowForWindowsMobile.CAB in the My Documents folder. Click OK if you get a publisher warning. The program will install on your phone.  Note:  Installation adds a plug-in which allows you to see SideShow glance data on your Phone’s home screen.  This may switch your layout from what you had previously.  To toggle layouts, open the home or today screen settings page on your phone.

From your PC, pair and connect your phone over Bluetooth.

On the device, click the Start button, click Settings, click Connections, and then click Bluetooth. Turn Bluetooth on and make the phone discoverable.

On your Windows Vista PC, open the Bluetooth Devices control panel, and then click Add.

Select your device and click Pair. If you do not see your phone, make sure it is in discoverable mode, and that there is a Bluetooth adapter connected to your PC and turned on.

Select "Let me choose my own passcode", and then enter a passcode.

A dialog box will appear on the phone asking you to enter the passcode.

Enter the passcode and then press return. If notifications to enable other services come up, click Allow All Connections.

When a message appears on the PC to install driver software, click Locate and install driver software.

After the drivers install, go to your phone's home or today screen, where you will see the SideShow logo with the text not connected (you may have to scroll to see this). Select the text. If you do not see this text, click the Start button, click Programs, and then click Windows SideShow.

If you get an error saying you do not have the latest version of the .NET Compact Framework installed, perform step 3 to install the .Net Compact Framework. Remove and reinstall Windows SideShow for Windows Mobile by clicking Start, clicking Settings, clicking Remove Programs, clicking Windows SideShow, and then clicking OK. Then start again at step 7.

Wait a few seconds for the phone to connect. If it does not connect automatically, click the Connect button on the lower left. Your phone may take up to 30 seconds to connect. If the phone does not connect, try turning it off and on, and see the“Troubleshooting – Phone fails to connect” section in the readme.

Choose your user account on the phone, when prompted. You can change this later by clicking Menu.
If you do not see your username in the drop down, it may be due to an ActiveSync partnership using a domain and username different from that on the computer you are using.
Open the Windows SideShow control panel to pick gadgets to use on your phone. You can click the "Get more gadgets online" link at the bottom of the screen to access the Windows SideShow section of the Windows Live Gallery.

I have tried twice to install windows XP Embedded with SP3 on to my windows 7 development machine with no luck.
When the install completes I cant run the target designer or component manager as both complain that the SQL database is missing.

I've tried following the vista install notes I found elsewhere on the web but this too has failed. does anyone know how you are supposed to
get an XPe development enviroment set up on windows 7? I can't be the only one who's tried this.



not sure if this is the right forum. I am just getting started with code development in windows. Anyway, i've written a simple service and build it. When i try to install it on a windows 7 machine i get: 


An exception occurred during the Rollback phase of the System.Diagnostics.EventLogInstaller installer.

System.Security.SecurityException: The source was not found, but some or all event logs could not be searched.  Inaccessible logs: Security.


When i install it on windows server 2008 r2 i works as expected. So what is the difference? I am installing from the same executable.

edit: to give some more detail: I am basically just using the service template in Visual Studio 2008 and adding the installer to it.


I am having issues installing Open License Visual Studio 2008 on a Windows 7 64 bit machine, and a Windows XP 64 bit machine.

The software says it is incompatible with 64bit, 

The trial version of Visual studio 2008 works on Both machines.  One has expired the other has 3 days to go.


The error presented is "The version of this file is not compatible with the version of windows you're running. Check your computers system information to see whether you need x86 (32bit) or x64 (64bit) version of the program, and then contact the software publisher.



Can i install windows server 2008 as a virtual macnine in Windows 7 laptop, If yes can you provide me some links for the process.

My aim is to run windows server 2008 and windows 7 in same laptop


I tried to install sharepoint 2010 in windows 7 I got the following error:

Setup is unable to proceed to the following error(s):

this product requires windows server 2008 Service Pack or above

Correct the issue(s) listed above and re-run setup



how to install window service in window's schedule task using C# ? if possible than give an example.

It fails at start ...

Tried to reinstall MSVC++ but nothing happend ... on this link find nothing interest ( this error i got both from ISO and web version )
Is any hint where to look a problem ?

Error message
A problem occurred while installing selected Windows SDK components.

Unknown product: {BC465213-5F05-46D4-8C00-90B27515D7D2}

Parameter name: productCode

Please attempt to resolve the problem and then start Windows SDK setup again. If you continue to have problems with this issue, please visit the SDK team support page at http://go.microsoft.com/fwlink/?LinkId=130245.

Here is installation log:

20:35:34 24. kvetna 2009: -------------------------------------------------------------------------------------------------

20:35:34 24. kvetna 2009: [SDKSetup:Info] Begin

20:35:34 24. kvetna 2009: [SDKSetup:Info] SDKSetup Version 7.0.7061.324

20:35:35 24. kvetna 2009: [SDKSetup:Info] SDKSetupDll_DoTasks: Starting

20:35:36 24. kvetna 2009: [SDKSetup:Info] SDKSetupDll_DoTasksWithGUI: Starting

20:35:38 24. kvetna 2009: [SDKSetup:Info] Config_OS_Detect: Operating system installation (detected)

20:35:38 24. kvetna 2009: [SDKSetup:Info] Config_MSI_Detect: Windows Installer Setup (detected)

20:35:38 24. kvetna 2009: [SDKSetup:Info] Config_Products_DetermineProductState_Begin: Product: Microsoft Windows SDK for Windows 7

20:35:38 24. kvetna 2009: [SDKSetup:Info] Config_Products_DetermineProductState:       Product: Microsoft Windows SDK for Windows 7;  Installed: Unknown;

20:35:38 24. kvetna 2009: [SDKSetup:Info] Config_Products_DetermineProductState_End:   Product: Microsoft Windows SDK for Windows 7


I get the following error when trying to install the following:

Microsoft® Windows® Software Development Kit (SDK) for June CTP of Windows Vista and .NET Framework 3.0 Runtime Components

The error that I get when I click of the Setup.exe is:

SDKSetup encountered an error: Failed to download the file

http://download.microsoft.com/download/3/B/C/3BC8831B-75D4-43F0-BAC5-4574DBEBC332\SDKSetup.xml.  Error - The remote server returned an error: (407) Proxy Authenication Required.

It failed on my Laptop after the first or second component so I tried it on PC. It fails on "Microsoft Visual Studio 2010 Ultimate - ENU" Every time without even getting past 0% on that particular progress bar. This was a disk made by a professor and he said he put custom files (such as models) on it. I would think maybe that's what messed it up but if that's the case everyone in the class wouldn't be able to install.. It must be just me or he would have sent out an email. What should I do, copy in the full setup log or something?


I tried installing the WPF Performance Toolkit, in order to get the Perforator tool, installing it from the Windows SDK 7.0, however when I tried attaching my process, all the items on the Select a Process dialogs were disabled, and when launching the executable it told me that it was unable to attach.

So I did a bit of digging around, and got to the conclusion that I needed to install it through the Windows SDK 7.1 for .NET 4.0 support - now, however, the Install Windows Performance Tool Kit item isn't in Start Menu -> All Programs -> Windows SDK 7.1 -> Tools like it was in Windows SDK 7.1 -> Tools.

Does anyone have an idea how to install it?




<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure