Home » Visual Studio

how to install extension (.vsix)

I'm trying to install a .vsix file (I downloaded it from the Gallery)

Double clicking the file doesn't work it gives me the following message:

the extension is not installable on any currently installed products

I tried the Extension manager in VS2010 (Tools->Extension Manager) however there is no option to import for example extensions from local machine!

The Online Gallery gives me an error saying:

Cannot search for online extensions because an error occured while trying to contact server!!

So how to add the extension that I downloaded it?


4 Answers Found


Answer 1

Double-clicking the vsix  should normally install  the extension. From the error message  I assume that the extension  requires a higher Visual Studio edition than the one you have installed. Which edition of VS do you use? Which extension did you try to install?

Answer 2

I'm using Professional Edition


Microsoft Visual Studio 2010
Version 10.0.30319.1 RTMRel
Microsoft .NET Framework
Version 4.0.30319 RTMRel

Installed Version: Professional

Microsoft Office Developer Tools   01018-532-2002102-70213
Microsoft Office Developer Tools

Microsoft Visual Basic 2010   01018-532-2002102-70213
Microsoft Visual Basic 2010

Microsoft Visual C# 2010   01018-532-2002102-70213
Microsoft Visual C# 2010

Microsoft Visual C++ 2010   01018-532-2002102-70213
Microsoft Visual C++ 2010

Microsoft Visual F# 2010   01018-532-2002102-70213
Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Team Explorer   01018-532-2002102-70213
Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010   01018-532-2002102-70213
Microsoft Visual Web Developer 2010

Crystal Reports Templates for Microsoft Visual Studio 2010  
Crystal Reports Templates for Microsoft Visual Studio 2010

Microsoft Visual Studio 2010 SharePoint Developer Tools   10.0.30319
Microsoft Visual Studio 2010 SharePoint Developer Tools


Answer 3

Architecture Layers Patterns is the extension  that I'm trying to install

Answer 4

That is an extension  for the layer diagram, which requires the VS Ultimate edition. VS Professional does not include layer diagrams, therefore you cannot install  the architecture layers patterns extension.




VSIX packages are a great thing, I love the ease of deployment that they supply. However, there is a BIG feature missing. You can not deploy MSBuild extensions to the well-known MSBuild directory. This is a showstopper for me, and anybody else developing full language/compiler integration packages. The workaround provided by the IronPython integration sample is simply not acceptable. I would love be able to use a VSIX, but for now, I'm stuck with using .msi's. A quick search online shows that I'm not the only one that wants to be able to do this.





Just wondering if the VS team is aware of this scenario and if MSBuild tasks are going to be added to the possible output groups for a VSIX in the near future (SP1 please?), or if I should go ahead and create a Connect enhancement.



Hey guys!

Unfortunately I can't upload my extension to your gallery. After digging through different forums I tried to manipulate with different browsers, cookies and other stuff - but result is still the same.

An error occurred while processing your request.
And that's all:) All .vsixmanifest info seems to be fine.
I also wondering why you can't provide some more diag info:(
P.S.: I also didn't checked Express Editions checkboxes - just Professional, Ultimate and Premium. 


when trying to upload my VSIX package into the Visual Studio gallery I receive the error:

Path may be too long in VSIX.

This makes no sense since I can install the VSIX just fine by double clicking it. Does anyone have a pointer to enlighten me about what specific path may be too long? My package name is SharePointDevTools.vsix, and inside the package I have a few templates that go about 5 subfolders deep (CSharp\SharePoint\2010\1033 or something)



Now that VB Express has the Extension Manager you'd think it would be easy to install extensions, but I haven't found out how to do it yet. I've downloaded a couple of VSIX files to try it out: ItalicComments.vsix and ThemeManager.vsix. Double clicking on either of these files always gives the message "This extension is not installable on any currently installed products". Of course, I do have VB 2010 Express installed.  Could these VSIX files really be uninstallable in Express, or otherwise how should I do it?

I found tried using VSIXInstaller.Exe (in Common7/IDE) directly but so far without success. Maybe I am muddling the syntax.

tia, BB


My Enviornment

 Visual Studio 2010 Ultimate with Visual Studio 2010 SDK  & GAX installed.

The installation of Service Factory 2010 fails with following errors n exceptions


Found installed product - Microsoft Visual Studio 2010 Ultimate
The extension with ID '306C9B2B-E7C7-4E03-B4E9-F62CCD292AAB' is not installed to Microsoft Visual Studio 2010 Ultimate.
The following target products have been selected...
Microsoft Visual Studio 2010 Ultimate

Beginning to install extension to Microsoft Visual Studio 2010 Ultimate...

 Install Error : Microsoft.VisualStudio.ExtensionManager.NestedExtensionInstallException: The extension 'E3821E6E-C0AD-4F8F-B300-DE95E9776716' nested within '306C9B2B-E7C7-4E03-B4E9-F62CCD292AAB' failed to install.
The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters. ---> System.IO.PathTooLongException: The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.
   at System.IO.PathHelper.Append(Char value)
   at System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32 maxPathLength)
   at System.IO.Path.GetDirectoryName(String path)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.WriteFilesToInstallDirectory(InstallableExtensionImpl extension, String installPath, ZipPackage vsixPackage, Dictionary`2 extensionsInstalledSoFar, AsyncOperation asyncOp, UInt64 totalBytesToWrite, UInt64& totalBytesWritten)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstallInternal(InstallableExtensionImpl extension, Boolean perMachine, Boolean isNestedExtension, Dictionary`2 extensionsInstalledSoFar, List`1 extensionsUninstalledSoFar, AsyncOperation asyncOp, UInt64 totalBytesToWrite, UInt64& totalBytesWritten)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstallNestedExtensions(InstallableExtensionImpl parentExtension, ZipPackage parentVSIX, Boolean perMachine, Dictionary`2 extensionsInstalledSoFar, List`1 extensionsUninstalledSoFar, AsyncOperation asyncOp, UInt64 totalBytesToWrite, UInt64& totalBytesWritten)
   --- End of inner exception stack trace ---
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.BeginInstall(IInstallableExtension installableExtension, Boolean perMachine, AsyncOperation asyncOp)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstallWorker(IInstallableExtension extension, Boolean perMachine, AsyncOperation asyncOp)

Please let me know how I can fix this issue.


Is there any API to detect that a newer version of an installed vsix is available in the Gallery (the Extension Manager can!) ? I would like to make the update notification more visible. (I can see this has been done for the Vs 2010 Power Tools)






VSIX does not support XML schemas installation (*.xsd files).

I got the following code that can do the job (copying the schema to Schemas directory) :

IVsExtensionManager extensionManager = this.GetService(typeof(SVsExtensionManager)) as IVsExtensionManager;

XmlLanguageService xls = (XmlLanguageService)this.GetService(typeof(XmlLanguageService));
string schemasPath = xls.XmlPrefs.SchemaCacheLocation;

IVsShell shell = this.GetService(typeof(SVsShell)) as IVsShell;

object obj2;
shell.GetProperty((int)__VSSPROPID2.VSSPROPID_InstallRootDir, out obj2);

if (obj2 != null)
  string str = obj2.ToString();
  if (str != null)
    if (str.EndsWith(newstring(Path.DirectorySeparatorChar, 1)))
      str = str.Substring(0, str.Length - 1);
    schemasPath = schemasPath.ToLowerInvariant().Replace("%vsinstalldir%", str);

IInstalledExtension extension = extensionManager.GetInstalledExtension(GuidList.guidPackagePkgString);
  Path.Combine(extension.InstallPath, @"Schemas\mySchema.xsd"),
  Path.Combine(schemasPath, "mySchema.xsd"));


But I don't know where to add it to be executed each time the extension is loaded. Any idea ?


- Bruno


...and if so, how?

I have a VS2008 MSI-installed package that I'm moving forward into the VS2010 world. I wanted to give the VSIX model a try, since it _seemed_ easier both to implement and the users to run. Part of my package is a custom file type + editor.

I've managed to jump through the hoops to make VS2010 put my ItemTemplate in the "Add New Item" dialog, but when I proceed, I get a hostile "The following template is requesting to open one or more documents in a manner that could pose a security risk.....", with a looong path to an unpacked copy of my ItemTemplate zip file.

Now, I've read elsewhere that VS does this because the itemtemplate is not in a "trusted place". I'd like my users not to see this dialog -- I'm hoping they're trusting me when they run my VSIX installer. So, can I have the VSIX file I'm generating place the templates under $(VSINSTALLDIR)\Common7\IDE\ItemTemplates, which I'm guessing is considered a trusted place? How?

If this is not possible, it seems I'm going to have to abandon VSIX deployment for package, which is a shame.


I have an Isolated Shell solution that works fine and I want to be able to deploy a .vsix in it, preferably, just by double-clicking on it.
I've tried to specify the Isolated Shell as a supported version of my vsix (I'm actually not sure about the Shell ID value I should put in the vsix manifest. See http://social.msdn.microsoft.com/Forums/en/vsx/thread/0294609b-47c7-49f8-97b6-009cf145511b)
When I launch the vsix file, Visual Studio 2010 is the only version that I can check.



I am attempting to install GAT/GAX SCSG and WCSF.

GAX appears to be the first pre-requisite, however, I get the following error:

"The extension could not be installed because the following error occurred:

The file is not a valid VSIX package."


I have installed the VS2010 SDK

Operating System: Windows 7 X64 Enterprise

VS2010 RTM Professional

VS2008 Professional SP1

I already have the following extensions installed successfully in 2010:

PowerCommand for Visual Studio 2010

Enterprise Library V5 Configuration Editor

I get the same error message about invalid VSIX when I try to install any of the other P&P extensions

I think this may be because I have both VS2008 and VS2010 installed.

Has anyone got any ideas?


If you want to do a lot more with Small Basic, a good starting piont is to install Fremy's Extensions.  These are the step by step instructions to install them.  These instructions assume that you have setup your computer in a standard format. Click on the following link http://cid-201f3835d49587fe.skydrive.live.com/self.aspx/Public/Small%20Basic/lib.zip Internet Explorer will open a web page for you.  In the top left hand corner just below the green band. you will see the word "Download".  Click on it. The standard open or save window will open.  SAVE the file to your usual download location, ie Your desktop. Launch windows explorer and click on the + symbol in front of your c: Drive.  This will expand the directory tree for your c: drive. Go down this list until you see the "Program File" Folder. Click the + symbol to the left of "Program File" to expand this branch of the directory tree. Go down this list until you see "Microsoft" Click the + symbol to the left of Microsoft to expand this branch of the directory tree. Go down this list untill you see "Small Basic" and click on it. In the right hand pane you will see the contents of the SMall Basic directory Right Click on the right pane and add a new folder called "Lib" Copy the file you downloaded in step 4 to your new Lib directory Expand the zip into this same Lib directory. You should now see the file FC.Dll If you also see smallbasic.dll, delete it to summarize you should have placed the file FC.DLL into the Directory c:\program files\Microsoft\Small Basic\Lib Now launch Small Basic. To tell your program to use the extensions you have just installed, simply make the first line in your program "GraphicWindow.Show()" The Test to see if every thing is contect is to simply type "DR" on the next blank line. Intellisense will display "Drawings" in the right hand Help panel with a list of all the things that Drawings can do. Congradulations!  Who have just installed the Fremy Extensions!  Explore, Learn and have fun!

I have installed the SQL extensions for Powershell on my Server 2008 R2 server, with the dependencies (CLR types, native client, MSXML, and 2008 management suite).  Installation seemed to go fine but I cannot see any way to use it.  Doesn't show up in the available modules or snapins.  None of the cmdlets listed in the Microsoft help site is there.  help *sql* shows nothing.

I am confused!



When installing the Extension Pack, I get this error while it is processing the .sql scripts:

Invalid connection (Could not obtain information anout Windows NT group/user 'domain\MyUserName', error code 0x5. Warning the SQL Server client assembly 'ssma4oraclesqlserverconnections.net, version=1.0.3110.22188, culture=neutral, publickeytoken=xxxxxxxx, processorarchitecture=msil.' you are registering is not fully tested in SQL Server hosted environment.)


Invalid Connection (Column parameter, or variable #5: Cannot find data type ssma_oracle.Record.Parameter or variable '@value' has an invalid data type.)

I'm using a fresh VM of Server 2k3 with Oracle and SS2k8.

Ideas? Thoughts?




What is the latest VSE for SP?  Will it install on my 64bit machine?  My edition of VS.NET 2008 is 32 bit i think.

Hello All:

I ran into an issue with ajax.  I installed asp.net 2.0 ajax extenion 1.0 in Windows Sharepoint Services Version 3.0.   This is for Sharepoint 2007.  I used this link to modify my web.config file. http://msdn.microsoft.com/en-us/library/bb861898(office.12).aspx.   Now, I keep on getting 500-Internal Server error whenever I used the new config file.  Any ideas? 

Thank you for your assistance






Trying to install the PivotViewer Extensions.   My issue is with the first step of provisioning the database.  It doesn't work.  Will post the error below.  Things that may be of use to know:

1.  Computer name has a "-" in it.  Specifically it is called "bi-poc".
2.  If I manually create the database (with the GUID) the unprovisioning routine will delete it.
3.  I am logged into the server as Administrator who currently has the following SQL roles - dbcreator, public, securityadmin, sysadmin.
4.  I did run from an elevated command prompt.
5.  No database is appearing in SQL when viewed from SQL Management Studio.
6.  When I run the command I do see the license term window popup.

I run the command and get the following error:

bprovision.exe -sbi-poc -op

Error on executing the BICollection db provision manager: Cannot connect to database master at SQL server at bi-poc. The database might not exist, or the current user does not have permission to connect to it.

Call stack:
   at Microsoft.SharePoint.Administration.SPDatabase.EnsureSqlDatabase(SqlConnectionStringBuilder connectionString)
   at Microsoft.SharePoint.Administration.SPDatabase.SetDatabaseOptions(SqlConnectionStringBuilder connectionString, Dictionary`2 options)
   at Microsoft.SharePoint.Administration.SPDatabase.Provision(SqlConnectionStringBuilder connectionString, TextReader provisioningScriptStream, Dictionary`2 options)
   at BICollectionUtils.BICollectionDatabase.Provision()
   at BICollectionDBProvision.BIDBProvisioner.Provision()
   at BICollectionDBProvision.BIDBProvisioner.Run()

If I try to re-run the command I then see:

Error on executing the BICollection db provision manager: A SharePoint database named BICollection_d5d3b022646842ba9dfae88e4b0361e2 already exists.  You must supply another name for the new database.

Call stack:
   at Microsoft.SharePoint.Administration.SPDatabase.Update()
   at BICollectionDBProvision.BIDBProvisioner.Provision()
   at BICollectionDBProvision.BIDBProvisioner.Run()

Any thoughts?




My problem is that after installing an Extension in Visual Studio 2010 I cannot see Project and Item Templates associated with the extension.
The Extension manager contains the extension and says that it is installed and active. Still the templates don't show up in the new project dialog.

I've tried to shorten the pathname to the extension template data as suggested here:
but it didn't work for me.

I am using Visual Studio 2010, Version 10.0.30319.1 RTMRel.
I'm trying to install the ConfigurationSectionDesigner Extension as well as the CustomStartPageProjectTemplate Extension.
As the problem I am facing is the same for both I don't think the issue is on the extension side.

Thank you for any help.


I have written a 32 bit SNMP extension agent dll in native C++ (since you have to write it this way).

This works on a Windows XP machine and a Windows 2003 server machine without any problems.

I have now installed it on a machine running Windows Server 2008 i.e. 64bit.

I have added my SNMP agent to the following registry location (which is a different location to that used on the 32 bit versions):


My entry under this key references another registry location which has a Pathname entry which is set to "d:\test\PP.PixelPromo.Support.SnmpAgent.dll" as a REG_EXPAND_SZ type (as opposed to a REG_SZ type).

Every time that I start the SNMP service I get the following error in the event log:

The SNMP Service is ignoring extension agent dll "d:\test\PP.PixelPromo.Support.SnmpAgent.dll" because it is missing or misconfigured.

I have removed all the code from the SNMP agent dll except the 4 main entry points and even this gives me the error.

I cannot see anything wrong with the settings that I have made in the registry. This is obviously a 32 bit/64 bit issue but I cannot see what the issue is.

Can anyone help with this problem?




As we all now "Extension methods" are only methods, not getters/setters
I would love to have extension properties, I think you would all love...

Please mark post as helpful if you think it is...

I have been doing a little proof of concept and have run into a question.

1. The extension I have is one where I want to render a report and deliver it to a number of possible points, these being fax, print, file drop and email.  Thing is I want to sent to one single path or to any combination of the four.

To do this I pass the Notification object as is, the Subscription data in the form of string[,] and a debugging flag that determines how much data is written to the log files. Since my target dll does not have the IDeliver stuff and the IExtension implemented I have certain thing I have to do in the extension before I call the dll.

But since the dll has the Notification in it I can render the report in the dll. I did have to regiseter it with full trust in the security policies for both manager and server but it runs fine now. So I prototyped my emailing module and can email and log the image of the report and send off a copy to whoever. All working fine.

The question is when I fire up my dll I pass the Notification and I know that this is heavy lifting and it works, but is it okay?  I could render the report before  I call the delivery dll and pass in the byte[] and make it work, but is it okay to pass the Notification?  It lives in the same execution context and works so is it not recommended or does anyone know?



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure