Home » Microsoft Technologies

Internet Explorer 9.0 Compatibility Issues

After loading the Beta version of Explorer 9.0 I had problems with "Save & Close" on the Task items.  Has anyone else tried 9.0 and found problems with CRM 4.0?  Is there some change to the settings that I need to make?  Explorer 9.0 seems to be a vast improvement for Microsoft and I would like to make the change over to using it as soon as possible.

5 Answers Found


Answer 1

HI  Rhett ,

Can you  tell us  what are  issues will be coming if we using  IE9 for crm 4.0 which  does not contain any updated rollup for IE9


I would like to know  what are  major issue we will be facing on doing that ?

and also minor  issue ?

is there  any way user can  run ie8 from ie 9  if any issue are persistting ?

do  you  think if we  install update  roll up 15 for crm 4.0 will resolve any issues by using IE9

You  suggestion would greatly help us  in going hence forth...




Answer 2

I don't have a list of issues between IE9 and CRM but here are some posts that you might find helpful. If you are going to stick with IE9 then install the latest rollup 15 and then see if you still have the same problem as rollup 13 was supposed to have resolved some issues as mentioned by Neil. IF all else fails revert back to IE 8 or try Pablo's IE8->IE9 workaround using the spoon plugin.




MSCRM Bing'd - http://bingsoft.wordpress.com
Check out the CRM 4 to CRM 2011 JavaScript Converter Tool
CRM Forum Guidance on how to Help Us Help You

Answer 3

IE 9 is currently not supported for use with CRM. I would wait until Microsoft give the green light on this.

Answer 4

Update rollup 13 released yesterday addressed some issues  with the IE9 beta, but I'm not sure if it addressed the issue you describe. Might be worth a try though!

Answer 5


As workaround, maybe you can follow what I have shared here.

Hope it helps,

PP [twitter.com/pabloperalta]




I have a panel with scroll.

But when i am in compatibility mode the scroll only func to titles but the textbox are fixed don´t func.

How I resolve?



I want some code that detects that if my page is being viewed by internet explorer 9 the browser automatically is switched to compatibility view.

Is there some way how to achieve this?


Roderick Vella

what does T1(1.5) mean in reference to choosing a download type  for example  DSL/cable  etc...I have an airlink card from verizon on my laptop...and i don't know which type to choose so that I can download the internet explorer 8

I am building a Facebook Application (or IFrame Application).


Facebook load my application into the IFrame at runtime when the user wants to use my application.  My application allows end users to view their Facebook videos, upload videos and so on.  The end users videos are stored on the Facebook CDN (Content Delivery Network).



Currently this is working, in Chrome 8.0 and 9.0, Firefox 3 and Safari but not IE 8 or IE 9. I keep getting the error message in my flash media player inside the iframe inside facebook that says:


"We are unable to connect to the content you've requested. We apologize for the inconvenience"


When I examine IE 9 Debugger and look at the network traffic the caputres in there say:


Initiator: Flash

Method: Get

Result: 404

Type: Text/Html


Now when i create a standard html page with the flash player not inside of facebook but on my own server and run it again.  The video plays fine in IE.  So I'm presuming that IE is not liking the fact that my app is inside of the facebook domain that is doing a call out to the facebook cdn or indeed any cdn and is preventing this transfer from happening.


The question obviously is then is how do I go about getting around this problem so that I can offer customers my service on IE ...


I've uploaded several videos to facebook to test against they in turn convert them to MP4.  Here is one that you can see for yourself.




There is a crossdomain.xml policy file at the root:




So there are no problems with permissions.  What else could be the problem here as to why IE refuses to load the cdn videos from within my application that is inside the facebook domain?

Or better yet how do I fix this problem, or is this a bug in IE????






I am running windows vista professional and I am having intermitent problems with internet explorer "not responding" when I try to start it. How can I solve this issue?

Am running Windows 7 with IE8.  IE usually starts okay and displays the home page I use.  However, ofter (usually) when I click the "new tab" button to open another browser window, the "Connecting..." message displays and progress on that pane stops.  Sometimes a second or third attempt will open a new browser window; sometimes the IE program goes "not responding", and I have to close everything down using the Windows Task Manager.

I tried downloading and installing IE9 beta.  Afterward, I kept getting a window popping up telling me I needed to download Adobe Flash Player.  When I tried, I could never get the flash player download to go anywhere.


I have a Silverlight page which makes 7 WCF service calls. It works 5 out of 10 times. But the other 5 times the 7 WCF calls are made from Silverlight, but the calls never reach the WCF service.

Does anyone know how can this be solved?


my internet explorer will not load web page it comes up with box stating :-   Runtme error!       Program C:|  program files | internet explorer| 

                                                                                                                                IEXPLORE.EXE           Abnormal program termination

Also when i go to internet options it wont open....
Computer is xp   ,,,.,,,,,,,,,,,,    im not very good with computers so any help would be great thanks......

I know it's a known issue and there are few reasons for it; (here are some:






Just wanted to note, that there is something that seems to me as bug in IE DOM implementation that can cause it as well. In my application I have following code on the client side:

while (body && body.hasChildNodes()) {

var node = body.firstChild;

// ... app logic



while body content is created by Response.Write on the server side (I write down context in <p>...</p> paragraphs sections ).

Occasionally I was getting "Internet Explorer cannot open the Internet site - Operation aborted" in IE. In Firefox it was never happen.

After some research I found that it was related to the fact that on the server side I was writing:

1) '<p>'

2) content

3) '</p>

so - sometimes on the client side the code was running while paragraph wasn't fully formed (e.g. only <p> was written).

In this case body.hasChildNodes() still returns true (bug #1) and body.removeChild(node) will cause "operation aborted" (bug #2).

Hope it may help someone.

Alex Pinsker


I cannot access any Microsoft product from my computer. cannot run  regedit, network center is locked up print spooler is missing service control manager missing. cannot install or uninstall any program. and various other problem however computer (one user) can be connected to the internet through Firefox only wireless network (network connection invisible) please help. trying for four days now.

I have two computers, and on one of them I am unable to open Internet Explorer because I keep getting a dialog box that says "Internet Explorer Security - a website wants to open web content using this program on your computer.  This program will open outside of Protected mode.  Internet Explorer's Protected mode helps protect your computer.  If you do not trust this website, do not open this program.

  Name:  dw20.exe

  Publisher:  Microsoft Corporation"

The details say it has to do with ...rosoft.NET\Framework\v2.0.50727\dw20.exe

Each time I click on Allow or Don't allow, IE closes and I can't use it.  It doesn't seem to matter which option I choose....it still closes.  What is causing this and how do I fix it?  It's very frustrating.  I need to be able to get into IE on this particular computer.



XP Professional SP2 and 3 boxes running internet explorer 6 or 7. The same issues exists in all versions. All boxes have 3rd party network providers, namely Hummingbird NFS.

The issue:
When a user is in internet explorer and tries to browse to a file sever location, it uses the 3rd party provider. When the user tries to browse to the same location using windows explorer, it uses Microsoft Windows Network provider.

Asside from changing the provider order, is there a way to force internet explorer to use a specific provider? This is important our situation because we heavily use web-based file sharing. This of course doesn't work well when a user tries to access a shared file with a 3rd party provider that our file servers aren't setup to use. I don't want to change the provider order because it breaks other terminal applications that require the provider to be listed first.


I have become confused by the lack of mapping between the registered versions of shell.explorer that are available, and the installed version of internet explorer.

So, two questions:

1. What is the difference between shell.explorer.1 and shell.explorer.2 ? Is it just an difference in the offered interfaces, but with the same actual rendering technology?

2. Given that there are only 2 shell.explorer versions, how would I try an instantiate - or at least verify the capabilities of - a particular version of the Internet Explorer renderer control? i.e. I would want to be able to instantiate a control that renders compatible with pages developed for IE6 - or verify the version of the control is the IE9 renderer?



Windows 7 32bit

Sharepoint 3.0

Internet Explorer 8


I'm currently troubleshooting an issue with a user who is attempting to access his document library in Explorer view. When this action is attempted the error: Internet Explorer cannot display the web page.


When attempting to replicate, opened the users Sharepoint site, as the user, in IE8, navigated to the document library, clicked action > Open with Windows Explorer. Nothing happens. No error received and the documents do not open.

Any ideas.


I provide SSRS 2008 reports to my client using Windows Authentication on a remotely hosted server.  They recently upgraded everyone to Windows 7 and Internet Explorer 8, and now the performance is so bad they can't use these reports. It takes close to a minute for a report to load. Subsequent report loads are somewhat faster but still painfully slow.

When I roll back IE 8 to IE 7 on their test machine, the performance is fine, but the client's IS manager will not roll back everyone to IE 7; nor will he install Chrome or Firefox.  I upgraded the server from SSRS 2008 to SSRS 2008 R2, but that did not help.  I've changed all of the IE 8 options I can think of, without any luck.  I will surely loose this client if I can't resolve this issue, so any help would be appreciated.

I have a webpage with nested ActiveX control. When I use zoom in/out in Internet Explorer browser design zooms correct, but ActiveX control stays the same size. How I can zoom in/out ActiveX Control corresponding to webpage zoom?
I too am having difficulty in registering in that it uses Internet Explorer, and is incredibly slow to load, the little blue progress bar just stops growing, even after half an hour waiting, so I give up. Can I use Firefox?

73, harry


If I set the uiMode to full and the FullScreen to true. I can verify that the loop is being set correctly, because the repeat icon on the WMP screen turns on if loop is set to true or turns off if loop is set to false.

So, I know that the WMP is getting the loop setting correctly. 

However, I get the following behavior:

1)loop is set to false
2)the last item in the playlist finishes
3)the WMP playstate returns "Ready"
4)the WMP turns the FullScreen mode OFF 
5)the WMP starts playing from the beginning of the list

effectively ignoring the fact that the loop is set to false.

Any ideas what might be happening here? or how to solve it?



I have built a simulation program that utilizes Windows Speech API and uses a browser plugin to run it in Internet Explorer.  The program runs fine using Internet Explorer on Windows XP and Vista but it will not run the speech portion of the program using Internet Explorer and Windows 7.  I have checked numerous security settings and tried all of the compatibility settings for the executable.  The program runs the speech api fine as a standalone program in Windows 7 so I'm almost positive that the problem lies in the security settings of Windows 7 and Internet Explorer 8.  Can anyone shed some light on what may be the issue?



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure