Home » Visual Studio

LC.exe was not found

I'm using Orcas beta 2, and am recieving the following error when I compile a project:

Code Snippet
Error 101 Task failed because "LC.exe" was not found, or the .NET Framework SDK v3.5 is not installed.  The task is looking for "LC.exe" in the "bin" subdirectory beneath the location specified in the InstallationFolder value of the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework.  You may be able to solve the problem by doing one of the following:  1.) Install the .NET Framework SDK v3.5.  2.) Manually set the above registry key to the correct location.  3.) Pass the correct location into the "ToolPath" parameter of the task. Management Suite 2

This comes after I add a third party control to a form. The licenses.licx file is created properly, but the project doesn't compile. I've done 1, but can't find the registry key for the 3.5 framework or the "ToolPath" parameter.

Is this a problem with the project, or the third party stuff?


13 Answers Found


Answer 1

Nevermind. I reinstalled the SDK again and it works now.


Answer 2

Where did you get the 3.5 beta  2 sdk  from? I can't find  it anywhere and I have this same issue on Vista x64

Answer 4

Wow, and I thought the .NET 3.5 installer itself was bloatware....



Answer 5

Most of it is documentation and samples. Just because something is big doesn't mean it's bloated.


Answer 6

Tell that to the 100+ meg install  of the .NET 3.0+ runtime... (.NET 2.0 runtime = 25 megs approximately)

Answer 7

I guess it's just a matter of perspective. As somebody who uses a great deal of the features across all versions of the runtime, I'm not bothered by the size.

Answer 8

Well Bloatware question aside and back to the original problem.

I have experienced the exact same problem  with Orcas Beta 2. The issue is that I have re-installed .NET 3.5 and I have checked the registry  key which is set  correctly. The toolpath option is confusing me and I cannot find  it. However, all things being correct  I am still unsure why it cannot find LC.exe. I have checked that it is there and it is where the registry says it is.

Now here is the question. I had to install  to a second harddrive. My C:\ drive is small and loaded and I cannot put Orcas there. All my other Visual Studio installs had no issues running from E:\ and like I said all seems to be in good order.

Does anyone know how I might go about getting around this issue? Any assistance would be wonderful!

Answer 9

This is necessary to compile  the license's files with extension *.licx. When this problem  appeared on my site, this is what I did to solve  it. I had the Windows SDK v6.0a already installed. This is the Vista SDK. However you can install  the Framework SDK, it should be the same. If the key  still doesn't exist, you can create it manually. In my case the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.0A didn't exist. it was up to the "Windows" registry  key -> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows . You should create the key manually, then add  the "InstallationFolder" vlaue (again manually). Then set  the path to the v6.0a SDK folder.  In my case it is : C:\Program Files\Microsoft SDKs\Windows\v6.0A\
The LC.exe is located in the Bin subfolder, but it shouldn't be in the reg value. Only the root folder.

Then the next important step is to restart the Visual Studio if it is already started.

It seems that VS is taking the settings in the biginning when started. After that it should be restarted to get the new settings.


Answer 10

Error message was the as mentioned above - but for me under "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.0A " the "InstallationFolder" was setted to some string which was not poiting to anything.

So I went and changed the key  to point to "C:\Program Files\Microsoft SDKs\Windows\v6.0A\" and then it worked fine for me, please remember to re-start the VS after this change.


Answer 11

Thank you so much Geroge...

it works for me...


Answer 12

I faced the same problem in VS 2005 v2.0.

I noticed that the 'bin' folder containing 'lc.exe' file under 'C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Bin' was empty. I copied and pasted all files under 'bin' folder from other machine and pasted to my machine.

It just worked;)


Answer 13

how to create key  manually??

Recently we've started automating our build system using several different products.  Everything is working well, but we hit a minor snag in LC.exe under certain circumstances.  I'm hoping someone with intimate knowledge of LC.exe could shed some light on this problem. 

We use the following on our Build Server:
FinalBuilder Server
Cruise Control .NET

We also use ComponentOne libraries for the build and these are causing the problem.  I suspect that it's not related directly to these components or their versions because under certain conditions they work, others it fails during LC.exe.

Remoting into the build server as a domain user and launching a build from Visual Studio or the FinalBuilder IDE gives us a good build.  However, if we use FinalBuilderServer (ASP / Web Services) or CruiseControl's Service, the build (using MSBuild.exe) fails with the following exception:

C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin\LC.exe [various parameters]  
ERROR LC0004 in Properties\licenses.licx(1,0) : Exception occurred creating type 'C1.Win.C1Command.C1NavBar, C1.Win.C1Command.2, Version=2.0.20071.19104, Culture=neutralPublicKeyToken=e808566f358766d8' System.TypeInitializationException: The type initializer for 'do' threw an exception. ---> System.ArgumentException: Parameter is not valid.  
ERROR LC0004 in Properties\licenses.licx(3,0) : Exception occurred creating type 'C1.Win.C1Command.C1TopicBar, C1.Win.C1Command.2, Version=2.0.20071.19104, Culture=neutralPublicKeyToken=e808566f358766d8' System.TypeInitializationException: The type initializer for 'ar' threw an exception. ---> System.ArgumentException: Parameter is not valid.  

EDIT: [Not True]:  Doing some testing shows that using Devenv.exe from the command line (through FinalBuilder), does not produce this problem.

My hunch is that it must be security related, or have something to do with a Windows Service executing this utility.  We also tried changing the user of the service (Cruise Control), to log on as the same user that can build it correctly, but it doesn't seem to work this way either.

EDIT: [Breaks with Devenv.exe as well]:  Any suggestions or insight about how LC.exe works from the command line that differs between Devenv.exe and MSBuild.exe?

Thanks in advance.


EDIT: My testing proved me wrong.  Apparently running the build using Devenv.exe does not resolve the problem either. 
Here is a more thorough output of the LC.exe when we run it from a windows service / web application (custom libraries have been removed from the /i: listing):

C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin\LC.exe   
/i:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Core.dll"   
/i:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Data.DataSetExtensions.dll"   
/i:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\System.Runtime.Serialization.dll"   
/i:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\System.ServiceModel.dll"   
/i:"C:\Program Files\Business Objects\Common\2.8\managed\CrystalDecisions.Shared.dll"   
/i:"C:\Program Files\Business Objects\Common\2.8\managed\CrystalDecisions.CrystalReports.Engine.dll"   
Properties\licenses.licx(2): error LC0004: Exception occurred creating type 'C1.Win.C1Command.C1NavBar, C1.Win.C1Command.2, Version=2.0.20071.19104, Culture=neutralPublicKeyToken=e808566f358766d8' System.TypeInitializationException: The type initializer for 'do' threw an exception. ---> System.ArgumentException: Parameter is not valid.  
Properties\licenses.licx(4): error LC0004: Exception occurred creating type 'C1.Win.C1Command.C1TopicBar, C1.Win.C1Command.2, Version=2.0.20071.19104, Culture=neutralPublicKeyToken=e808566f358766d8' System.TypeInitializationException: The type initializer for 'ar' threw an exception. ---> System.ArgumentException: Parameter is not valid.  

EDIT2: I have another small piece of evidence here.

FinalBuilder Server uses a windows service (I suspect it's the web service), to launch a command line executable, which in turn launches MSBuild, which launches LC.exe.

If I let FinalBuilderServer.exe (The Windows Service), execute FBCMD.exe, LC.exe will fail with the above problem.  
FinalBuilderServer.exe --> FBCMD.exe --> MSBuild.exe --> LC.exe (FAIL)
If I run FBCMD.exe in a command line, logged in as the same user as the windows service, LC.exe will succeed.
    cmd.exe --> FBCMD.exe --> MSBuild.exe --> LC.exe (PASS)

In both cases, the output was cleaned before hand, so it's not a matter of build sequence. 

So what's the difference between a Windows Service executing a command line and me doing it through cmd.exe?


I am using Windows XP SP2, and working on MS VS .NET 2005.

My application was working fine till I installed few windows updates. Now on compilation I get an error message - ""LC.exe" exited with code -1073741819."

Someone told me that this could OS bit problem. I checked in My Computer->properties ->advanced->environment variables ->system variables->Processor_Architecture which states x86 over there.

I am not able to compile my applications due to this problem. The application was working normaly. I think the software updates caused this problem, I even uninstalled the updates but then nothing helped. I am stuck on this.

Someone please help. Highly urgent.



We converted our code from VS 2005 to VS 2010. As part of that we changed all the projects from .NET 2.0 to .NET 4.0. It compiles fine in Perforce and Clearcase snapshot views. However, when trying to compile in a Clearcase dynamic views (i.e integration view). I get this error:

22>LC : error LC0000: 'Could not load file or assembly 'Lassalle.Flow, Version=, Culture=neutral, PublicKeyToken=bfc5c756e54a9d2a' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)'

I've tried adding these lines to the devenv.exe.config file:


        <NetFx40_LegacySecurityPolicy enabled="true"/>
        <loadFromRemoteSources enabled="true"/>

I still get the same error. In fact, the NetFx40_LegacySecurityPolicy enabled change produces additional "ResolveComReference" errors.

Any ideas?


So I created a PDF from in Adoble LifeCycle ES2, chose the right DSN and made sure the connections worked to the MS SQL server. SQL server was up and running and I couild log in. In the form, I was able to see and use all of the tables and fields to populate the forms just fine, saved it.

Issue: When launching the form, I get a 'Connection from Source (name) failed because the environment is not trusted'. And it does this for every connection. I tried several different DSN methods and while some connect in the Adobe form creation and I see the tables created in SQL Server, I cannot link to them to update. Funny part is, the data in the SQL database already there, does populate the form.

Am I missing something obvious?


After installing MS .Net Security Update (KB2416472) my project does not compile anymore exiting with the above mentioned error.

Does anyone expierence the same thing.

Regard Christoph


Win 7 Enterprise

VS 2010 Professional

(Automatic updates enables so all patches applied)


i have just tryed to publish my program and i got a error signtool.exe not found. i have looked at tons of help but none of the walk arounds work. I cant even find the sn.exe thing in the program files. can somebody give me a link were i can download this sn.exe or the the signtool.exe to my my computer and put it in the folder.


I have already setuped vs2008sp1.When I checking the "Client-only Framework subset" checkbox and publish it , I got
two warning:
1.cannot publish because a project failed to build.

2.theinstall location for prerequisites has not been set to
"componentvendor's  web site " and the
file'dotnetfx35client\dotnetfx35clientsetup.exe' in item '.net
frameworkclient profile' can not be located on disk .

How do I fix it ? Thank you!


I'm using TFS 2010 beta 2 and am getting this error.  I'm planning an upgrade to the RTM version, but I don't think it will solve this issue.

I have a simple c# solution with several projects.  Most of the projects seem to build fine.  One does not and gets this error.


I have tried installing the windows SDK.  I also updated the path to include the path to resgen:

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\vcpackages;c:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\Microsoft SDKs\Windows\v6.1\Bin\x64;


I have installed the latest RTM TFS on the build server now.  Hasn't resolved it.  


Where is Outlook.exe for Office 2010 Beta?

I'm converting an old COM add-in to work on OL2010.  When I debug my add-in, I need to tell it what application to run.  For OL2007, I pointed it to the Outlook.exe in C:\Program Files\Microsoft Office\Office12.  With OL2010, there is a new Office14 folder, but only 6 files in there, and none of them are Outlook.exe.  My Outlook 2010 shortcut properties are pointing to:

"C:\Program Files\Common Files\microsoft shared\Virtualization Handler\CVH.EXE" "Microsoft Outlook 2010 (Beta) 2014006204090000"

but when I use that, it seems the CVH.exe launches the Outlook.exe and then quits, so I can't really debug my add-in.  I'm running Vista 32 bit and the 32 bit version of Office Beta.

How do I debug an add-in when I can't find the Outlook.exe?





I have some Java code that calls to QWINSTA.EXE and then parses the results to see what sessions are active.  On all windows systems EXCEPT my Windows 7 ones this file can be found and called.  I have tried natively calling it and via cmd shell (both from my Java code).  Interestingly the results are consistent:  cannot find the file.  When I open a cmd shell and type in QWINSTA it runs fine!  So frustrating.  File permissios are fine and I'm running as Administrator.  It's not a hidden or system file so what gives?


When I tried to xna build MechWarrior I got this msg :

error MSB3428: Could not load the Visual C++ component "VCbuild.exe". To fix this, 1) install .Net Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location of the component to the system path if it is installed elsewhere.

I couldn't find vcbuild.exe anywhere, though I found vcbuild.dll. I've already installed Net Framework 2.0 SDK, Microsoft Visual Studio 2005 and modified path.

Does anyone know the solution?

Thanks in anticipation

Hindu Puggal


Other Errors and Warnings
 3 error(s), 0 warning(s)
 Tracker.exe: Response file C:\Documents and Settings\sysadmin\Local Settings\Temp\700aafbf4ec842cd8e8f856126b51a00.rsp not found.
 Tracker.exe: Response file C:\Documents and Settings\sysadmin\Local Settings\Temp\798f855c3ca6488cbe54b0ca73e93269.rsp not found.
 Tracker.exe: Response file C:\Documents and Settings\sysadmin\Local Settings\Temp\d436f6d14e544e40aa0f884ded21f2b2.rsp not found.

Why am I getting this error on the SUMMARY section of the VIEW SUMMARY build results and how can it be resolved?

Many people are reporting the same error.

I have this error whenever i try to open windows live messenger 2009, when i sign in,when someone send a message to me and when i double click a contact to chat with them. But, my windows live messenger doesn't crash, it just have the error pop-up and its very irritating.
This is the error i had.
The procedure entry point _except_handler4_common could not be located in the dynamic link library msvcrt.dll.
I am using Windows XP SP3.



According to this page:

I have to download and install the "Microsoft Windows SDK for Windows 7 and .NET Framework 4 Version 7.1", after which the FxCopSetup.exe file will be available in this folder:
%ProgramFiles%\Microsoft SDKs\Windows\v7.1\Bin\FXCop folder

I ran the SDK setup and selected all components for installation, but the FXCop-folder mentioned above was not there afterwards.
In fact, there was no file with "fxcop" in the name on my system after having run the SDK setup.

I need this tool to prepare for an ISV Platform test.
Can someone please tell me where I can find V10.0+ of FxCopSetup.exe?

Thanks in advance!


Hi! I've just upgraded to TFS2008 & doing a build. The build runs this:

Using "TestToolsTask" task from assembly "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\Microsoft.VisualStudio.QualityTools.MSBuildTasks.dll".
Task "TestToolsTask"
  MSTest.exe /nologo /searchpathroot:"c:\Builds\AM\AM_Test\Binaries\Release" /resultsfileroot:"c:\Builds\AM\AM_Test\TestResults" /testmetadata:"c:\Builds\AM\AM_Test\Sources\Main\Source\AM1.vsmdi" /testlist:"AM" /publish:"
http://its3:8080/" /publishbuild:"AM_Test_3.1.77" /teamproject:"AM" /platform:"Any CPU" /flavor:"Release" 
  The "TestToolsTask" task is using "MSTest.exe" from "MSTest.exe".
MSBUILD : warning MSB6003: The specified task executable "MSTest.exe" could not be run. The system cannot find the file specified
  The previous error was converted to a warning because the task was called with ContinueOnError=true.
  Build continuing because "ContinueOnError" on the task "TestToolsTask" is set to "true".
Done executing task "TestToolsTask" -- FAILED.

So the system couln't find MSTest.exe, but it is in C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\!

I even added it to the System path variable, but there is no result. May be anybody knows what's this?

" An error occurred while signing: SignTool.exe not found"

Vista Utlimate x64 Service Pack 1

Microsoft Visual Studio 2008
Version 9.0.30729.1 SP
Microsoft .NET Framework
Version 3.5 SP1

Installed Edition: Professional

When I attempt to publish my application using the publishing wizard, sign code not checked.  I get the error above.
Looking back through previous posts, this was a problem in earlier beta releases, but was to be fixed by the final release of Visual Studio.

Searching my machine using the search function shows SigntTool.exe is not present on the machine.

Frankly it has been a while since I tried to compile and publish a project using click once, but it worked then now it fails.  So I cannot firmly blame it on the Sp1 installation, I'm suspicious.

How do I make it work??

Ed Warren

Raising sails on masts not masts on sails

hi everytime i try to debug my program this error always pops up

The procedure entry point, ??3_AllocBase@details@concurrency@@SAXPAX@Z could not be located in the dynamic link library MSVCR100D.dll.


In my effort to troubleshoot a problem with Database Mail, I discovered that, apparently, I don't have DatabaseMail90.exe on my machine. I am running SQL Server 2008. Production Version: 10.50.1600.1, ProductLevel: RTM, Edition: Enterprise Edition 64 bit. This is running on a Windows 7 Professional 64 bit machine. I thought I had done a full installation. I have Folder Options set to view all files and folders.

Why would this executable not be on the machine?

Thank you for your help!



To whom it may concern: 

I am using a Fortran compiler to build a solution under Visual Studio 2008. 

I repeatedly get this error message: mt.exe not found. 

I presume the executable come from SDK, but I am unsure where to place it. 

Can you help? 


Nelson Conti


I have installed VS 2008 on my new Windows 7 computer.  I have copied my old project folders <app> and <app setup> to \users\me\Documents\Visual Studio 2008\Projects\.  The new installation of VS 2008 did not have a \Projects folder in \users\me\Documents\Visual Studio 2008.  When I try to rebuild my application, <MyApp>, I get the error message:

Could not find file 'C:\Users\Me\Documents\Visual Studio 2008\Projects\<MyApp>\obj\Debug\<MyApp>.exe' 'The system cannot find the file specified.'

Indeed, when I look in that folder, there is no <MyApp>.exe

When I copy my <MyApp>.exe from my previous XP computer and paste it into the above folder and then rerun build, <MyApp>.exe disappears from the folder and I get the same error message.

I am also having problems with \My Project files.  VB2008 isn't generating the file app.manifest and Application.myapp

Help doesn't help.


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure