Home » SQL Server

Linked Server Mapping Error "Access to the remote server is denied because no login-mapping exists"

SQL Server 2005 SP3 32bit server
Connecting to an Oracle 10g server
Loaded OracleClient 10g

I'm able to ping the Oracle Server, and ODBC connect and able to run an open query with a single remote user id.

Issue: When I use the security context "Be made using this security context" it connects.
When I choose the "Not Be Made" WITH THE SAME USER ID & PASSWORD, I get the mapping error.


8 Answers Found


Answer 1

When you select "Not Be Made" then it will not allow your connection to Oracle server  until you specify in Local server login to remote  server login mapping.

In my Scenario I select this option when certain users need permission to remote database.

I hope this will make clear about this error.



Answer 2

I enter the same user ID and password up top for the mapping  and it's like it doesn't recognize the entry in the mapping section.

This same mapping (userid) works on a 2000 server  going to the same Oracle server so I'm wondering if it's something in 2005 that is either a bug or a setting that is not turned on

Answer 3

I hope you are not mapping  windows users. If yes then you have to enable MSDTC service on both machines.

I had same problem with SQL 2005 on both ends. SQL authentication works fine for me without any problem.


Answer 4

Hi.   MSDTC is enabled.
I can connect via linked  server to another SQL server  using multiple user mappings.
The issue is when I link to an ORACLE server using multiple user mappings.

I can use the "Be made using this security context" and connect to the Oracle server, if I change the security option to "Not Be Made"  using THE SAME USER ID & PASSWORD I get a mapping  error.


Answer 5

Hi Steph,

I am using exactly what you are saying and it's working for me when I do "Not be made" and then map Local Windows User to SQL User on remote  machine.

I hope you are not imporsonating user while mapping.


Answer 6

Nope, I'm not impersonating.    It's really weird, I do that mapping  on a SQL to SQL linked  server and it works the way it should. 

But SQL to Oracle gives me the mapping error  unless I use the Be made using this security context.


Answer 8

When you select "Not Be Made" then it will not allow your connection to Oracle server  until you specify in Local server login to remote  server login mapping.

In my Scenario I select this option when certain users need permission to remote database.

I hope this will make clear about this error.


It is exactly what I need, It's good for reference, Now I understand more about it, Thanks for your effort!


I'm running a very lengthy SSIS package (SSIS 2008 hitting a 2008 instance) that keeps giving me this error message on random execute sql tasks. 

Access to the remote server is denied because no login-mapping exists.

The funny thing is that the query is not using a linked server.  I've validated I have a good connection to the server via my connection manager and when I run any of these queries that are giving me this message in SSMS, they run fine.  I don't get it.  I do have a linked server set up on this instance, but it has a good connection as well (not that it should matter, because its not being used). 

Its funny to note that the actual tasks in this package that do use the linked server work fine.  :)


getting error while mapping linked server

error detail given below : it giving error ad hoc updates to system catalogs are not allowed SQL error # 259

according to this article  : http://msdn.microsoft.com/en-us/library/aa258720%28SQL.80%29.aspx

ad hoc update to system are not enabled.

i tried to enable but didn't solve my problem. can anyone help me on this issue. Thanks!!!


I have the following setup:

MSSQL64 -- Local server

MSSQL32 -- Another, 32-bit instance of local server, which also appears on MSSQL64 as a linked server

ACCESSLINK -- TA linked server on MSSQL32 to an access database file. 


The MSSQL32 installation was needed as I have 32-office installed on the machine, which prevents me from adding ACCESSLINK directly to MSSQL64.


I can query ACCESSLINK tables from MSSQL32.


I can query other databases on MSSQL32 from MSSQL64.


But, try as I might, I can't figure out how to query ACCESSLINK from MSSQL64.

In fact, only the actual MSSQL32's actual databases show up in the object explorer, not the linked servers.  (The tables in ACCESSLINK do show up in the object explorer in MSSQL32).


Any help?




Hi Folks,

 I'm uploading data from WM devices to SQL 2008 and experience intermittent errors of the type:-

 'SQL Server does not exist or access denied.' from '.Net SqlClient Data Provider' 'Procedure: ConnectionOpen (Connect()).'

 Sometimes months can occur between instances of this. I include exception handling to retry the connection - sometimes 1 retry and it connects, other times it doesn't connect at all. I've looked in the SQL Server logs and there isn't any record of the request being refused etc.

 Prior to this I used SQL Server 2000 and had the same problems - I thought this might be related to TCP / IP settings and the lack of connection pools in the Compact Framework http://support.microsoft.com/default.aspx?scid=kb%3ben-us%3b328476 but this didn't resolve.

 I put off pursuing further whilst I upgraded to SQL 2008 but the issue still occurs. Is this likely to be network connection related?

 The error is so intermittent that its very hard to put it down to one factor.

 An overview of the scenario is notice my error in:-

 Windows Mobile 6.0 device running .NET Compact Framework 3.5 and SQL Server CE 3.5 connecting to instance of SQL Server 2008 via ActiveSync 4.5.


Many Thanks,



Hi Guys,

The subject of this question is the error which I am receiving when running a scheduled job also this is an error which we get at a random intervals and the frequency would be once or twice in a month. I have been through several posts and didn't concluded anything out of it. At the time when we receive this error the memory usage of the database was normal with free resources available and also the network was stable without issues.

Our Sql database is in cluster mode with named instance.

Can anyone share some information on this, I know this is not the right forum with the error message I have posted but am sure some one might have face the same problem when running some ETL jobs. Source and target both are sql server and the error message is generated in the validation phase of the connection manager connecting to target database.

SSIS 2005 SP2

64 bit environment


Hello all.

I am using Access 2010 and SQL Server 2008 (locally). I can easily connect to server using SSMS and it works excellent. But when I want to import a table to Access 2010 using ODBC, it says that "SQL Server doesn't exist or access denied". It worked previously - almost 3 days ago, but now, it doesn't!

Please help!

Mohammad Javahery



after successful installation of SQLServer 2008 R2 and providing my account as a 'sysadmin' I failed to access the server from a management studio of a SQL-Server 2005 release installation. The TCP/IP access is enabled and the server is configured to allow access from remote connections.  The error message reads a follows: ' A network-related or instance-specific error occured while establishing a connection to SQL Server. The server was not found or was not accessible. Verify ... (Provider: Named Pipes Provider, error 40 - Could not open a connection to SQL Server)(Microsoft SQL Server, Error:2)' Accessing the SQL-Server by the management studio from the local host works fine but trying to acces by command line using the '-E' parameter fails. Is there any additional configuration on the operation system level needed to open a SQL-Server 2008 instance to be selected by other members of  domain groups from the non-local host?

Thank you for the answer  


DB - Machine A - Windows Server 2007 - Enterprise/ SQL Server 2008

FileShare Machine B - Windows Server 2007 () - Standard

SSMS - Machine C - My XP PC

When I am trying to BULK INSERT/access \\MachineB\File.txt from MachineA - SSMS 2008 using windows authentication, it works fine.

When I am accessing the same file \\MachineB\File.txt from Machine C via SSMS 2008 (SQL Server 2008 DB (Machine A)) using same windows authentication.


Yes, I do have access to that share from MachineC: I can access \\MachineB\File.txt using MachineC - Windows explorere and also from MachineC- SSMS. e.g.

EXEC master.dbo.xp_cmdshell 'DIR \\Sqldev2\filename.txt' - I am getting results.


I am not that good on Windows security deligation and all - so if that is the thing please explain in detail.


Thanks for your help!

Is it possible to display for ex: State Boundary of California only in Bing Maps instead of entire USA Map?

How should alternate access mapping be setup in SharePoint for external access to Project Server 2010.  The internal site is accessed at http://x1test/pwa.  Externally, I will access the site as https://ps.company.com/pwa.



During attempts to update the database with the "approve" value, I receive an "Error during an updateNo mapping exists from object type". Could you please review the code and explain how to process the selected rows in the checkbox with an update to the SQL database? Any suggestions or help would be greatly appreciated.

Imports Microsoft.VisualBasic
Imports System
Imports System.Data
Imports System.Configuration
Imports System.Web
Imports System.Web.Security
Imports System.Web.UI
Imports System.Web.UI.WebControls
Imports System.Web.UI.WebControls.WebParts
Imports System.Web.UI.HtmlControls
Imports DevExpress.Web.ASPxGridView
Imports System.Collections.Generic
Imports System.Data.SqlClient

Partial Public Class Default2
    Inherits System.Web.UI.Page
    Private isEditing As Boolean = False
    Private dt As New DataTable
    Private dv As New DataView
    Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
        If Session("GridDataSource") Is Nothing Then
            Session("GridDataSource") = CreateDataSource()
        End If
        ASPxGridView1.DataSourceID = Nothing
        ASPxGridView1.DataSource = Session("GridDataSource")

    End Sub
Private Shared Function CreateDataSource() As DataTable
        Dim DataTable As New DataTable()
        Using conn As New SqlConnection(System.Configuration.ConfigurationManager.ConnectionStrings("ConnectionString").ConnectionString)
            Using adapter As New SqlDataAdapter("SELECT ID, Song, Genre, Approved FROM [DebugTbl]", conn)
                adapter.FillSchema(DataTable, SchemaType.Mapped)
            End Using
        End Using
        Return DataTable
    End Function

    Protected Sub ASPxGridView1_CustomCallback(ByVal sender As Object, ByVal e As DevExpress.Web.ASPxGridView.ASPxGridViewCustomCallbackEventArgs)
        Dim grid As ASPxGridView = TryCast(sender, ASPxGridView)
        'Switch the grid to edit mode for the last selected row
        If e.Parameters = "StartEditing" Then
            Dim lastSelectedRowKeyValue As Object = grid.GetSelectedFieldValues("ID")(grid.Selection.Count - 1)
            Dim lastSelectedRowVisibleIndex As Integer = grid.FindVisibleIndexByKeyValue(lastSelectedRowKeyValue)
        End If
    End Sub

    Protected Sub ASPxGridView1_StartRowEditing(ByVal sender As Object, ByVal e As DevExpress.Web.Data.ASPxStartRowEditingEventArgs)
        isEditing = True
    End Sub

    Protected Sub ASPxGridView1_CellEditorInitialize(ByVal sender As Object, ByVal e As DevExpress.Web.ASPxGridView.ASPxGridViewEditorEventArgs)
        Dim grid As ASPxGridView = TryCast(sender, ASPxGridView)
        'Make sure that the code initializing editor values in EditForm is executed only once - when switching the grid to edit mode
        If Not (grid.IsEditing AndAlso isEditing) Then
        End If
        If grid.Selection.Count = 1 OrElse e.Column.ReadOnly Then
        End If
        'Initialize an editor's value depending upon the value's uniqueness within a column
        If IsCommonValueForAllSelectedRows(e.Column, e.Value) Then
            e.Editor.Value = e.Value
            e.Editor.Value = Nothing
        End If

    End Sub

    Private Function IsCommonValueForAllSelectedRows(ByVal column As DevExpress.Web.ASPxGridView.GridViewDataColumn, ByVal value As Object) As Boolean
        'Determine whether the passed value is common for all rows within the specified column
        Dim res As Boolean = True
        Dim selectedRowValues As List(Of Object) = ASPxGridView1.GetSelectedFieldValues(column.FieldName)
        For i As Integer = 0 To selectedRowValues.Count - 1
            If selectedRowValues(i).ToString() <> value.ToString() Then
                res = False
                Exit For
            End If
        Next i
        Return res
    End Function
    Protected Sub ASPxGridView1_RowUpdating(ByVal sender As Object, ByVal e As DevExpress.Web.Data.ASPxDataUpdatingEventArgs)
        Dim dt As DataTable = TryCast(Session("GridDataSource"), DataTable)

        'Modify row values after a single grid row has been edited
        If ASPxGridView1.Selection.Count = 1 Then
            Dim row As DataRow = TryCast(dt.Rows.Find(e.Keys("ID")), DataRow)
            row("Song") = e.NewValues("Song")
            row("Genre") = e.NewValues("Genre")
            row("Approved") = e.NewValues("Approved")

        End If
        'Modify row values after multiple grid rows have been edited
        If ASPxGridView1.Selection.Count > 1 Then
            'Obtain key field values of the selected rows
            Dim selectedRowKeys As List(Of Object) = ASPxGridView1.GetSelectedFieldValues("ID")

            For i As Integer = 0 To selectedRowKeys.Count - 1
                'Find a row in the data table by the row's key field value
                Dim row As DataRow = TryCast(dt.Rows.Find(selectedRowKeys(i)), DataRow)

                'Modify data rows by leaving old values (if the EditForm's editors are left blank) or saving new values entered into editors
                If (e.NewValues("Song") Is Nothing) Then
                    row("Song") = row("Song")
                    row("Song") = e.NewValues("Song")
                End If
                If (e.NewValues("Genre") Is Nothing) Then
                    row("Genre") = row("Genre")
                    row("Genre") = e.NewValues("Genre")
                End If
                If (e.NewValues("Approved") Is Nothing) Then
                    row("Approved") = row("Approved")
                    row("Approved") = e.NewValues("Approved")
                End If

                Continue For
            Next i
        End If

        'commit datatable changes

        'For Each row As DataRow In dt.Rows
        '    Console.WriteLine("{0} {1}", row("ID").ToString().PadRight(15), row("Approved").ToString().PadLeft(25))

        For Each row As DataRow In dt.Rows
            Using DS As New DataSet()

                    Dim sqlQueryText As String = _
                    "UPDATE DebugTbl SET Approved = @Approved WHERE ID = @id"

                    'If ConfigurationManager.ConnectionStrings("Dialerresults") IsNot Nothing Then  
                    'Dim connection As String = ConfigurationManager.ConnectionStrings("Dialerresults").ConnectionString  
                    Using conn As New SqlConnection(ConfigurationManager.ConnectionStrings("ConnectionString").ConnectionString)
                        ' execute the update   
                        Dim strID = ASPxGridView1.GetSelectedFieldValues("ID")
                        Dim strApprove As List(Of Object) = ASPxGridView1.GetSelectedFieldValues("Approved")

                        Using cmd As New SqlCommand(sqlQueryText, conn)
                            cmd.Parameters.AddWithValue("ID", strID)
                            cmd.Parameters.AddWithValue("Approved", strApprove)
                        End Using
                    End Using

                    'message.Text="ConfigurationManager.ConnectionStrings('Dialerresults') is Nothing!"  
                    'End If  
                Catch ex As Exception
                    Dim errorMsg As String = "Error during an update"
                    errorMsg += ex.Message
                    Throw New Exception(errorMsg)

                End Try
            End Using



        'Close the grid's EditForm and avoid default update processing from being executed
        e.Cancel = True

    End Sub
End Class

I'm using WinHttp.WinHttpRequest.5.1 for sending/receiving HTTP requests/responses
When trying to access responseText getting and error "No mapping for the Unicode character exists in the target multi-byte code page."

Tried to do this with JScript (using AutomatedQA TestComplete) and MS Visual C++ usingMS Visual Studio 2005

Here is the JScript example:

var sInput = 
'payload=<?xml version="1.0" encoding="UTF-8" standalone="yes" ?><GetUserSessionId xmlns="http://www.companyname.com/UR_ESB"><GuestMode>false</GuestMode><WorkId></WorkId></GetUserSessionId>';

function PostXml(sURL, sXmlInput)
  var xmlhttp = new ActiveXObject("WinHttp.WinHttpRequest.5.1");
  xmlhttp.open("POST", sURL, false, "", "");
  xmlhttp.setRequestHeader('Content-Type', 'application/x-www-form-urlencoded');
  return xmlhttp.responseText //!!! Causes exception

This is a response produced by xmlhttp.getAllResponseHeaders()

Server: Apache-Coyote/1.1

Pragma: no-cache

Cache-Control: no-cache

Content-Type: text/xml;charset=utf8

Content-Length: 279

Date: Tue, 12 Jan 2010 14:02:23 GMT

When using JMeter for testing the same sXmlInput got no such issues. Here is the response received from JMeter:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><Response xmlns="http://www.companyname.com/UR_ESB"><UserSessionId>G48ykMDalwKvwkgsMkQCnT5kYLVY9YNuDSkF+DdnWvUAqgfbbclskQxTZ7LS</UserSessionId><status>0</status><text>Operation completed without exception.</text></Response>

Does anybody have any ideas about the possible reasons of this issue.
Would appreciate any suggestions how to resolve it.


We run asp.net 3.5 on iis 7.5 (w2k8 r2 web). I try to read a file on a share (unc) from a w2k8 r2 enterprise (cluster). The website runs with impersonation.

We have a farm of multiple web servers accessing this share. The web servers have the exact samt setup (shared iis configuration) and same code (replicated with robocopy).

Everything has been working for a long time, but today all of our web servers except one stopped working with the error message:

[UnauthorizedAccessException: Access to the path '\\pathtofile\filename.jpg'is denied.]
  System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +10546755
  System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy) +2580
  System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy) +138
  System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) +89
  System.Web.Hosting.IIS7WorkerRequest.SendResponseFromFile(String name, Int64 offset, Int64 length) +103
  System.Web.HttpWriter.Send(HttpWorkerRequest wr) +116
  System.Web.HttpResponse.UpdateNativeResponse(Boolean sendHeaders) +1077
  System.Web.HttpRuntime.FinishRequestNotification(IIS7WorkerRequest wr, HttpContext context, RequestNotificationStatus& status) +195



An iisreset does not help.

If we reboot the web server it starts working again!

I have checked the logfiles on the fileserver and the web servers but it doesn't have any information about the problem.

I need help with suggestions on how to find the root cause of the problem. The workaround is to reboot the web server, but I want to find the real issue.



I have deployed my custommebrship assembly and role provider assembly in the sts web config , central admin web config  and current web appln web config 's. i have created a  dll which has  login control and in the sign_authenticate event i am creating the securitytoken.

when i establish a session using the security token created using the iissettings object, and  while tryibng to redirect to the   home page of the/landing page of the web appln am Getting access denied error. 

signInControl_Authenticate(object sender, AuthenticateEventArgs e)




e.Authenticated = true; //till this line  it worked success.

 base.RedirectToSuccessUrl(); //here it throws  :" Eror: access  denied "     current ly signed in user : myname sign is as   diuff. user


anybody knows how to overcome this , means authentication is  success, but authoriation didnt work.

 how can i get asuccessfull login to theweb appln/ siteccollection? in my role provder class i  have created my own roles

for user name: myname

role name:  Administrators, Contributor.

any help is appreciated





I am building a VB.net application using ADO to open a recordset. When I try to connect to a SQL Server 2008 on a Windows 2008 server, I get the SQL Server does not exist or access denied error. The server exists, and the account has the right permissions. When I use a classic ASP using ADO to connect to it (using the same connection string), it works. When I use the same app to connect to a different SQL server, by changing the name of the server in the connection string, it works. It is just using VS 2008 that I can't connect to just this server. My main development machine is Vista Ultimate. I've disabled the firewalls on both the server and the client, and applied service pack 1 to the SQL Server. I tried it on a virtual pc running XP (but hosted on the vista box), it doesn't work either. The connection string is:

"Provider=SQLOLEDB;Data Source=hbvSQLServer08;Initial Catalog=WorkOrder;User ID=W0System;Password=WOP@ssword"

Any ideas?



since today we can't access the project portals of all our projects (Visual Studio TFS 2008/sharepoint admin 3.0 running on esx 4.0). I already checked every possible security settings, they're all OK. I also tried creating a new site but I can't access the site. I can however access all the settings.

For example when I try to access: http://server/Sites/Profel I get the "Error: Access Denied" message and the browser is redirected to http://server/Sites/Profel/_layouts/AccessDenied.aspx?Source=http%3A%2F%2Fserver%2FSites%2FProfel%2Fdefault%2Easpx

I have no problem navigating to: http://server/sites/Profel/_layouts/settings.aspx and I can go to al lot of pages, but when I want to create something like a calendar I can specify the parameters but when I click the create button I get the same error.


I already tried this: http://support.microsoft.com/kb/926642  http://support.microsoft.com/kb/896861/en-us but no success

Any help is welcome,

Greetz, Peter



I get the follwowing exception while running my ASP.NET 1.1 web application.  The Web application will call a web service which connects to to the DB server and returns the data to the application. This error occurs when we move the webservices and databases to new servers.

I am able to connect to the DB server from web servers through SQL port.

System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Data.SqlClient.SqlException: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior) at System.Data.SqlClient.SqlCommand.System.Data.IDbCommand.ExecuteReader(CommandBehavior behavior) at System.Data.Common.DbDataAdapter.FillFromCommand(Object data, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) at System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) at System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, String srcTable) 

Why does this error occur and how to solve this?



I have a new install of SharePoint Server 2010.  I'm getting this error message in event viewer: 

Event ID 6398 - Microsoft-SharePoint Products-SharePoint Foundation

The Execute method of job definition Microsoft.Office.InfoPath.Server.Administration.FormsMaintenanceJobDefinition (ID 6c413970-cc48-462d-b900-3400a6cee6dd) threw an exception. More information is included below.

Access to the path 'C:\ProgramData\Microsoft\SharePoint\Config\ee42009ea521450982bd7c1e996ba696' is denied.

I do not have a folder at: 'C:\ProgramData' so not sure how to fix this error.


Good Morning,

I disabled My Sites by following this article http://blog.beckybertram.com/Lists/Posts/Post.aspx?ID=101 and when I click on the menu in the upper right hand corner where the username is and click the My Site link i receive a "Error: Access Denied" message.

I had assumed (obviously incorrectly) that the My Sites link would no longer be there.  Do I need to write a feature or something to remove it all together?

There is nothing in the logs as fars as errors just a log message.  Also nothing in the even viewer on the server.

Log Message:
Name=Request (GET:http://MYMOSS:80/sites/Profiles/_layouts/accessdenied.aspx?closeConnection=01)

Any help is always appreciated, thanks,


Hi all,

I have file locations stored in my DB. The locations are mapped drives on a different server. How can I access them? Do I need to set something up in IIS?

Here are som example locations:

\\FILESERVER\P4W$\Documents - FC\Client\005109\1\1000LE~1.DOC

V:\4\7\1\47123\1\File Note


Any help much appreciated!


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure