Home » .Net Framework

cannot load .rptproj in vs2010


I cannot load my solution which includes a .RPTPROJ  for the reports development.

The .RPTPROJ project is not recognized.

Does anyone know why? And please don't say "It doesn't because it is not supported".

If it is not then Why?

Are we to wait for the next  SQL release? Isnt there a plugin to support .rptproj?

Apparently i need to run vs2005 (or 2008) to support the reports while running vs2010 for program development.

Is there already a plugin or patch?

Does vs 2010 (vb.net) support the report viewer object?

Does vs 2010 (vb.net) even support .rdl files?

I am developing against sql server 2005 as this is the clients version.



Jerry Cic








1 Answer Found


Answer 1

Hi Jerry,

The rtproj created in Business Intelligence Development Studio 2008 or 2008 R2 currently only works in the Visual Studio 2008 shell. This is a feature that is under consideration for future releases of sql  Server and is being tracked by another work item in our database.

This is by design for Visual Studio 2010. And this issue will be tracked by the SQL Server customer bug, which already exists.

For more information:



Best regards,
Guang-Ming Bian - MSFT
MSDN Subscriber support  in Forum
If you have any feedback of our support, please contact msdnmg@microsoft.com



It used to work, but then...

Visual Studio 2005 was hummin' and I had a number of BI projects in both Report Services and Analysis Services. I wanted to add source control and decided to install the Team Suite and I did something wrong. I just don't know what it was.

In the end, I deinstalled every Visual Studio 2005 (including, of course,the Team stuff)and SQL Server 2005 application, and reinstalled old faithful Visual Studio 2005, but nothing has worked. I'm missing the Business Intelligence project templates completely and I'm guessing that if I had them, I wouldn't get either of the following 2 messages when I try to open existing projects:

"The project application for 'c:\...\SOS.dwproj' is not installed. Make sure the application for the project type (dwproj) is installed."

"The project application for 'c:\...\SOS.rptproj' is not installed. Make sure the application for the project type (rptproj) is installed."

Anyone got any ideas?


I have installed
- SQL Server 2008 original version with SP1 and the Business Intelligence Development Studio
- Visual Studio 2008 with SP1.
I am told that Reporting Services 2008 is part of the Business Intelligence Development Studio 2008,
however when I try to open my Reporting Services 2008 .rptproj files with Visual Studio 2008, they will not open.
The error message is:

'C:\vs2008\CWReportsVS2008\CWReportsVS2008\CWReportsVS2008.rptproj' cannot be opened because its project type (.rptproj) is not supported by this version of the application.
To open it, please use a version that supports this type of project.

My VS 2008 cofiguration is:

SQL Server Reporting Services  
Microsoft SQL Server Reporting Services Designers Version 10.0.2531.0
Microsoft Visual Studio 2008 Version 9.0.30729.4462 QFE Installed Edition: Enterprise
Microsoft .NET Framework Version 3.5 SP1
Microsoft Visual Basic 2008, C# 2008, C++ 2008
Microsoft Visual Studio 2008 Team Explorer
Microsoft Visual Studio 2008 Tools for Office
Microsoft Visual Studio Team System 2008 Development Edition
Microsoft Visual Web Developer 2008
Crystal Reports Basic for Visual Studio 2008
Microsoft Visual Studio 2008 Team Explorer - ENU Service Pack 1
Microsoft Visual Studio Team System 2008 Development Edition - ENU Service Pack 1
Microsoft SQL Server Analysis Services Designer
Microsoft SQL Server Integration Services Designer
various hot fixes
various security updates
various team foundation updates

My computer configuration is:

Windows XP, Professional, Version 2002, Service Pack 3

My SQL Server Configuration is:

Microsoft SQL Server Management Studio 10.0.2531.0
Microsoft Analysis Services Client Tools 10.0.1600.22
Microsoft Data Access Components (MDAC) 3.85.1132
Microsoft MSXML 2.6 3.0 4.0 5.0 6.0
Microsoft Internet Explorer 8.0.6001.18702
Microsoft .NET Framework 2.0.50727.3615
Operating System 5.1.2600

Is there something I haven't installed yet?




  I am geting the above error on a project that i have just moved form vs2005 to vs2010.  I have seen a similar post from 2007 but that pointed to a miss match in .net versions.  I do not belive this is the case here as i have check the version (4.0) and that looks ok. I have also opened the assably using Reflector and can see no problems.   Where should i look now?


Hello, I have configured VS2010 with the source server option.I want to have a place to save all the pdb files generated for a Team build, so I set the parameter 'Index Sources' to true and set a 'Path to Publish Symbols'.

When an assembly is "source server-enabled", the pdb file will contain the full path and the exact version of the file in source control that was used to build that assembly. If the debugger then enters a method, Visual Studio automatically downloads that correct file, places it in a local cache, and opens it for debugging.

The solution consist on one console project with one reference to other library that shows a message. I want to debug my application with different versions of this library.

After I have launched the build, I can look that the pdb files exist in the folder I have used to set the path to publish symbols.

I put that path in the Debugging --> symbols option to load the symbol.

Ok here is the problem when I am debugging my application I have to load the symbol for my own dll manually but Visual Studio never takes the pdb files from the source server, so always take the source code that is located in my local directory and never the code from the source control (that could be different).

So my question is how can I debug my own application using the pdb files generated for the Team Build that are located in the source server?




I have solution which contains cca 25 projects. When I will open this solution in VS2010 Ultimate, dialog will pop-uo. this dialog showing info "Preparing solution". Dialog will disappear after cca 30 sec. There is absolutely no info for "what" is VS preparing solution or if there is any problem with solution\loaded projects. All projects are loaded correctly on the end.

Any idea when I can find for what is VS trying to find solution as this dialog is really sticky for our developers ?


When I select Analyze -> Profiler -> Attach/Detach, I get the error "Unable to load file or assembly VSPerfControl.interop.dll version =, system cannot find the file specified."

I found the file in C:\Program Files\Microsoft Visual Studio 10.0\Team Tools\Performance Tools. I registered it in the GAC and restarted VS 2010 and now I no longer receive the error. However putting it in the GAC seems like overkill. Can you tell me where VS2010 expects to be able to find this?

Thank you!

Jason Wells

I am getting the error "AsmMeta failed with uncaught exception: Could not load file or assembly 'System.Core, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified." on our build machine (TeamCity launches MSBuild).

I will look into the Fusion logs to see why it is not resolving -- it does resolve to the 4.0 version in Reflector, or at least appears to -- not sure what causes or allows that.


I'm using Visual Studio 2010. I created an exe with the /Profile switch. I ran it under vsperfmon and created a .coverage file. When I try to load the .coverage file into VS2010, it gives me the following error:

Exception was thrown: Class not registered.
Looking for object with CLSID: {D9B3211D-E57F-4426-AAEF-30A806ADD397}

Also, I recieve the following error:

Exception was thrown: The template specified cannot be found. Please check that the full path is correct.

No other descriptions or errors are generated.



I am spending 5 days to solve"No symbols have been loaded for this document."   but no luck.

any body can help me to solve this issue.

My Scenario: OS Windows XP SP3, VS 2010 Professional, Silverlight 4 release version,

1) I have 3 project TestSilverlight, Test.web, TestWCF.

2) In Silverlight project i have a login page and i call WCF UserLogin(txtUser.text, txtPass.password) from silverlight.

3) In WCF project a Method called UserLogin(string user, string password)

4) I host both the application (Silverlight, WCF) in IIS.

5) Set service reference of WCF in Silverlight application.

I set a break point in WCF UserLogin method.

And from menu  --> Debug --> Attached to Process --> aspnet_wp.exe.

Now the break point in WCF UserLogin method goes yellow and says

"No symbols have been loaded for this document".

If i run my Silverlight application from IIS. Break point not hit.

I have tried all the solution after find from google.

Can any one from Microsoft help me to resolve this problem.

Please suggest the correct solution.

Thanks in advance.



I am migrating a Word (Office 2007) application addin from VS2008, .Net 3.5 to VS2010 and Net 4.0.  During runtime our .Net 4.0 assembly uses a 3rd party assembly to load native code.   The 3rd party assembly is built with Net 2.0   At that point I'm getting the "Mixed mode assembly is built against v2 runtime and cannot be loaded into the v4 runtime." exception message.  

The provided response to that issues is to add the


to the <startup> configuration section of the config file.   We can update the VSTO addin assembly app.config, but that appears not to have any effect as the config at the process level has to be changed.  For Office addins, we cannot change the winword.exe process configuration file.  There may be other VSTO addins that load into the same Office process.

So how are VSTO based solutions supposed to deal with this issue?  Anyone have a solution?



I am trying to export my VS2010 load test results to excel. I have a couple of questions:

1. In VS2010 after my load test has completed and I am viewing the Loat Test Summary - I right clicked and chose the option: "Export to Microsoft Excel"

It launches Excel and pops up a Waring message "Unable to open about:blank. The internet site reports that a connection was established but the data is not available". Then I am left staring at a sheet with one cell filled in reading "ExternalData_1"

Any ideas?


2. Reading Lumley's blog entry here: http://blogs.msdn.com/b/slumley/archive/2009/05/22/dev10-feature-load-test-excel-report-integration.aspx

It says:

"1)      Launch Excel – This is easier way.  Just launch excel.  You will see a new ribbon called Load Test.  Click on the load test ribbon."



I do not see a ribbon called load test...the version of Excel at work is Excel 2003 11.8231 SP3 - what version of excel should I be seeing this in? Is there any way I can get this to work?





I have a VS2010 Web Application that uses the AjaxControlToolkit.

I am able to build the Debug configuration.

When I build the release configuration I get the following error message:

Error 89 Could not load file or assembly 'file:///S:\My Code\Libraries\ACT\May 2010\AjaxControlToolkit.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515) S:\My Code\EZFishing\EZFishing\EZFishing\SGEN EZFishing

The location of the file is correct, and I just downloaded and unzipped there the Ajax CT.

I have always built this app correctly before upgrading to VS2010 and ACT May 2010.

Any idea of what is going on?

Thank you in advance for your help.




Not loaded. A runtime error occured during the loading of the COM Add-in.

Again. I am sorry to open yet another thread around that topic. Please be sure I read as many threads on the topic as possible. And tried the troubleshooting steps proposed there. Still I could not figure out what is wrong.


I develop an Excel add-in using Visual Studio 2010. For now it is an empty add-in, no code yet, just what the VS template created. The targets are Office 2010 and .NET 4. I publish the (empty) add-in using clickonce.

And I wanted to check that the add-in was loading as promised in Office 2007. So I setup a fresh test workstation with Windows 7, Office 2007 SP2, .NET4, VSTO 4 redistributables. I install my add-in and that works, it appears to be loaded by Excel 2007.

Then I setup a fresh workstation with Windows XP SP3, Office 2007 SP2, .NET4, VSTO 4 redistributables. And that does not work. The add-in is not loaded. "Not loaded. A runtime error occured during the loading of the COM Add-in."


Could you help me getting to the root cause of that issue? Thanks a lot,




I have activities that is made in VS2010, that are to be used in a rehosted WorkflowDesigner app. In the rehosted app I have a WorkflowDesigner, a toolbox with all the standard and my custom activities, and a property window. The problem occures when I load a composite activity that has reference to other custom activities (and that is drawn in the designer in VS2010). In the rehosted app the composite activity is shown almost as expected, except that all the referenced activities are shown in the designer as a red error message: "Activity could not be loaded because of errors in the XAML."  If I load the same activity in VS2010 it works.  If I remove the referenced activity in the rehosted app and adds it from the toolbox there, it works. If I draw the composite activity in the rehosted app from "the ground up", it works.

If I compare the activity XAML that is saved in VS2010, and the activity XAML when opened, modified and saved in the rehosted app, I find differences in how namespaces are expressed:

The Activity-XAML from VS2010 has namespace resolution at the top: xmlns:local="clr-namespace:WCFWorkflowPOC"

The Activity-XAML from the rehosted app does not save namespace resolution at the top.

If I add the activity in the rehosted app insted of in VS2010, it places namespace resolution at the referenced activity instead of globally at the top of the XAML:

<local:MyActivity sap:VirtualizedContainerService.HintSize="200,22" ret="[ret]" xmlns:local="clr-namespace:WCFWorkflowPOC" />

So, I may draw composite activities in VS 2010 OR in the rehosted app, but I may not share them across.

Anyone who can help me figure out how to solve this? Thanks in advance.


i have migrated VS 2008 application in VS2010  including crystal report. i have installed SAP crystal reports to support  crystal reports in VS 2010.

how can i migrate the old reports into SAP crystal reports

please suggest me.


I just upgraded my VS2008 to VS2010 Ultimate. Everything looks fine except one problem. The resources cannot be loaded. My application uses only a default culture, not intended to do any localization in the near future too. I added a few strings and images to my resources file (resources.resx), the property is set to Embedded Resources.

In my code, if I need use some string in the resources, I just do like this, e.g. WindowTitle is a string resource defined in the resources.

myWindow.Text = MyAppNamespace.Resources.WindowTitle;

Everything worked fine in previous version (VS2005, VS2008), but now it does not work. The application just crashes, throwing FileNotFoundException because MyApp.Resources.dll cannot be found.

If I remove that line, the application will continue to run until it hits another call of resources.

Any advice to fix this problem?

I have a package for VS2008 that contains a custom editor, and I'm testing out moving it to VS2010 Beta 2.  I seem to have everything set up correctly, but the custom editor never loads in VS2010 Beta 2.  The file always opens as text.  Any ideas what I might be missing?

This is probably the wrong forum, but since I didn't found any for the windows Forms Designer i will post my question here.
I noticed that VS never unloads the compiled binaries of my project, when I recompile the project and open a form in the (WindowsForms)designer witch contains types of this project.
So if I recompile and open the Designer again, then a new copy of the assembly is loaded.

I suspect that the reason is that load Data from a Database into a cache, if that's the reason, any idea how I could determinate when I have to unload them?


Our scenario:

A cluster host with 3 windows 2008 servers on NLB with the application loaded on all servers. All are virtual servers with 4G ram. Trying to run load test for the web test from another server in the network using VS2010 Ultimate.

The URL for the test is something like this http://<Cluster Host IP>/<VD Folder>/<Sub Folder>/xxx.aspx.

For the web test, I ran the url above and recorded the test, no issues there. But when I do the load test for the web test I keep getting 403 errors on the <sub Folder> during the test. We have directory listing disabled on IIS and I am not sure I understand why the test is trying to read the contents of this folder.

I am using the default connection per user with a pool size of 50.

I can ignore this and move on as the test ran without any other issue and I have all the parameters I need. But I would like to understand this behavior.

Any help is appreciated.




When I start Visual Studio 2010 the application (devenv.exe) loads fine without any errors.  But when I load a .sln solution file into the application it will load the last open files but than the application freezes.  However,  At times the solution loads but I am unable to build / debug the project because VS2010 freezes.  I have tried many projects and troubleshooters on the internet.  I have also tried running VS2010 in safe mode.  Still no luck.

<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure