Home » .Net Framework

.net framework

I have .net framework from 1.1 to 4, this may sound stupid, I was wondering if I had to keep all of them installed or if I can remove the older ones and just keep the latest version?

1 Answer Found


Answer 1

When you install the .NET Framework 3.5 SP1, it will also install the .NET Framework 2.0 SP2 and the .NET Framework 3.0 SP2 behind the scenes. You cannot use the .NET Framework 3.5 SP1 unless you also have the .NET Framework 2.0 SP2 and 3.0 SP2 installed. Therefore, you will not be allowed to uninstall the .NET Framework 2.0 SP2 or 3.0 SP2 if you have the .NET Framework 3.5 SP1 installed. If you try to uninstall those versions of the .NET Framework, their uninstall processes will block and tell you that they are needed by another application on your system.

The .NET Framework 1.0 and .NET Framework 1.1 can be installed side-by-side with the .NET Framework 2.0, 3.0 and 3.5. Most applications that were created for the .NET Framework 1.0 or 1.1 will automatically use the .NET Framework 2.0 instead if it is installed on the system. In most cases, that means you do not need to keep the .NET Framework 1.0 or 1.1 installed on your system if you already have the .NET Framework 2.0 installed.

Search for  .net framework


I am attempting to clean up my laptop as it is running a bit slow and noticed I have both these versions of Microsoft.NET Framework.  I tried removing Framework 2.0 but got a message to say that it was needed to support some components with the link http://go.microsoft.com/fwlink/?LinkId=91126.  Following that, I came to information about Framework 3.0 but no information to help me.  Can anyone advise on whether I need both? Are components of 2.0 used by 3.0? How to sort this out?  I am not a developer and I have no idea how/when I managed to get to both these versions (probably hit a wrong button or made an inappropriate selection when seeking upgrades for my microsoft software).




I have an assembly which is developed for .NET framework 4.0(3rd party assembly). I wanted to consume this assembly in a webservice which is developed for .NET Framework 3.5. I am facing the following isses.

1. When I am trying to refer the 4.0 assembly in VS 2008 IDE it is not recongnising it at all. I think this will be basic nature

2. When I am trying to add the reference of 4.0 assembly in VS 2010 in 3.5 targeted Webservice, it successfully added the reference. And I am able to use the classes in the 3.5 application. But when I am trying to compile the 3.5 application then the 3.5 compiler is not able to recongnize the classes of 4.0 assembly, and is giving the error like "missing refernce for the class".

The assembly developed for 4.0 is not using any 4.0 features. It is using only the 3.5 features but compiled for 4.0 framework.

Can any one know how to use the .net 4.0 assembly (targetted framwork is 4.0) for 3.5 version applications?.

The restriction is my application will not work on .net 4.0 because it is consuming other applications which always checks for version validation ie 2.0/3.0/3.5 only.

Appreciated prompt help. Thanks in advance.

Suresh Kumar Thanda

couldnot install what's the problem!!!!

Hi All

I have been going insane with this warning:
"The version of the .NET Framework launch condition '.NET Framework 3.5' does not match the selected .NET Framework bootstrapper package. Update the .NET Framework launch condition to match the version of the .NET Framework selected in the Prerequisites Dialog Box."

I have read a whole bunch of forum posts on this and various other boards about people updating the targetted framework, etc., but mine are all the exact same and I'm still getting the warning.

My System:
Windows 7 x64
VS2010 Premium

My Project was upgraded from VS2008.

The three different areas I have found where you can select .NET Framework versions are:
Project Properties -> Compile Tab -> Advanced Compile Options -> Target Framework
Project Properties -> Publish Tab -> Prerequisites
Setup Properties -> Launch Conditions -> .NET Framework

All of the above settings are set to .NET Framework 3.5

I have the bootstrapper package in:
C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bootstrapper\Packages\DotNetFX35

Before I put my fist through my monitor, does anyone have any suggestions for me?



KB981145 is hotfix for Microsoft .NET Framework 3.5 Service Pack 1. Its not included in Update for Microsoft .NET Framework 3.5 Service Pack 1.

I want to know that Microsoft .NET Framework 4 enhancements/imporvements cover KB981145 or not. In other words, Will using .Net 4 instead of earlier versions will solve the issues fixed by KB981145 or not?



After making a full restore, i can not open some applications (Microsoft Office 2003, Intuit Quickbook POS).

Once i try to open them it shows me the following message:

NET Framework Initialization Error: C:\WINDOWS\Microsoft.NET\Framework|v2.050727\mscorwks.dll could not be loaded.


However it does let me open several others such as Microsoft Works, etc, etc.


I created setup project on vs 2010 beta 2 and .net framework 4, it worked good but after I made some changes on the original project (not the setup project), when I ran the .msi file I got this message :

This setup requires .net framework version v.NET Framework 4. Please install the .Net framework....

I removed the original and setup projects from the solution and recreated them it worked but again after some other changes I got same message.

any idea?


Hi not sure if i posted in right area ( sorry if not)

Have been trying to install Failed Install Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86 for a while now i keep getting the error code 800B0100. I have tried various step to install but no luck as of yet. I have ran the clean up other things people have recommended but none of them have helped. Here is what my  CheckSUR log says.

Checking System Update Readiness.
Binary Version 6.0.6002.22441
Package Version 9.0
2010-09-20 18:10

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages
(f) CBS MUM Missing 0x00000002 servicing\Packages\ws4-update-MiniLP~31bf3856ad364e35~x86~en-US~7.0.6001.16503.mum  
(f) CBS MUM Missing 0x00000002 servicing\Packages\ws4-update-TopLevel~31bf3856ad364e35~x86~~7.0.6001.16503.mum  
(f) CBS MUM Missing 0x00000002 servicing\Packages\ws4-update~31bf3856ad364e35~x86~en-US~7.0.6001.16503.mum  
(f) CBS MUM Missing 0x00000002 servicing\Packages\ws4-update~31bf3856ad364e35~x86~~7.0.6001.16503.mum  

Checking Component Store

Seconds executed: 1812
 Found 4 errors
  CBS MUM Missing Total count: 4

Unavailable repair files:

Thanks in Advance :) x



I am trying to install .NET Framework Version 1.1 Redistributable or .NET framework 2.0 packages, but both of them are sending an error. My OS is Windows 7 with 64-bit. Version 1.1 says it can't be installed due toincompatibility and version 2.0 rejects 64-bit OS.

I am keen on installing especially these packages in order to run EditVoicePack for Flight Simluator 2004. Is there any options I can install it or it simply doesn't work with Windows7 64-bit system?





I have .NET Framework 1.1 Remoting service. I wanted to consume it from my APS.NET application in .NET framework 4.0.

Is it possible?

I tried this but I got error, The remote server returned an error: (401) Unauthorized.

Is any thing missing?




I have been trying to install TurboTax 2009. I've noticed that TT2008 stopped working but when i uninstalled .NET 3.5, it will load.  I have used the frameworks cleanup tool, then reinstalling 3.5 SP1, with no luck.  I tried the frameworks cleanup tool and a reinstall of 3.5 SP1 with updates, as well as used the MS Windows repair utility, all with no success. 

I have contacted turbotax who provided me with a link to a link to Aaron Stebner's Weblog for the NET Framework setup verification tool.

The tool reports a failure when I run it against frameworks 2.0 SP2, 3.0 SP2 and 3.5 SP1, and has the following errors written into its error log files as shown below. The same errors were written into the error logs when the utility was run for each frameworks version.

File C:\Windows\Microsoft.NET\Framework\v1.1.4322\regsvcs.exe.config is not installed on the system
File C:\Windows\Microsoft.NET\Framework\v1.0.3705\installutil.exe.config is not installed on the system
File C:\Windows\Microsoft.NET\Framework\v1.0.3705\mscormmc.cfg is not installed on the system

Verification failed for product .NET Framework 2.0 SP2

Verification failed for product .NET Framework 3.0 SP2

Verification failed for product .NET Framework 3.5 SP1

Per turbtax, after "repairing" frameworks with the MSWindows repair utility, i downloaded 1.1 and tried to repair/reinstall it using the instructions per MS KB306160 and using the command
     N:\dotnetframework\dotnetfx.exe /t:c:\temp /c:"msiexec.exe /i c:\temp\netfx.msi REINSTALL=ALL ReinstallMODE=vomus" ).  

After version 1.1 was installed, i reran the verification tool, which continued to log the same errors as listed above.  

I then ran the sfc / scannow command (per Aaron Stebner's Weblog, and upon completion, it had not found any frameworks integrity violations.  

I'm at a dead end on how to resolve the verification errors, in the hopes I can fix my "original" problem.  Any thoughts or advice?

I'm running Windows Vista Home Premium (32-bit), SP2, Intel CPU 2160@ 1.8Ghz, 2GB RAM


I have developed a small application using VS 2010 and ASO.NET Enity Framework 4.

Now I feel this may be a major limitation. Now the system which I am going to deploy is having only framework 3.5 and VS 2008.

Do I have to re-code using VS 2008 


Hi all,

 I have created a windows based application using .Net framework 3.5 with
 WPF and created an MSI which uses framework 3.5 in the period of installation
 But I want it to convert it now in framework 2.0. Is it possible? If yes please
 suggest the appropriate solution for that.

  I will be very thankful for that.

With warm regards

Arvind Softedge


I have VS 2008 SP1 and SQL Compact Compact 3.5 SP 1 installed.

I can see "ADO.NET Entity Data Model" when I go to Add -> New Item in Web Application project but same is not shown in Smart Device 2.0 application.

How to use Entity Framework (which version) with .NET CF 2.0 application and SQL Compact 3.5 SP 1?


Anyone have experience with this UI Framework ?

I stuck on a few things.


UIForm is the only place where the controls can be draw !!??

Can I have multiple canvas ??

If I create a separate class how can I draw my controls to the main canvas from the new class ??

Couldn't find any documentation for this UIf, hopefully some one here can guide me.

Will be back with more specifics if some one can help me whit this UIf





it's my first post at this forum - I hope you could help me.

After having problems with installing VS2010 (it freezes when installing .Net Framework 4) I decided to download the stand-alone installer for the .Net Framework: dotNetFx40_Full_x86_x64.exe

But I have the same problems: after starting the installer (with admin privileges) the decompression starts and I confirm the install.

The installer announces some security checks and afterwards it freezes with a progress of 0%. Nothing happends for hours.

Maybe someone could give me a hind, wath to do. Where can I find logs to analyse the reason for the problem and the point of freeze.

Thank you very much,



Hello,  have xp pro sp 3 .net 3.5.  want to install c# express 2010.  This is a problem so installing .net 4 first.  However this is still a problem.  Downloaded collection tool and have logs collected.  Where to send them?




I downloaded the the .Net Framework 3.5 from Microsoft and I am trying to install the .Net Framework 3.5 in a clean Windows Vista Ultimate installation but it fails. The dd_dotnetfx35error file shows:

[03/08/08,19:05:35] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 1
[03/08/08,19:05:46] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

Thank you for your help.

hello community,

is it possible after compiling the exe to make it a standalone exe that does not need the .net framework to be installed on the clients machine, because some clients have IT policies that forbid them to make installations. most of my applications are Ms access + vb.net so is there a way to give the customer the db with exe & no other installation steps are needed.

Thank you in advance.

Best regards.

Hello everyone,

I'm creating an updater for an IP address, and I need to ensure that only one instance is running on the computer.  This is to prevent (or at least make it more difficult for) having multiple tunnels running (it's an updater for an IPv6 tunnel).

I've seen various ways of doing it in VB 6.0 and early .NET, but nothing that deals with .NET 3.5 or VIsual Basic 2010. So I'm pretty well clueless about how to do this.

Any help is greatly appreciated.

Thanks, and have a great day:)


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure