Home » .Net Framework

.NET Framework and Google Chrome

Earlier today I was attempting to install a piece of software and it told me that I needed .NET Framework 1.1.432 for it to work. Not knowing very much about what .NET is, I went in search of what to do. I believe I installed .NET Framework 1.1.432 because the program I was originally working on started working. Well, after this happened, my Google Chrome completely stopped working. No matter what page or site I go to, I get the blue screen that says "Aw, Snap! Something went wrong..." and blah blah blah. This was the ONLY program effected. I'm on Firefox right and it's fine. Anyways, I really like using Chrome so I'm hoping someone can work with me to resolve this. There may not be a lot of information in this question but if someone is to help me, I'll explain it in more detail.


Thanks in advance!


1 Answer Found


Answer 1

I would suggest that you ask Chrome technical support.


I also suspect that Chrome is not a .NET application, and that something coincidental has occurred. You might try reinstalling Chrome.




I have a page where I want to keep several combo boxes adjacent to each other. I have put them in divs that are floated left.

This works fine in IE, Firefox. But when I render the same page on Chrome I observe the uneven gap between combo boxes. Upon analysis I found out that each combo box is occupying space based on the data inside it.

This happens because on Safari and Chrome, the option list control is placed differently as compared to that on IE and Firefox.

Please see the following code from ComboBox.pre.js (in AjaxControlToolkit source/Server/)

        // force inline display on Safari by moving the list to the bottom of the form.
        if (Sys.Browser.agent === Sys.Browser.Safari || Sys.Browser.agent === Sys.Browser.WebKit) {
            var parent = this.get_element().parentNode;
            while (typeof (parent) != typeof (document.forms[0])) {
                parent = parent.parentNode
            var safariListContainer = document.createElement('div');
            safariListContainer.className = this.get_element().className;

This is how it looks:

Combo Boxes awry on Google Chrome

I have tried doing the following but none of them helped:

Changed the RenderMode of combo box to 'block' from 'inline'Commented the lines above in combobox.pre.js

Basically, as per my study, unlike IE and FF, on Chrome, the outer combo box div occupies space as the width of absolutely placed ul present inside it which anyways doesn't seem to be a correct implementation.

How to circumvent the problem? Any help in this regard would be really appreciated.




Hi there,

 I used small business starter kit, modified it for my project, it validates at W3C CSS Validation Service, and looks great in IE 7.0.

PROBLEM: Google Chrome does not draw the menu correctly - it is pushed to the right and jumbled.

Has anyone solved this problem?

I appreciate any response.



Hi, I've used autocompleteextender inside a repeater control. On OnClientItemSelected event of autocompleteextender i am setting some hidden field value to use it on server. The code is working fine in all browsers except google chrome. Actually when i traced the code, event is occuring and hidden field is getting value set but the hidden field value is not appearing on the server. On the server i got empty hidden field.



All --

I think that sometimes maintainscrollpositiononpostback is not working in Google Chrome 5.0.353.70 beta.

Has anyone else experienced this?

Does anyone have a fix for this?

Does anyone have an alternative for this?

Please advise.

Thank you.

-- Mark Kamoski


I'm building an ASP.NET 3.5 webapplication using VB.NET, and I'm having problems redirecting to another URL when using Google Chrome. Other browsers like IE and Firefox are fine.

My data entry forms all have an OK and an Cancel button, which are both handled server-side. The Cancel button just redirects back to the originating page, while the OK button will add or update a database record and then redirect to the originating page.
The redirect to the originating page is done by calling the following shared sub on a general utilities class in my appication:

    Shared Sub Redirect(ByVal p_sURL As String)
        Dim l_sURL As String = p_sURL.ToLower
        If Left(l_sURL, 1) = "~" Then
            Dim l_oControl As New System.Web.UI.Control
            l_sURL = l_oControl.ResolveUrl(l_sURL)
        End If
        If Left(l_sURL, 1) <> "/" Then
            If Left(l_sURL, 7) <> "http://" AndAlso Left(l_sURL, 8) <> "https://" Then
                l_sURL = HttpContext.Current.Request.Url.GetLeftPart(UriPartial.Authority) & wsUtils.SiteRoot & l_sURL
            End If
        End If
        'HttpContext.Current.Response.Redirect(l_sURL, False)
    End Sub

As you can see, I've tried using the extra argument in the Response.Redirect call, but that doesn't make a difference.

All browsers except Google Chrome redirect fine, but Chrome does not redirect at all. When pushing the Cancel button nothing seems to happen. And when pushing the OK button, the corresponding database record is added or updated, but the redirect to the originating page doesn't happen.

This Chrome redirect problem occurs only on the production server. When running the application at 'localhost' there is no problem.

Any idea what might be causing this redirect issue in Google Chrome?


So TempData works on my local machine in chrome, but not out on the server. It works fine in IE and firefox. I'm using the default Session State as InProc. I can see the cookie in chrome by looking at the developer tools.


Hello --

I have begun to use Safari frequently for the first time, due to my recent installation of IE9 Beta.  I'd tell you all sorts of stories about how IE9 is failing in routine daily usage, but it would take too much time.

In addition to that, the "Send Feedback" selection on the IE9 Tools leads to a dead end, even though this addon, Windows Live ID Sign-in Helper, is installed and enabled.

Last week, I was unable to locate a simple method to un-install IE9 Beta and restore Windows 7 IE8.

I am a Microsoft stockholder and would certainly support the company's efforts to improve IE9 Beta, but I might have to use Safari to do it.

The campers are unhappy,



 I'm tring to put up a Text Editor it works in all the browsers except Chrome has any one had this problem


i have used file upload on one of my web page..the file path is not shown in google chrome..rest in all browser the path is shown..in google chrome only the file name is shown and not the whole path..i want the path to be shown in google chrome

plz help me


Hi there, i have did some research on this topic. But what i have try to search still cannot solve my problem in Firefox.

 I have a textbox with textmode= multiline. i put a wrap= true is becoz i wan to display the address line by line and same as how the users input. I have tested in IE,Google Chrome and Firefox, two browser is not working except the IE.


<asp:TextBoxID="txtContactAddress"runat="server"CssClass="txtbox"TextMode="MultiLine"Text='<%#Eval("ContactAddressForApproval") %>'Wrap="true"></asp:TextBox>


when i display the address in website, i got a function to break line as below:


<asp:LabelID="lblContactAddress"Text='<%# GetAddress(Eval("ContactAddress"))%>'runat="server"></asp:Label>



PublicFunction GetAddress(ByVal strAddress AsString) AsString

Return Replace(strAddress, vbCrLf, "<br>")



Do anyone have idea on how to solve tis problem for Firefox and Google chorme?

please give me a hand. thank you in advance





VS 2008, ASP.NET 3.5

Description of problem

I would like to display a navigation on all pages in a website.  I try to achieve this by placing a drop-down list control in the master page, so all pages can inherited this navigation link.  The Auto-postback is set to "true", and the code behind handles the event "SelectedIndexChanged", and depends on the user selection, they are redirected to the relevant page. 

This works ok in IE 8, but it does not work with other web browsers (Firefox 3.5.13, Google Chrome 7.0.517.41, Opera 10.10, Safari 5.0.2).  Although the drop down list is visible, the selection cannot be changed.  The drop-down list values does not render, even the tool tip is not displayed.  It just appears as an image.  Is there something that I am missing here?  Please could you assist? 


Codes in MasterPage.master

<div id="QuickJumpList" visible="false">

        <asp:DropDownList ID="ddlQuickJumpList" runat="server" SkinID="QuickJumpList" AutoPostBack="True"
            <asp:ListItem>Quick Links:</asp:ListItem>
            <asp:ListItem>About Us</asp:ListItem>
            <asp:ListItem>Project 1</asp:ListItem>
            <asp:ListItem>Project 2</asp:ListItem>
            <asp:ListItem>Contact Us</asp:ListItem>


Codes in MasterPage.master.cs

 protected void ddlQuickJumpList_SelectedIndexChanged(object sender, EventArgs e)
        hfSelectedQuickJump.Value = ddlQuickJumpList.SelectedValue;
        Response.Write("Selected value = " + ddlQuickJumpList.SelectedValue);

        if (ddlQuickJumpList.SelectedValue == "Quick Links:")

 else if (ddlQuickJumpList.SelectedValue == "Home")
        else if (ddlQuickJumpList.SelectedValue == "About Us")
 else if (ddlQuickJumpList.SelectedValue == "Project 1")
 else if (ddlQuickJumpList.SelectedValue == "Project 2")
 else if (ddlQuickJumpList.SelectedValue == "Contact Us")
        if (hfSelectedQuickJump.Value != "")
            ddlQuickJumpList.SelectedValue = hfSelectedQuickJump.Value;






I can't believe that my Silverlight app is almost 2 times faster in Google Chrome browser than IE 9.  Is it me or there's something I don't understand ?


Just now viewing the silverlight.net/showcase website has not been a good experience.

I started with the Google Chrome browser version 8.0.552.224 and I get the 'Loading Silverlight Applications' animated logo in the middle, takes a while then I get the icons for all the different sites. The Weather station by Telerik looks interesting so I click on that and get a popup dialog with a 'View Now' button so I click on that.... nothing ... have I clicked on the button? I'll try again ... click  ....  nothing. Tried a few more times but not working, ok so I tried the Cubemania one, this loads something, music begins playing but no screen, nothing and the only way to turn the music off is to close Google Chrome.

I got it to work in Firefox. I knocked off the top box with the smiley face with the first shot, nothing happened so I knocked off the next box then it told me I had failed! hey!  Then I had quite a job closing the firefox browser window.

All in all, rather clunky, slow, buggy, not a good experience for a showcase, when running Cubemania in IE 8.0.7600* it took up to 95% processor and my whole machine behaved like a donkey with three broken legs and one in plaster and the 'connecting to chat' part didnt'.


Sorry guys, I know you have put a tremendous amount of work into Silverlight but I calls em as I seez em.

I think that the showcase shows what may be possible with silverlight on a good day with the wind behind you and the sun shining but this won't do, you have to have it work, click - BAM it works and anything less will probably just be left in the toybox.







Just reporting (maybe someone else can confirm) a bug we're seeing on our end. After discovering that Chrome does a wonderful job of quickly rendering our pages (much faster than IE or Firefox), several of the heavy page editors have adopted it as their main browser. 

However, they're just reported to me (and I've confirmed on my machine; video will be attached) that when text is entered into a Plain Text field on a List Item, that about a second after it's entered, it disappears. 

To replicate: 

* Create an empty Custom List

* Add three fields: Text (make it Multiple Lines of Text > Plain Test), Rich Text (Multiple Lines of Text > Rich Text) and Enhanced (Multiple Lines of Text > Enhanced Text). 

* In my condition, these were all required fields. 

* Add a list item, and enter information into each of the fields. Information entered into the Text field will disappear.... 

Video - http://www.youtube.com/watch?v=A8vres18yXQ

This doesn't manifest itself in other browsers or conditions - only the Plain Text field, or its equivalent. Rich Text or Enhanced Text fields do not show this behavior. I'll post a video example (just uploading to a hosting site now). 

Can anyone else replicate? How to go about reporting?


window xp home edition

I am attempting to clean up my laptop as it is running a bit slow and noticed I have both these versions of Microsoft.NET Framework.  I tried removing Framework 2.0 but got a message to say that it was needed to support some components with the link http://go.microsoft.com/fwlink/?LinkId=91126.  Following that, I came to information about Framework 3.0 but no information to help me.  Can anyone advise on whether I need both? Are components of 2.0 used by 3.0? How to sort this out?  I am not a developer and I have no idea how/when I managed to get to both these versions (probably hit a wrong button or made an inappropriate selection when seeking upgrades for my microsoft software).




I have an assembly which is developed for .NET framework 4.0(3rd party assembly). I wanted to consume this assembly in a webservice which is developed for .NET Framework 3.5. I am facing the following isses.

1. When I am trying to refer the 4.0 assembly in VS 2008 IDE it is not recongnising it at all. I think this will be basic nature

2. When I am trying to add the reference of 4.0 assembly in VS 2010 in 3.5 targeted Webservice, it successfully added the reference. And I am able to use the classes in the 3.5 application. But when I am trying to compile the 3.5 application then the 3.5 compiler is not able to recongnize the classes of 4.0 assembly, and is giving the error like "missing refernce for the class".

The assembly developed for 4.0 is not using any 4.0 features. It is using only the 3.5 features but compiled for 4.0 framework.

Can any one know how to use the .net 4.0 assembly (targetted framwork is 4.0) for 3.5 version applications?.

The restriction is my application will not work on .net 4.0 because it is consuming other applications which always checks for version validation ie 2.0/3.0/3.5 only.

Appreciated prompt help. Thanks in advance.

Suresh Kumar Thanda

couldnot install what's the problem!!!!

Hi All

I have been going insane with this warning:
"The version of the .NET Framework launch condition '.NET Framework 3.5' does not match the selected .NET Framework bootstrapper package. Update the .NET Framework launch condition to match the version of the .NET Framework selected in the Prerequisites Dialog Box."

I have read a whole bunch of forum posts on this and various other boards about people updating the targetted framework, etc., but mine are all the exact same and I'm still getting the warning.

My System:
Windows 7 x64
VS2010 Premium

My Project was upgraded from VS2008.

The three different areas I have found where you can select .NET Framework versions are:
Project Properties -> Compile Tab -> Advanced Compile Options -> Target Framework
Project Properties -> Publish Tab -> Prerequisites
Setup Properties -> Launch Conditions -> .NET Framework

All of the above settings are set to .NET Framework 3.5

I have the bootstrapper package in:
C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bootstrapper\Packages\DotNetFX35

Before I put my fist through my monitor, does anyone have any suggestions for me?



KB981145 is hotfix for Microsoft .NET Framework 3.5 Service Pack 1. Its not included in Update for Microsoft .NET Framework 3.5 Service Pack 1.

I want to know that Microsoft .NET Framework 4 enhancements/imporvements cover KB981145 or not. In other words, Will using .Net 4 instead of earlier versions will solve the issues fixed by KB981145 or not?



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure