Home » .Net FrameworkRSS

.NET Framework Set up 3.5 set up error.

Hi,

I can't install .NET Framework 3.5. I am using windows vista.

Pleasee see the error log:-

[07/03/10,17:41:06] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
[07/03/10,17:41:25] Microsoft .NET Framework 3.0SP1 (CBS): [2] CBS Component is marked to be uninstalled but CBSPackageName is not authored - CCBSComponent::SetManager()
[07/03/10,17:41:25] Microsoft .NET Framework 3.0SP1 (CBS): [2] CBS Component can't be uninstalled as CBSPackageName is not authored - CCBSComponent::SetManager()
[07/03/10,17:41:40] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/10/10,19:40:37] Microsoft .NET Framework 3.5 'package': [2] Failed to fetch setup file in CBaseComponent::PreInstall()
[07/10/10,19:40:37] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
[07/10/10,19:40:37] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
[07/10/10,19:40:37] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
[07/10/10,19:40:38] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
[07/10/10,19:40:38] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
[07/10/10,19:40:38] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
[07/10/10,19:40:38] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
[07/10/10,19:40:39] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/10/10,19:46:14] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
[07/10/10,19:46:26] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/10/10,19:54:11] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
[07/10/10,19:54:23] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.

 

7 Answers Found

 

Answer 1

There are similar threads in the forums, found by searching for "CBS Component is marked to be uninstalled but CBSPackageName is not authored".

like these:

http://social.msdn.microsoft.com/forums/en-US/netfxsetup/thread/0f1d286e-445e-4adc-92c4-ee6773a2d1e9/

http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/57c8fd33-3a88-4ff7-898d-ac947d618f9a

http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/f2356beb-c5a1-4063-95dc-b1db79f8f9d6/

Perhaps the suggested solutions offered will be useful to you.

 

 

 

Answer 2

Hi Robin,

Thank you for your email.

MSI (s) (04:14) [22:16:01:841]: Product: Microsoft .NET Framework 3.5 SP1 -- Error 1935.An error  occurred during the installation  of assembly 'Microsoft.VC90.CRT,version="9.0.21022.8",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="x86",type="win32"'. Please refer to Help and Support for more information. HRESULT: 0x80070003. assembly interface: IAssemblyCache, function: CreateAssemblyCacheItem, component: {B708EB72-AA82-3EB7-8BB0-D845BA35C93D}

For error code  "0x80070003", it means "the system cannot find the path specified".
This error sometimes happens when trying to install  managed assemblies to the GAC.
In many cases I have seen errors with this HRESULT have the same root causes as errors with HRESULT 0x80070002 ("the system cannot find the file specified"). So can you please try to use the troubleshooting steps at http://blogs.msdn.com/astebner/archive/2005/02/01/364375.aspx and see if they help you get past this error?

Hope this helps! If you have any concern, please feel free to let me know.

Best regards,
Yichun Chen
 

Answer 3

Hi,
I am running Windows Vista.
I renamed the assembly folder in C:\Windows, then I tried to install  3.5. I am getting the follwoing error:-

[07/10/10,22:12:20] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed  for component  Microsoft .NET Framework 3.5 'package'. msi  returned error  code 1603
[07/10/10,22:12:39] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/10/10,22:37:08] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned  error code  1603
[07/10/10,22:37:22] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/11/10,01:06:52] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
[07/11/10,01:07:14] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/11/10,12:16:56] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1601
[07/11/10,12:17:10] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/11/10,12:21:02] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
[07/11/10,12:21:03] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
[07/11/10,12:21:03] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
[07/11/10,12:21:03] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
[07/11/10,12:21:04] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
[07/11/10,12:21:04] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
[07/11/10,12:21:04] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] dlmgr: dlmgr::JobBase::Retry:  all retries failed
[07/11/10,12:21:05] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] Failed to fetch setup file in CBaseComponent::PreInstall()
[07/11/10,12:21:05] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
[07/11/10,12:21:05] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
[07/11/10,12:21:05] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
[07/11/10,12:21:05] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
[07/11/10,12:21:05] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
[07/11/10,12:21:05] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
[07/11/10,12:21:05] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
[07/11/10,12:21:06] WapUI: [2] DepCheck indicates Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86) is not installed.
[07/11/10,12:21:06] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
[07/11/10,12:23:17] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1601
[07/11/10,12:23:30] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/13/10,21:23:23] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
[07/13/10,21:23:40] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
[07/13/10,22:03:21] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
[07/13/10,22:03:43] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.

Can anyone help me please?
 

Answer 4

Hi Robin,

Thank you for your reply.

Since .NET framework  2.0 and 3.0 are shipped with windows  Vista as OS components, it is not recommended to rename the assembly folder in C:\Windows.

Have you tried the link that I posted above?

If it doesn't work, I would suggest you to try to run the SFC tool to repair your OS and upgrade your OS to Windows vista  SP2.

Hope this helps! If you have any concern, please feel free to let me know.

Best regards,
Yichun Chen
 

Answer 5

Hi,
I installed Windows Vista SP2. It was successful.
Then I ran Windows Update and it installed Microsoft .NET Framework 4 Client Profile.
I CAN SEE it in my control panel. But, NO information about Framework 3.5.
So, I tried to install  Framework 3.5 sp1 - No Luck!
Thanks,
Robins
 

Answer 6

Hi Robin,

I’m so glad to hear that .NET 4.0 has been installed on your machine.

For .NET 3.5 installation, could you please open a new thread in the forum so that our discussion here will not deviate too much from the original issue.

Thank you for your help.

Best regards,
Yichun Chen

 

Answer 7

Hi Yichun,

I opened a new thread. Please see this link:-

http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/eca05619-b9d0-448a-88bd-f39b621678ac

Thanks

 

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter