Home » Sharepoint 2010

Not getting the Prompt in SP 2010 for "Read Only or Check Out and Edit" anymore.


     I am not getting the prompt for Read Only/edit any more, I am only able to"Open Save, cancel" when I open the file it opens in the native client in read only mode.

 Here are the specs.

Sharepoint 2010 Standard on windows 2008 64 bit. Ms Office 2007

Changes made 

Sharepoint server publishing Infrastructure Activated. Changed the permissions to permissive to open the pdf files in the broswer. Installed/Uninstalled Ms Office 2010 beta.

Any help or guidance is highly appreciated.
I had highly mentioned (edit documents/ single document only) etc to my users and now I am in a pickle.



I am running windows 7 professional, 32-bit. I am also running Office 2007 Ultimate, except that I have put OneNote 2010 and removed OneNote 2007 in the process. 

I run Internet Explorer as a different user, and go to my company's SharePoint site which is in my Trusted Sites. 

When I click on a file (say, xls), I don't get a Read/Edit dialog and instead it just opens the file in Excel and then provides a message bar with a Check Out option. On SharePoint, check out is required for editing. 

I have tried several things:

1. Regedit to add OpenDocumentsReadWriteWhileBrowsing DWORD and set it to 1.

2. Repaired Microsoft Office from Control Panel.

3. Removed Groove features from Office. 

Still, I can't get it to work. 

I have seen quite a few threads with no real solution that seems to work. I have gathered that it is a "client side" issue, but I am looking for some help in identifying how exactly I can fix the client side issue :-(


Dear all,

As a default, my SharePoint farms are showing a pop up window from IE asking if users want to open the doc in read only or in edit mode. Is there a way to get rid of this window as chose one of the options for default? Where can I do this?

Thanks in advance.




Hello Everyone,

We use Sharepoint 3.0 and when I click on a document I get a pop up prompt that asks me whether I want to open the file in READ-ONLY or EDIT mode.   I use a machine with XP Pro that is running IE7.

A user called me today, also running IE7, and when he clicks to open a Sharepoint file he gets a different prompt - a simpler one that just offers OPEN or SAVE.   I don't care that his prompt looks different - the problem is that he is able to open the file, make edits, but then when he closes the file (using Excel) he isn't able to save his changes.   Excel only provides a save-as option for him.

This isn't a permission problem with his ID.   When I login to our Sharepoint 3.0 system as him, with his password (from my machine), I get the usual Read-Only / Edit prompt and when I open a file in EDIT mode I am able to save my changes with no problem.

Any thoughts on this?




I have a user on our Intranet who has permissions to edit documents from a document library. On her laptop the read only /edit prompt stopped working. It opens the excel file in read only format only. She needs to edit. When she logs into a different computer it works ok. I have tried checking all the I.E 7 settings but nothing helps. Has anyone come across this before?

Thank you.



I have a user on our Intranet who has permissions to edit documents from a document library. On her laptop the read only /edit prompt stopped working. It opens the excel file in read only format only. She needs to edit. When she logs into a different computer it works ok. I have tried checking all the I.E 7 settings but nothing helps. Has anyone come across this before?

Thank you.


Whenever a user tries to edit a document in SP 2010 (Excel, Word, etc), they are able to click edit document and then it loads up into Word or Excel and keeps on nagging you for your domain credentials. If you add your proper credentials it still comes back.

I guess the fact that it lets me click the edit document or check out button that my account has proper permissions. I've tried the recommendations of putting the fqdn into my trusted sites. I even get it without using the fqdn (https://sp)


Thanks! This is really bugging me...


Is there a solution to resolve the constant "Prompts" For user id's and passwords when a person tries to open/launch/edit office documents from sharepoint 2010.

My setup: sharepoint fqdn in the domain sp.domainname.local, The sharepoint server is a member of this internal domain. In dns I have local zone of sp.domainname.com with a cname that points to the internal sharepoint server. There is no issue in users accessing the server both internal and external, The issue arises when Office documents are launched from SP2010.

In central admin I have configured the alternate access mappings to be http://sp

I have also tried putting the fqdn dns name of the sharepoint server in IE8 trusted zone but
no luck, I still get credential prompts.

I think the issue might be that Office does not see that the files are coming from the fqdn of sp.domainname.com so hence the prompts.

Trying to fix this as right now its a total pita. I found some previous posts on this issue with SP2007 but found nothing that really addresses this in SP2010.

Thanks Paul


When I'm working on my site in Sharepoint 2010 and I select an option to edit with Sharepoint designer i get a dialogue box asking me if i would like to download it.









I am not sure this is a bug or it is meant this way. 

I check the file out and start edit it. While editing the footer or header area, i select check in, Word 2010 gives me a message "This document cannot be checked in while the Web server copy is open. Close the Web server copy and try again". However, if i quit editing the footer or header area, select check in, the document will be successfully checked in. 

Versioning is enabled on the library.



how can i edit the viewfilter.aspx mobile page in sp 2010, i want tp add more filter fields in the "add filter" option, currently im only getting the title field 




i want to edit and update my sharepoint task list using c#, i have selected fields and i want to edit those fields, how can show their old values as well when i press the edit button ? thanks


Is there a simple answer for checking if a list date field is blank in SP Designer 2010, so as to send an email if it is?


Is there a simple answer for checking if a list date field is blank in SP Designer 2010, so as to send an email if it is?


Hi.  Please excuse my ignorance.

I need to set up a Sharepoint Server upon which I'll install an eval webpart written by a well known MS partner.  The webpart will connect to that partner's eval server (which I've already set up) and render BI graphics for viewing by clients of the SP server.

My boss said to install the free version of SP 2010.  He said we have plenty of licenses.  I poked around and see about 4 flavors of free SP 2010 trials but nothing that looks free past the trial period.  Maybe I'm not looking hard enough.

My recollection is that in the SP space, there is/was a watered down version of SP that came free with the OS license.  I already have a server available with a licensed W2008 OS installed.   I just need to find the best SP download given my marching orders.  Can somebody help and enlighten me a bit? 



When I have local files that are edited, but not checked out, how can I get the option to merge it with what's on the server? At present TFS 2010 only gives me the option to overwrite the local file. TFS 2008 did this correctly - it gave you the option of merging them or ignoring the server and using just the local file.

thanks - dave

I have a solution of 4 projects under source control in a TFS server. I am using Visual Studio 2010 and have a workspace set up locally on my machine. Under Tools->Options->Source Control->Environment I have the Settings set to Team Foundation so all the check boxes are unchecked and under Checked-In Items I have Saving: set to "Check Out Automatically" and Editing: set to "Check Out Automatically". Allow checked-in items to be edited is also unchecked (though I tried this with it checked as well and it did not fix my problem).

When I edit a file in Visual Studio 2010, it does not get checked out. So when I make some changes to any file and try to save, I get the message:

The file X.cs cannot be saved because it is write-protected.

You can either save the file in a different location or Microsoft Visual Studio can attempt to remove the write-protection and overwrite the file in its current location.

I then have to select Overwrite. When I go to my source control, it doesn't recognize any change. It says I have the latest code and there is no pending change. I have to manually check-out the file before it realizes there is a change and then I can check it in.

My colleague has another workspace in the same project and his works fine. If he edits a file, it immediately checks out the file and shows a pending change in his source control. We have the exact same version of VS2010 (10.0.30319.1). I went through his settings and they are identical to mine. I even deleted my workspace and tried to create another one and I still have this problem. Going through every file I want to change beforehand and checking it out manually is just ridiculous. How can I make the automatic check out work again?


When attempting to edit a field we have set to read-only (Remaining Work) in the WIT, we get an error in Excel 2010:

TF84042: The value you entered is not supported in this field. Select a supported value from the list.

Excel 2007 allows edits with no error. Is this because Excel 2010 is enforcing the read-only attribute from the WIT and Excel 2007 doesn't?  Or is the error caused by something else?



wondering if anyone else has experienced this.

I have created a custom content type.

the template is an xltx that I created from an xlsx provided by one of the users.

I added 2 simple custom columns ( 2 choice fields )

I choose to create an instance of the content type from

documents tab -> new item -> new <content type>

so far so good.

I make some changes to the xlsx and update the 2 columns associated with the content type.

when I try to save the xlsx , a label is displayed saying that the document is checked out.

when I close the document I get the "other users will not be able to see the changes until you check the document in" ( even though i never checked the document out )

I then get an error when I click yes saying "no version checked out"

so I click no to close the document.

SharePoint displays the document as checked out.

I select "discard check out" and SharePoint says can't find checked out version please delete document.

seems strange ? anyone else notice this problem ?





Could any one, help me with step by step instruction how to migrate data form sbs2003 share point to share point 2010?

I have new instalation of w2k8 enterprise. Company web for new instance of sharepoint musn't be the same as previus site from sbs2003. I need only data like holiday calendar.

Thanks for help.



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure