Home » SQL ServerRSS

Could not load file or assembly ADODB, Version=7.0.3300.0

I have an application broadly deployed (about 10 computers). As of yesterday, two of these computers are unable to start the application, and failing with the error below. All other computers run the application just fine.

System.IO.FileNotFoundException: Could not load file or assembly 'ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
File name: 'ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

I checked and ADODB.dll version 7.0.3300.0 is in the GAC in the deployment target machines.

I find ADODB.dll in my C:\Program Files\Microsoft.NET\Primary Interop Assemblies folder (development computer), but this is version 7.10.3077.0 (file properties version)

I see ADODB.dll as a project reference, but this shows version 7.0.3300.0, and shows the path to the PIA folder. I have no clue why these are not showing the same version number. Local Copy is false.

Installing MDAC 2.8 on the failing deployment target machines did not help.

Any clues or ideas or things to try??
 

31 Answers Found

 

Answer 1

sounds like a versioning issue ...try installing the upgraded version to the non-qworking machines..

HTH

 

Answer 2

Lee:
I am having the same problem. I didn't understand HTH's reply about "installing the new version". Do you have any idea what version he was talking about?.

More importantly, wWere you ever able to resolve the problem? Thanks!

Jim

 

Answer 3

HTH:

I am having the same problem but don't understand your response. What product "version" are you referring to when you say it is a "versioning problem"?

Thanks!

Jim

 

Answer 4

Not a clue. It was not helpful to me. This has happened subsequently to us on other computers. What I found I needed to do was place a copy of ADODB.dll into the application folder. Even though the very SAME version of ADODB was ALREADY installed at the deployment computer's GAC. This should not be necessary, and makes no sense to me. I really believe there is some other problem here.
 

Answer 5

Hey Lee (or anyone),

I have the same exact issue.  Has anyone found a solution ?

Thanks !
Dwain

 

Answer 6

I just had this problem today and I found a solution to it:

if you look in c:\program files and cannot find the folder Microsoft.NET

then that is the first cause.

or if you dont see the file  adodb.dll in

c:\program files\Microsoft.NET\Primary Interop Assemblies

Solution:

go to a machine that has this folder and copy it (or the adodb.dll file if you have the folder) to the machines that cannot find the adodb  file

Go into this folder and into the primary interop folder

copy this folders contents to the GAC (c:\windows\assembly)

your app should find the adodb.dll now

Hope this helps

Jason

 

Answer 7

I have a web application that is reporting the same error.  It runs fine on my developement box but when I try to publish the site through the Publish function in VS 2005, I get the same error on the server.  My web server is a Win2K server.  I did what Jason said in his post and it didn't correct the error.  Any ideas?

Wes

 

Answer 8

hi, I made as Jason K said and it works for me, be sure after load  into de gac every dll , to restart your iis, and read carefully the new message error (if there is something else), it could be a new one error
 

Answer 9

I have a cuestion...

how assembly  the ADODB version 7.0.3300.0 in PC?


 

Answer 10

Works great. Thanks.

My production Windows XP Pro box did not have "C:\Program Files\Microsoft.Net," so I copied this folder from my development Win2000 Pro box onto it.

My production box login account did not have Administrator previledges and/or could not copy to "C:\Windows\Assembly" so I found the GACUtil.Exe on this box, which happened to be in "C:\Windows\Microsoft.NET\Framework\v1.1.4322," and relied on my DOS days to invoke this utility against each of the .dlls from the command prompt; registering them to the GAC.

The location of the GACUtil.Exe was not in my search path on this Windows XP box so the command was a bit weird looking, as it included the location of the GACUtil.Exe:

"C:\Windows\Microsoft.NET\Framework\v1.1.4322\GACUtil.Exe"   /i   adodb.dll

I actually registered all the .dlls in one command as follows:

For %J In (*.dll) do "C:\Windows\Microsoft.NET\Framework\v1.1.4322\GACUtil.exe"    /i   %J

Note: These commands were invoked at the Command prompt from within the "C:\Program Files\Microsoft.NET\Primary Interop Assemblies" directory; Alternatively I could have prefix the .dll names with their path (i.e. C:\Program Files\Microsoft.NET\Primary Interop Assemblies\adodb.dll in the case of adodb.dll).

GD.

 

Answer 11

salam all,

this is how i solved the issue:

 I copied:

c:\WINDOWS\assembly\GAC\ADODB\   from the development machine to the other machines ( same location ).

Hope this helps.

 

Answer 12

Hi,

I am using VS 2005 and SQL server2005. When I run application it build successfully but in place of login page following exception occured

"System.IO.FileNotFoundException: Could not load  file or assembly  'AnyDLL' or one of its dependencies. The system cannot find the path specified."

Pre-bind state information ===
LOG: User = CLIENT07\ASPNET
LOG: DisplayName = AnyDLL
(Partial)
LOG: Appbase = file:///C:/Develop
LOG: Initial PrivatePath = C:\Develop\bin
Calling assembly : (Unknown).
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: C:\Develop\web.config
LOG: Using host configuration file: c:\windows\microsoft.net\framework\v2.0.50727\aspnet.config
LOG: Using machine configuration file  from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/develop/8638167d/1d65244e/Interop.ADSSECURITYLib.DLL.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/develop/8638167d/1d65244e/AnyDLL/Any.DLL

LOG: Attempting download of new URL file:///C:/Develop/bin/Any.DLL

LOG: Using application configuration file: C:\Develop\web.config
LOG: Using host configuration file: c:\windows\microsoft.net\framework\v2.0.50727\aspnet.config
LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
ERR: Failed to complete setup of assembly (hr = 0x80070003). Probing terminated

Please help me regarding this.

Thanks

Mahen



 

Answer 13

I am facing the same problem. However I solved it differently. I just removed the following line from the web.config:

<addassembly="ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

However, now I have to remember removing that line everytime I provide the build. Because the VS 2005 adds that line back in and I dont know how to tell VS not to add that thing in.
 

Answer 14

The Safest way would be to Find the "adodb.dll" ver 7.0.3300.0 and paste it to your Project's BIN folder.
 

Answer 15

Hi, I resolved that problem by creating a Web Setup Project for my Web Site, then I added to the bin directory the adodb.dll from the GAC, by using the right button/Add/Assembly/adodb (from the GAC) and OK

Then this Interop Assembly is copied to the msi file  and installed on the bin directory of the virtual directory.

It works!

 

Answer 16

Well after reading all of the suggestions above, I tried the following and it resolved my issue that I was having that was similar to everyones above.

In the setup part of my project, I did an 'Add' ---> 'Assembly...' Then from the resulting dialog box, I picked 'ADODB'. After I rebuilt the package and installed it on the problem machines, the program is running fine now. Thanks everyone for your insight as to possible solutions. For my situation, this seems to be the cleanest solution.

Thanks again everyone! - ERic-

 

Answer 17

I have the same error message after deploiying to 2 machines (I have 3 that are OK)., but the problem I have is that one (for certain) DOES NOT HAVE ADODB anywhere on it even though I've installed the dotnetframework.
 

Answer 18

I was having the same issue on a W2K3 server. I found that it did work on my dev server, so I poked around and found a newer adodb.dll on my dev server in the same folder as the application that was throwing the error in prod. I renamed the existing dll on my prod server to .old then copied the later dll from my dev server to my prod server. This doesn't appear to be an OS related issue, more of an application dependency issue. If you are writing your own applications, be sure to check that your dependent dll's are up to date and packaged with your app when you do your final compile.

 

Answer 19

Resume is find Adodb.dll by anyway and open the target assembly  folder, then Drag and Drop the dll file  to the folder listed.

it's the simple way to import the Adodb.dll , no command, no headache

 

Answer 20

I found your solution is the better and best then the others posted.

Thanks a Lot

Balu

 

Answer 21

Lee Gillie wrote:
I have an application broadly deployed (about 10 computers). As of yesterday, two of these computers are unable to start the application, and failing with the error below. All other computers run the application just fine.

System.IO.FileNotFoundException: Could not load  file or assembly  'ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file  specified.
File name: 'ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

I checked and ADODB.dll version 7.0.3300.0 is in the GAC in the deployment target machines.

I find ADODB.dll in my C:\Program Files\Microsoft.NET\Primary Interop Assemblies folder (development computer), but this is version 7.10.3077.0 (file properties version)

I see ADODB.dll as a project reference, but this shows version 7.0.3300.0, and shows the path to the PIA folder. I have no clue why these are not showing the same version number. Local Copy is false.

Installing MDAC 2.8 on the failing deployment target machines did not help.

Any clues or ideas or things to try??
 

Answer 22

Safest and simple way of adding the adodb.dll ver 7.0.3300.0 is right click on the setup file  go to add-->Assembly You will get  the Select Component Dialog Box Select the Adodb.dll ver 7.0.3300.0 and click Ok the adodb.dll will be added to the setup file....by default the adodb.dll will be added to the application folder on setup ..


Happy Programming

 

Answer 23

just in web.config put <clear/> or  use
  <remove assembly="ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>

 <compilation defaultLanguage="c#" debug="true">
         <assemblies>
  <clear />
         </assemblies>
    </compilation>

Thanks!
Satyadev

 

Answer 24

I had the same issue where it works in a computer but not in another. For the one machine that was not working, I added that above key to the web.config and it worked like a charm. Thank you AmolB!

 

Answer 25

I encountered the same problem as I was publishing a new, lightweight .Net 2.0 app using ClickOnce. Since i have published quite a few of these, I got to looking around and saw that I needed to include a reference to the file  (ADODB.dll). Then, in the Project Properties, on the Publish page, I went to the Application files tab, selected ADODB.dll and changed the 'Publish status' to 'Include'. the next time I ran the installer, it automatically installed the dll for me, problem solved.

Hope this helps someone.

Bob Ives

Code Blue Designs

 

Answer 26

Hi

This is Deepak, and I developed a windows application, and create it’s setup. Now one error is in my application in running crystal report error description is given bellow.

Could not find load  assambaly

‘crystal Decisions.windows.forms,

version = 10.2.3600.0, culture = natural.

PocketKey Token = 692fbe95521el130’ or one of its dependencies, the system cannot find the file  specified.

Please tell me how I can solved it.

Deepak parkas

 

Answer 27

hey everyone thanks for the answers it helps me to resolve my problem with the adobd.dll

you are the best
 

Answer 28

I have been looking for an anwer places and found that SHRIMANT PATEL's solution is the simpliest and actually work. Yes, just copy and paste the dll to the bin directory.

Thanks.

 

Answer 29

I had the same problem today on 2 workstations running a .NET application.  Looking into the folder that the application is locally installed in I noticed that adodb.dll was missing.  Downloaded the latest version, copied it into this folder on each machine and voila - all works fine!

 

Answer 30

Hello my name is Marcel, I'm from Brazil.
Here is an installation package done in Visual Studio to various errors including GAC this error on the number 7.0.3300.0 of ADODB , is a page downlods, seize before it expires.


http://www.ziddu.com/download/6687294/InstalaodoPacoteVSTO.zip.html


msn: joaomarcelgomes@hotmail.com

 

Answer 31

I notice that some of my users have the directory c:\program files\Microsoft.NET\Primary Interop Assemblies as well as having the adodb  installed while others do not.

Is there already a package that should install this on a users PC..like does a .NET framework x.x   install this?

I really want to avoid having to set this up in my Windows Installer MSI

 

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter