Home » Visual Studio

Remote debugging symbols not loaded

When attempting to debug a web application running on its web server, VS 2010 always shows the, "Break point will not be hit, no symbols are loaded" message.  All machines are within my AD domain.  The workstation is running Windows 7 Pro x64.  The server is running 2008R2 Enterprise on a Hyper-V host.  After wasting several days hunting this down I found the following:

The PDB file is not getting copied to the Temporary ASP.NET directory where the debugger has loaded the DLL from.  If I attempt to load the symbols from the PDB in the URL bin directory, I get the "No matching file found" message.

If I copy the offending "No matching..." PDB from the URL bin directory to the Temporary ASP.Net Files directory, I can attach to the process and the symbols load just fine.

I do not have this problem when debugging a site or service on a Windows 2003 server hosted on the same Hyper-V host.

How do I kill this little gremlin?


2 Answers Found


Answer 1




Thank you for your question, we're doing research on this case. It might take some time before we get back to you.


By the way, you can submit this issue to Microsoft Connect feedback portal http://connect.microsoft.com, Microsoft engineers will evaluate them seriously, thanks. If this issue is urgent, please contact support at http://support.microsoft.com.


Answer 2



This problem has already been reported earlier to VS product group

PDB missing from Temporary ASP.NET Files when debugging on remote webserverhttps://connect.microsoft.com/VisualStudio/feedback/details/563707/ 

Meanwhile you can follow the workaround in above URL



Good day,
I have an ASP.NET application that isn't too big, 10 pages and a moderate amount of code behind. When I run the app in debug mode it takes over a minute to load the symbols, about 75 seconds consistently, which seems excessive to me. This of course leads to the issue of the browser doesn't open until the symbols are done.

Here are some particulars concerning my environment. The machine is a P4 2.8 with plenty of resources. I haven't had any issues with it recently. I recently installed SP1 for VS2005. I also have VS 2003 on the same machine and it runs fine and takes about one second to load all of the symbols. The debugging is only local on the one machine. When I start the app without debugging (CTRL-F5) it starts up in about a second or two. This is how I have been debugging recently rather than stepping through code. Just trading one source of pain for another. I did try running the install of VS2005 again in maintenance mode with no change in performance.

Below is the text from the Modules window is VS2005. Sorry for is being so mangled. Having read, it feels like, every post in here that seemed to have anything to do with this issue, I don't think there is anything unusual here. Thanx for any assistance you can provide.

mscorlib.dll C:\WINDOWS\assembly\GAC_32\mscorlib\\mscorlib.dll Yes No Skipped loading symbols.  1 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:15 PM 790C0000-79BA6000 [3696] WebDev.WebServer.EXE: Managed 

 WebDev.WebServer.EXE C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\WebDev.WebServer.EXE Yes No Skipped loading symbols.  2 8.0.50727.762 12/2/2006 5:36 AM 00400000-00420000 [3696] WebDev.WebServer.EXE: Managed 

 WebDev.WebHost.dll C:\WINDOWS\assembly\GAC_32\WebDev.WebHost\\WebDev.WebHost.dll No No Cannot find or open the PDB file.  3 8.0.50727.42 9/23/2005 5:20 AM 5DED0000-5DEE0000 [3696] WebDev.WebServer.EXE: Managed 

 System.Windows.Forms.dll C:\WINDOWS\assembly\GAC_MSIL\System.Windows.Forms\\System.Windows.Forms.dll Yes No Skipped loading symbols.  4 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:17 PM 7AFD0000-7BC56000 [3696] WebDev.WebServer.EXE: Managed 

 System.dll C:\WINDOWS\assembly\GAC_MSIL\System\\System.dll Yes No Skipped loading symbols.  5 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:16 PM 7A440000-7ABFE000 [3696] WebDev.WebServer.EXE: Managed 

 System.Drawing.dll C:\WINDOWS\assembly\GAC_MSIL\System.Drawing\\System.Drawing.dll Yes No Skipped loading symbols.  6 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:17 PM 7ADE0000-7AF74000 [3696] WebDev.WebServer.EXE: Managed 

 System.Web.dll C:\WINDOWS\assembly\GAC_32\System.Web\\System.Web.dll Yes No Skipped loading symbols.  7 2.0.50727.210 (QFE.050727-2100) 1/10/2007 5:25 PM 65F20000-66A72000 [3696] WebDev.WebServer.EXE: Managed 

 System.Configuration.dll C:\WINDOWS\assembly\GAC_MSIL\System.Configuration\\System.Configuration.dll Yes No Skipped loading symbols.  8 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 64890000-6497E000 [3696] WebDev.WebServer.EXE: Managed 

 System.Xml.dll C:\WINDOWS\assembly\GAC_MSIL\System.Xml\\System.Xml.dll Yes No Skipped loading symbols.  9 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:18 PM 69BE0000-6A148000 [3696] WebDev.WebServer.EXE: Managed 

 System.Web.RegularExpressions.dll C:\WINDOWS\assembly\GAC_MSIL\System.Web.RegularExpressions\\System.Web.RegularExpressions.dll Yes No Skipped loading symbols.  10 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 69890000-698D0000 [3696] WebDev.WebServer.EXE: Managed 

 Microsoft.JScript.dll C:\WINDOWS\assembly\GAC_MSIL\Microsoft.JScript\\Microsoft.JScript.dll No No Cannot find or open the PDB file.  11 8.0.50727.42 9/23/2005 2:34 AM 5E600000-5E6BA000 [3696] WebDev.WebServer.EXE: Managed 
 VJSharpCodeProvider.dll C:\WINDOWS\assembly\GAC_32\VJSharpCodeProvider\\VJSharpCodeProvider.dll Yes No Skipped loading symbols.  12 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 6C3B0000-6C3D8000 [3696] WebDev.WebServer.EXE: Managed 

 CppCodeProvider.dll C:\WINDOWS\assembly\GAC_MSIL\CppCodeProvider\\CppCodeProvider.dll No No Cannot find or open the PDB file.  13 8.0.50727.762 12/2/2006 5:23 AM 5B300000-5B31C000 [3696] WebDev.WebServer.EXE: Managed 

 App_Code.lpt2etxi.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Code.lpt2etxi.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Code.lpt2etxi.pdb 14 2/28/2007 8:29 AM 00D50000-00D5C000 [3696] WebDev.WebServer.EXE: Managed 

 Microsoft.VisualBasic.dll C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualBasic\\Microsoft.VisualBasic.dll Yes No Skipped loading symbols.  15 8.0.50727.42 (RTM.050727-4200) 1/10/2007 5:24 PM 5E410000-5E5BC000 [3696] WebDev.WebServer.EXE: Managed 

 System.Data.dll C:\WINDOWS\assembly\GAC_32\System.Data\\System.Data.dll Yes No Skipped loading symbols.  16 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:16 PM 65140000-657A8000 [3696] WebDev.WebServer.EXE: Managed 

 App_global.asax.7xffqv5i.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_global.asax.7xffqv5i.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_global.asax.7xffqv5i.pdb 17 2/28/2007 8:29 AM 00DB0000-00DBA000 [3696] WebDev.WebServer.EXE: Managed 

 ExceptionHandler.DLL C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\assembly\dl3\7639dd36\00e51216_78cfc601\ExceptionHandler.DLL No No Cannot find or open the PDB file.  18 1.0.2437.19305 9/3/2006 10:43 AM 11000000-11008000 [3696] WebDev.WebServer.EXE: Managed 

 System.Web.Mobile.dll C:\WINDOWS\assembly\GAC_MSIL\System.Web.Mobile\\System.Web.Mobile.dll Yes No Skipped loading symbols.  19 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 695A0000-697DA000 [3696] WebDev.WebServer.EXE: Managed 

 App_Web_go2nuzei.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_go2nuzei.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_go2nuzei.pdb 20  2/28/2007 8:30 AM 00E00000-00E28000 [3696] WebDev.WebServer.EXE: Managed 

 App_Web_iccp.master.cdcab7d2.cycmyovv.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_iccp.master.cdcab7d2.cycmyovv.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_iccp.master.cdcab7d2.cycmyovv.pdb 21 2/28/2007 8:29 AM 044B0000-044BE000 [3696] WebDev.WebServer.EXE: Managed 

 System.Transactions.dll C:\WINDOWS\assembly\GAC_32\System.Transactions\\System.Transactions.dll Yes No Skipped loading symbols.  22 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 67AF0000-67B9C000 [3696] WebDev.WebServer.EXE: Managed 



i have the following VS2010 issue:

I have a profiler dll registered via env. vars by Guid like this:



So am able to profile any silverlight4 aplication, and can see the result of my profilee work.


The problem comes when i try to debug my profiler.

I am passing the apsx file to my ie browser as env. var in my VS2010 profiler project.

command: c:\Program Files (x86)\Internet Explorer\iexplore.exe

command argument: http://localhost:3954/SilverlightApplication1TestPage.aspx

i even pass the working path dir to my sileverlight's pdb file, in order to load its debug info ...

working directory: C:\Users\grozdev\Documents\Visual Studio 2010\Projects\SilverlightApplication1\SilverlightApplication1\Bin\Debug

the profilee has been debugged, but i cannot stop in any of the breakpoints i setted.


First i get a note that "Debbuging information for iexplore.exe cannot be found or does not exist. Symbols found (information stripped)"

And then any of my breakpoint is marked as "Breakpoint will not currently be hit. No symbols have been loaded"

PS: I load all the symbols from the "Microsoft Symbols Server" (options->debugging->symbols), and except:

'iexplore.exe': Loaded 'C:\Program Files (x86)\Common Files\microsoft shared\Windows Live\WLIDNSP.DLL', Cannot find or open the PDB file
'iexplore.exe': Loaded 'C:\Program Files (x86)\Unlocker\UnlockerHook.dll', Binary was not built with debug information.

.., all the symbols has been loaded.


Thank you in advance!


Afternoon all,

This morning VS 2010 started doing something interesting.  Without my altering any settings it's started loading a whole slew of symbols anytime I start debugging.  The one that seems to take the longest is "Loading symbols for C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\Accessibility\v4.0_4.0.0.0_b03f5f7f11f50a3a\Accessibility.dll".  It's happening in more than one solution.  I've checked that the enable just my code option is selected(Debug menu -> Options and Settings... -> Debugging -> General -> Enable Just My Code (Managed Only). 

Visual Studio takes even longer once I break out of debugging (shift+F5) and shows the"Microsoft Visual Studio is Busy" balloon which states "Microsoft Visual Studio is waiting for an internal operation to complete.  If you regularly encounter this error during normal usage please report this problem to Microsoft."

Any ideas?


I'm pulling my hair out over this one. Custom pipeline component written to use OLEDB to parse contents of an Excel document into a DataTable.


It is having a problem where it is returning null for certain fields and I'm trying to debug where this happens and why. But I am unable to get the debugger to load the symbols when I attach to the BizTalk host. 


I've rebuilt, redeployed, confirmed it is in the GAC (with the right version) as well as copied the assembly to \BTInstallDir\Pipeline Components, restarted host instances (restarted server too in case it was some oddball problem). I made sure when building it was in debug/development mode and not release.


I've never had this much trouble attaching my debugger to a process and I have no clue why this is so difficult. Is there anything else that needs to be done to attach to custom pipeline components I am missing?


I moved a ASP.Net project from VS2008 Pro to VS2010 Premium and now for that project it takes forever to start a debug session.  VS is spending an inordanate amount of time loading symbols.  My settings under Tools->Options->Debugging->Symbols are Microsoft Symbol Servers is unchecked, I have local case folder specified and Only Specified Modules are to be loaded of which there are none.

Are these settings correct, or is there something else that is causing this problem?



I can't seem to debug any thread that I start in my C++ MFC application. The non threaded code debugs. I can see the call stack and step through the code. When I try to hit a break point in a thread VS tells be that no symbols are loaded and the source is not available. I use AfxBeginThread(ThreadFunc, this) to start the thread.

Up until a few weeks ago I was able to debug everything just fine. Since then Office 2010 has been installed along with Internet Explorer 8. I am running on Windows XP 64-bit SP2. I first encountered this problem with Visual Studio 2008 so I tried installing VS 2010 to see if that would solve the problem. It did not unfortunatly.

I tried uninstalling VS 2008 (leaving just 2010). I reinstalled the remote debugger as I saw that mentioned in a different thread. I've tried many of the solutions presented in other threads although they tend to relate to not being able to debug at all or about Silverlight or .NET debugging. Of course I've rebooted countless times. I still have to problem.

OK, Everyone who has done a decent amount of coding has run into this problem once or twice over the years.  I know I have in the past and I've been able to fix it.  This time however I need some help.  Someone who knows where to kick the beast I'm sure.  I'm running on Windows 2008 on a 64 bit machine.  Using VS2008 I've built a "website" which shows up under the websites folder of VS2008 not the Projects folder.  This matter because the property pages and some other settings are different than if I would have created the project and made a web application.   IIS 7 is the web server that is being used.  I am at the point where I need to use IIS 7 as the debugger not the .NET debugger.  I can debut in the .Net debugger but for some reason no-matter what I've tried I can not get the break points to set when I switch the debugger to use IIS 7.  It tells me that the symbols are not loaded.  I have Verified the following:

1) Settings in web.config is set to



2) All aspx files have debug="true in them


@PageLanguage="C#"AutoEventWireup="true"CodeFile="Default.aspx.cs"Inherits="_Default"debug="true" %>

3) Under The Website Tab -> Start Options -> use custom server is checked.

4) In configuration manager Active Solution is set to Debug

Debug, .Net and the check box is checked

5) When I compile it indicates that it is compiling for DEBUG

6) After compiling three App_Web_*.pdb files are built in the Framework/v2.0.50727/Temporary ASP.NET Files/<websitename> directory.  Specifically


7) When I hit F5 to debug Different App files are created in the Temporary ASP.NET Files/Root Directory (2 files)


Description of Problem:

When I try and set a break point in the page_load function of the default.cs (code behind).  I get a hollow red circle and it says that the symbols are not loaded.

1) When I look at the Modules it says that the symbols have been loaded for the two .pdb files in root but there is no reference of the .pdb files that were created when the project was compiled (in the above stated directory)

2) This is the same weather f5 debug or attach to process.  No files in the website project have any symbols loaded.  Yes the IIS and VS2008 are running on the same machine.

3) There is no reference to the compiled .pdb files in the modules loaded page so I can not override the symbol file to load so I can not do it manually.

Please help me OB1 your my only hope.  I've been on this for weeks.  Where do I kick VS2008 or IIS to finally be able to debug?




Some days ago all of my projects started working crazily - I'm using VS 2010, .NET 4.0, Silverlight 4 SDK, WP7 SDK. The previously compiled code parts can be debugged as they should be, but as soon as I make any change to the observed .cs file all symbols are ignored.

"The breakpoint will not currently be hit. The source code is different from the original version."

However, the compile is successful, moreover the changes in the code can be seen in the debug mode as well (e.g. if i add messagebox.show(...) it works as expected), but I'm unable to debug the project.

This happens to my Silverlight, WPF, WP7 solutions, Web Applications, so everything important. The most annoying thing is that I even reinstalled Visual Studio, the whole .NET Framework 4 Client Profile, but nothing changed.

I don't want to reinstall the whole OS, but this way i'm unable to work:/

Any help / tips appreciated on what to do / what else to reinstall.




I need to know what the performance bottlenecks are, and what the functions are trying to do, within an IE 8 instance.

I can attach to the process successfully, and generate a performance report successfully, however the resolution stops at mshtml.dll.

After ceasing data collection, I get the following in the output tab within VS. I believe it is related:

Symbol Engine: Failed to load matching symbols for module 'C:\WINDOWS\Symbols\dll\mshtml.pdb'

I am using IE8 on Windows XP Professional with SP 3. It is not the check/debug version.
I am running VS Team System 2008, Development Edition.
I have downloaded and installed symbols from here: http://www.microsoft.com/whdc/devtools/debugging/symbolpkg.mspx
I tried running an instance after this and it still gave the failed to load symbols output.

Within VS I have gone into Tools>Options>Debugging>Symbols and added the following three symbol files locations:

Note: the buttons 'Load symbols using above locations' and 'Load symbols from Microsoft symbol servers' are greyed out.
In the textbox 'Cache symbols from symbol servers to this directory' I put c:\SymbolCache
I tried running an instance after this and it still gave the failed to load symbols output.

Note: I don't know if the 'debug' option area even applies, however there is no symbol setting interface within the Performance Tools option section.

Following this thread: http://social.msdn.microsoft.com/Forums/en/vstsprofiler/thread/db1e2ad9-3161-4f67-b781-6e7b83273c2d
I saved the performance .psess file to a static location and copied mshtml.pdb from c:\windows\system\mshtml.pdb to the same location.
Re-running a capture resulted in the same output:
Symbol Engine: Failed to load matching symbols for module 'C:\WINDOWS\system32\mshtml.dll'

To reiterate; performance explorer is working fine... I just need it to be able to 'dig in' to mshtml.dll.

I think the underlying questions are simple: Why can't it do so, and how do I get it to?


Hello All,


I know similar questions been answered before but I could not find an answer similar to my scenario.

OS: Windows XP SP3

Debugger: VisualStudio 2010 professional

I have created a project in VS2010 and it uses couple of DLLs which are build in VC++6 using "optimisation set to disable" and debug info set to "programme database". I have given the symbol paths from VS2010 Tools -> Options->Debugging -> symbols -> xxx.pbds

I can hit my break points and I can step into the code without any issues, but I dont see anything on locals window neither when I add class memebers to watch i get well know CXX0017 error.

I must be doing something silly, but I cant figure that out yet. Could one of you kindly shed some light for me.


Note: If I do the same test other way, i.e. build my .exe using VS2010 and run it through VC++ 6 (where I originally build my DLLs) then if I set break points I can see all variables. But unfortunately debugging is much slower in VC++ 6, hence this is not an option for me at the this moment.

please help me.





I am trying to debug a Farm level solution (Full Trust Solution) and cannot get the BreakPoint to hit on VS2010. This is my Hyper-V setup:

DevSp10 = hosting the SharePoint 2010 application, SP2010 installed, and remote debugger DevVS2010 = Sharepoint installed and Visual Studio Now, I created my WSP (Visual Web Part, timer job) and manually deployed it and activated the feature on the DevSP10 environment. Looks good, but getting a small error on the Webpart. Now, I turn on Remote Debugger, starts off fine, I go back to my DevVS2010 environment and look for my DevSp10 connection and it accepts it. I show all processes from all users and attach to the w3wp.exe process. It attaches just fine and now the Breakpoint tells me "The breakpoint will not currently be hit. No symbols have been loaded for this document". Suggestions?

Ever since upgrading to Visual Studio 2010, when I'm debugging my application (a few minutes into debugging), I get the following error message "The remote debugger has encountered a serious internal error, and must abort the remote debugging session. Please restart debugging." in th windows event log. The upgrade to 2010 coincided with us also running the application in 64 bit. This is currently happening when I'm debugging locally, but it doesn't mean that the problem doesn't happen remotely as well.

After that error message i also get the following events

Faulting application name: msvsmon.exe, version: 10.0.30319.1, time stamp: 0x4ba23831
Faulting module name: msvsmon.exe, version: 10.0.30319.1, time stamp: 0x4ba23831
Exception code: 0xc0000005
Fault offset: 0x0000000000071469
Faulting process id: 0x2f74
Faulting application start time: 0x01cb49ff50df3c61
Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x64\msvsmon.exe
Faulting module path: C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x64\msvsmon.exe

That is quickly followed by my application crashing the following event repeated twice

NET Runtime version 2.0.50727.4927 - Fatal Execution Engine Error (000007FEF473B4DF) (0)

After all this, I am unabled to debug into my process again until I restart my instance of Visual Studio


Hello there,

'The debugger cannot connect to the remote computer. This may be because the remote computer does not exist or a firewall may be preventing communication to the remote computer.  Please see Help for assistance.' is the error, into which I run on trying to debug my code.

I have googled for a couple of past days searching for a solution and have tried far too many suggested solutions, yet none worked. So asking this question here is my last resort more or less.


My code is deployed on Windows Server 2003 SE R2 on top of VMWare 7.0.1; I have Visual Studio 2008 Remote Debugging installed there.

My project and Visual Studio 2008 SP1 run on 64-bit Windows 7 Enterprise.

Both machines are part of the same domain, and my user account is a local Administrator on each of these machines.


If I run MSVSMON on my remote machine in No Authentication mode Allowing any user to debug, my local Native debugger is able to connect using the Remote transport.

However, if I switch MSVSMON to Windows Authentication mode, my local Managed debugger is no longer able to connect using the Default transport. And here I am stuck, since I need to debug an ASP.NET code.

I suspect that the problem is related to security settings around Named Pipes and DCOM that enable the Default transport  of remote debugging, so I disabled any security restriction on Named Pipes, DCOM and remote access, which I could find. Without any success...


So at this point any help will be deeply appreciated, and I thank in advance for any assistance.


-- Best regards,

I'm on a team of around a dozen engineers working on a large C++ project using Visual Studio 2005. After many months of working correctly a problem began yesterday for two of us.

The problem is that when we attempt to start debugging our program, visual studio halts for several minutes while it appears to be loading symbols for ntdll.dll. Once this hitch is done things seem to continue as normal, although it appears to run a bit slower (this could be user perception.)

Starting without debugging causes no hitch, however attaching to a process DOES cause the hitch.

Adding an extra 5-10 minutes each time we try to debug is a significant productivity problem for us. Has anyone else suffered from this problem?


I've installed a program that was developed in house and have copied the entire development tree, including the exe's and symbols, to a local drive. After loading this solution into Visual Studio 2k5, I then attach to Outlook 2k7 and attempt to set a break point in one of our DLL's (we inject some DLL's into the Outlook address space). However, Visual Studio doesn't associate the source code in the solution with the binaries that it is debugging so it won't let me set break points, trace through source, etc. Is there some way to let Visual Studio know that the source code in the project belongs to the binaries it is currently debugging?
On this computer (Windows XP) I am unable to download debug symbols from the public microsoft symbol server. According to my network monitor, VS rapidly initializes and closes networking (probably once per dll module) but doesn't open any connections. As a result, whenever I try to load symbols, VS just hangs for a while and then prompts me to find the symbols file on my computer. I tried downloading the xp sp3 symbol package, but apparently it's only for clean unpached installs. I also tried windbg and it also has these issues. It's possible it's related to my earlier issue - http://social.msdn.microsoft.com/Forums/en/vsdebug/thread/4cc361c4-5f7a-4a40-98ac-f1e5534eaf17 . I'm suspecting that some windows service that the symbol downloader requires is stopped, however I have no idea which one. The fact that VS fails totally silently isn't helping either. Anyone know how to solve this?

I am posting on behalf of my colleague, who is facing this issue. He has a application, which is throwing up the below errors while debugging.

Loaded 'ntdll.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\kernel32.dll', no matching symbolic information found.

Loaded 'D:\September month Overrieder C 2010\OVERIDERC\Debug\c4dll.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\user32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\gdi32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\comdlg32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\advapi32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\rpcrt4.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\secur32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\comctl32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\shell32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\msvcrt.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\shlwapi.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\winspool.drv', no matching symbolic information found.

Loaded 'C:\WINNT\system32\oledlg.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\ole32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\olepro32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\oleaut32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\imm32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x-ww_35d4ce83\comctl32.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\uxtheme.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\msctf.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\version.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\msctfime.ime', no matching symbolic information found.

Loaded 'C:\WINNT\system32\clbcatq.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\comres.dll', no matching symbolic information found.

Loaded 'C:\WINNT\system32\version.dll', no matching symbolic information found.

CoCreateInstance of OLE control {DB797690-40E0-11D2-9BD5-0060082AE372} failed.

>>> Result code: 0x80040154

>>> Is the control is properly registered?

Warning: CreateDlgControls failed during dialog init.

The thread 0x161C has exited with code 0 (0x0).

The program 'D:\September month Overrieder C 2010\OVERIDERC\Debug\OverriderC.exe' has exited with code 0 (0x0).

May I know if any body knows the solution? Thanks in advance.



I have one C++ application that crashes when installed on the same machine as SQL Server 2008. I works fine on machines without SQL Server 2008.
The root cause seems to be the fact that version 8.0.50727.1833 is installed on this machine (probably SQL Server 2008 does this), because the crash occurs inside MFC80.DLL only on machines with SQL Server 2008.

Normally I would debug this problem by stepping through the MFC code, but
- Microsoft's symbol server does not offer any debug symbols for MFC80.DLL version 8.0.50727.1833, and
- the source code in Visual Studio 2005 SP1 is for MFC80.DLL version 8.0.50727.762.

Therefore, my question is:
Where can I get the debug symbols and the source code for MFC80.DLL version 8.0.50727.1833?

- Frank



I'm trying to profile Silverlight 4 application using xperf. I followed steps on http://blogs.msdn.com/b/slperf/archive/2010/08/19/analyzing-silverlight-memory-usage-part-1-obtaining-measurements.aspx but I can't see any debug information on Silverlight dlls (agcore.dll, npctrl.dll...).

It looks like there are no debug symbols on MS Symbol server (http://msdl.microsoft.com/download/symbols). for latest Silverlight runtime (4.0.51204.0) Can you please tell me when theese debug symbols will be available? Or where can I download theese files?




Hello, I have configured VS2010 with the source server option.I want to have a place to save all the pdb files generated for a Team build, so I set the parameter 'Index Sources' to true and set a 'Path to Publish Symbols'.

When an assembly is "source server-enabled", the pdb file will contain the full path and the exact version of the file in source control that was used to build that assembly. If the debugger then enters a method, Visual Studio automatically downloads that correct file, places it in a local cache, and opens it for debugging.

The solution consist on one console project with one reference to other library that shows a message. I want to debug my application with different versions of this library.

After I have launched the build, I can look that the pdb files exist in the folder I have used to set the path to publish symbols.

I put that path in the Debugging --> symbols option to load the symbol.

Ok here is the problem when I am debugging my application I have to load the symbol for my own dll manually but Visual Studio never takes the pdb files from the source server, so always take the source code that is located in my local directory and never the code from the source control (that could be different).

So my question is how can I debug my own application using the pdb files generated for the Team Build that are located in the source server?




<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure