Home » Sharepoint 2010

What are the side-effects of renaming SharePoint Application Pool in IIS


I wonder if it's safe to rename application pool in IIS that is used by SharePoint Service Application?

This question is raised from the fact that when we create new application pool in the dialog box of creating new Service Application, this application pool is created with GUID name in IIS, and it's hard to track down which app pool in IIS is linked to SharePoint. 

There is an article in MSDN describing how to rename the app pool http://technet.microsoft.com/en-us/library/cc725568(WS.10).aspx but I'm not sure how SharePoint can be affected in this case.




Is it possible to rename the Sharepoint 2010 application pools? I'd like to use something more meaningfull than GUIDs.

Thank you,



Hi there,

I'm working intensively with the VBA editor in Access. Sometimes I realise that the name of a variable should be changed. However, that variable is not only used within one module but all over the Access application, even in queries. But since there is no refactoring possible with the editor, a change of a variable name (in the definition section) means to find all variables within all modules, forms, queries, etc. And of course it is very easy to miss out a variable. That all can finally lead to serious side effects. The search will allow you to find variables in the modules, but not in forms, queries or reports.
The same counts for functions which need to be renamed.

So, how do serious Access developers deal with that issue?



When creating a PowerPivot Service Application I am giving two options: "Use existing application pool" or "Create new application pool" and if I join an existing pool which one should it be "SharePoint Web Services Default" or "SharePoint Web Services System"?

Now I understand isolation and other technical reasons but what I want to understand is what you guys in the field that run SharePoint Farm would want me to configure and if that does not cause me any scale or performance issue we are good.  If I want to run outside most SharePoint standards I better have a good reason.

One note I just missed was: "While this may be a good security best practice, you may still want to use an application pool and/or managed account that is tied to your SharePoint Farm account. As will be noted in Chapter 9, for the PowerPivot data refresh feature to work, the PowerPivot Service Application and PowerPivot System Service requires Farm account rights to access the Secure Store Service database." -- PowerPivot for Excel and SharePoint, page 217

So folks what you would suggest or better yet, how would you like it configured within your farm.


Denver, CO


  I've a wcf application that is published into an IIS application pool.

  After publishing it, and accessing the services exposed, everything works fine. But when accessing the application after a certain time, the idle tiem configured for the IIS application pool, the application is no more compiled and I get the following error, below.

  Does anyone figure out why the application works fine and only after the idle time this compilation problem occurs? And, how can I know which assembly is the IIS trying to load and which file is not found?

Thanks in advance,


[FileNotFoundException: The specified module could not be found. (Exception from HRESULT: 0x8007007E)]
   System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0
   System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +43
   System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +127
   System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +142
   System.Reflection.Assembly.Load(String assemblyString) +28
   System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses) +162
   System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath) +11729164
   System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +42
   System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +479

[ServiceActivationException: The service '/Corporativo/SPOCServices/Corporativo.SPOC.WS.TIBCOiProcessService.svc' cannot be activated due to an exception during compilation.  The exception message is: The specified module could not be found. (Exception from HRESULT: 0x8007007E).]
   System.ServiceModel.AsyncResult.End(IAsyncResult result) +11599786
   System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +194
   System.ServiceModel.Activation.HostedHttpRequestAsyncResult.ExecuteSynchronous(HttpApplication context, Boolean flowContext) +176
   System.ServiceModel.Activation.HttpModule.ProcessRequest(Object sender, EventArgs e) +278
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +68
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75


OK so here is the situation:

I created a web application on port 80 working fine and i went to install SMTP services. have no clue how but when i did this is removed my web applications from my site list. I was able to run the sahrepoint configuration wizard and get the administrative console back, everything seems to be in order and work EXCEPT my web application isn't in IIS and i have no clue how to get it back in, just how to extend it and remove it..  so overall, all i need to do is basically re attach my web application to IIS so i can use it again.



We planned to switch from native mode to sharepoint integrated mode our SQL Server Reporting Server.
But it is a production server, so we liked to know if any side effect can happened on existing report and if it is possible to switch an existing database into sharepoint integrated mode ?

Mathieu Perrin.


Hello! I have problem with my hosting company.
They set virtual memory limit on iis, and says, than my web site exceed limit - 96 Mb.

I testing in memory profiler and knew, that is not right.

I made a simple test.  I create simple project (frameworkk 3.5) from one page with text "Hello World" and attached this site
to my IIS6.

And I see, if I set the  parameter maximum virtual memory is less than 500 Mb, then
I get error
In event viewer:
"A worker process with process id of '5848' serving application pool 'DefaultAppPool' has requested a recycle because it reached its virtual memory limit."

If I set parameter maximum virtual memory to 500 Mb and set parameter maximum used memory to 96 Mb my site work normally.


It seems, that asp.net takes a 500 mb memory in reserve.


I have a WCF service hosted in IIS (IIS 7 with .NET 3.5 SP1) that uses a custom UsernamePasswordValidator to validate message credentials against a database. The problem is that it works for a while, but over a period of time IIS stops responding to all client requests until the application pool is recycled. The IIS worker process has some requests that get stuck in the "AuthenticateRequest" pipeline state of the "ServiceModel" module.

In my testing, I can consistantly reproduce the problem by forcing a client to create a new service proxy with a different username and password and calling the WCF service every few seconds.

To troubleshoot I created a new project and removed all of the authentication code in the Validate function so that the UsernamePasswordValidator will accept any username and password combination without throwing an exception, but IIS still hangs:

namespace WcfTestService
  publicclass CustomValidator : UserNamePasswordValidator
    publicoverridevoid Validate(string userName, string password){//code removed for testing}

If I remove the ServiceCredentials node from the Service Behavior, IIS doesn't hang anymore, but there is no user validation that takes place either, which is a problem.

Here is the service binding configuration:

<services><servicename="WcfTestService.Service1"behaviorConfiguration="WcfTestService.Service1Behavior"><endpointaddress="" binding="wsHttpBinding"bindingConfiguration="SecureAuthBinding"contract="WcfTestService.IService1"/></service></services><behaviors><serviceBehaviors><behaviorname="WcfTestService.Service1Behavior"><serviceMetadatahttpsGetEnabled="true"/><serviceDebugincludeExceptionDetailInFaults="false"/><serviceCredentials><userNameAuthenticationuserNamePasswordValidationMode="Custom"customUserNamePasswordValidatorType="WcfTestService.CustomValidator, WcfTestService"/></serviceCredentials></behavior></serviceBehaviors></behaviors><bindings><wsHttpBinding><bindingname="SecureAuthBinding"><securitymode="TransportWithMessageCredential"><transportclientCredentialType="None"proxyCredentialType="None"/><messageclientCredentialType="UserName"/></security></binding></wsHttpBinding></bindings>



Currently I have Sharepoint 2010 installed and it's taking about 30 seconds or so to open it up initially in the morning.  I'm assuming it's application pools are being recycled sometime during the night time.  What will be the easiest way to configure the server, so that I can minimize the slowness in the morning?




I am using Visual Studio 2010 to create page layouts and preview images(http://blog.beckybertram.com/Lists/Posts/Post.aspx?ID=71). I was successful in creating page layouts but the image was not coming properly.

So I decided to change the path of image and deploy the project (Empty SharePoint project). But this time, I am getting an error
Error occurred in deployment step 'Recycle IIS Application Pool': Provider load failure
I am sure there is no relation between changing image path in elements.xml and this error.

I also browsed through and found some related issues, but they are not specific to VS 2010 or SharePoint 2010. And I am apprehensive of implementing them.

1. The logged in user is site collection admin and local admin
2. Windows Management Instrumentation service is running
3. App pool's identity is configured to the local admin & password has not changed.

Thanks in advance

Vighnesh Bendre



good mornning all,

When i am trying to Deploy Solution for Web parts in Visual Studio 2010 having an error.

Error occurred in deployment step 'Recycle IIS Application Pool': The local SharePoint server is not available. Check that the server is running and connected to the SharePoint farm.

after looking different links on net i found that Sharepoint_Config and Sharepoint_Admin databases user should be db_Owner and same account user which Visual Studio 2010 is running. Means what user name i entered in credentials to log in on machine same user name should be db_owner for  Sharepoint_Config and Sharepoint_Admin database. i did the same for Sharepoint_Config database made my machine user account name db_owner for Sharepoint_config database.

But also there is one condition is that in my sqlserver management 2008 only one database Sharepoint_Config is avilable but Sharepoint_Admin not.is there any problem because of it.

Still when i try to Deploy Solution i face the same error.

Thanks to all.


We migrated our web server to window server 2008, IIS 7.

We have single sign on application - that we login through one application called "users" and then no need to login to other applications, they all use the same machine key and cookie.

it works fine when all then applications under the same application pool.

but we have one application that is asp.net 2005.  (the rest are asp.net 2003)

 the user application is in asp.net 2003 and that  other application is in asp.net 2005.

so each application is in a different application pool. -

one pool to asp.net 1.1 and other pool to asp.net 2.

when I run the asp.net 2005 application

I get the login page and after I  login  I get the following errer:

HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested Url: /users/Unauthorised.aspx


Important: If I switch the "user" application (the login) to work under the same pool as my asp.net 2005 application, then it works fine with the asp.net 2005 application,but I get the above error for the asp.net 2003 applications

All this happened after we switched to IIS 7 Windows 2008, with IIS 6 it works great!!!

Thank you





Hello All,

I had posted this question at IIS forum. http://forums.iis.net/t/1172803.aspx

Was told to post the question on ASP.NET forum. Here is the problem I am facing.

"My application (ASP.NET) writes certain files in folders on my servers. In IIS 6.0 I used to give write access to IUSR account so that IIS can write to the folder. Now what I see is my application pool runs under App Pool Identity account. That is good but users are able to create files in the folders without App Pool Identity user being given specific permission to do so.

Has anybody come across the issue?"

One of the reply seems to accurate. It looks like once the user is authenticated it can create folders and write files anywhere.



Hi All,

My first ever question here. I have looked around the internet for some material around this and found nothing, which makes me believe it's likely to be something I have missed/done wrong!

Anyway, the problem is that when I click on "Configure Service Accounts" under the Security heading in Central Admin there are quite a few more Web Application Pool's than is showing in IIS manager.

These are all old web app's that were created through SharePoint 2007 and have since been deleted. (The ones I deleted I used Central Admin to remove, I don't think this is the case for every single app though)

This seems to be the only place in Central Admin which is listing these old Web Applications. Could anyone advise where I should be looking so I can clean these up?

Thanks in advance for any help you provide.


For the second time in a few weeks, we've had to cycle one specific IIS Ap pool serving one our SharePoint Web applications.  If users hit that site on that node, there were getting a http 500 error. The other node would serve the site just fine.


Here's the last relevant thing event system log was reporting around 1:13am last night - we noticed the problem around 8am today:


A process serving application pool 'pool name here' exceeded time limits during shut down. The process id was '6640'.


A process serving application pool  exceeded time limits during shut down



Seeing lots of errors like this around the time in SharePoint log



High       #20001: Cannot open file "Resources.resx" for reading.

08/23/2010 01:12:38.27 w3wp.exe (0x24BC)                        0x1798  Windows SharePoint Services   General                                72kg                High       (#3: Cannot open file "Resources.resx" for reading.)      

08/23/2010 01:12:38.27 w3wp.exe (0x24BC)                       0x1798  Windows SharePoint Services   General                                       8e26      Medium               Failed to open the language resource for Fea75A0FEA7-C256-49cb-BF7F-DE124CA9BF13 keyfile Resources.



Then this around 1:12:


08/23/2010 01:12:55.28 w3wp.exe (0x220C)                       0x0C38  CMS                                       Publishing                           8x0a       High                    AppDomainUnloadListener.RegisterSelf() entered lock(this=41149443)

08/23/2010 01:12:55.28 w3wp.exe (0x220C)                       0x0BF0  CMS                                       Publishing                           8x0a       High                    AppDomainUnloadListener.RegisterSelf() entered lock(this=41149443)



08/23/2010 01:12:49.11 w3wp.exe (0x1358)                         0x24F0  Windows SharePoint Services     General                                0                Medium               Flushing template cache due to low memory condition. Current memory used 25718196, target memory used 42620928

08/23/2010 01:12:49.11 w3wp.exe (0x1950)                         0x24CC Windows SharePoint Services     General                                0                Medium               Flushing template cache due to low memory condition. Current memory used 408162, target memory used 42620928


08/23/2010 01:12:49.11 w3wp.exe (0x2574)                         0x08CC Windows SharePoint Services     General                                0                Medium               Flushing template cache due to low memory condition. Current memory used 21774571, target memory used 43292672

08/23/2010 01:12:49.11 w3wp.exe (0x05F4)                         0x264C  Windows SharePoint Services     General                                0                Medium               Flushing template cache due to low memory condition. Current memory used 8389288, target memory used 43292672

08/23/2010 01:12:49.11 w3wp.exe (0x1AC4)                       0x1A5C Windows SharePoint Services     General                                0                Medium               Flushing template cache due to low memory condition. Current memory used 477701, target memory used 43327488


08/23/2010 01:12:49.11 w3wp.exe (0x1B30)                         0x0964  Windows SharePoint Services     General                                0                Medium               Flushing template cache due to low memory condition. Current memory used 40148947, target memory used 43409408

08/23/2010 01:12:49.11 OWSTIMER.EXE (0x06C0)                              0x0284  Windows SharePoint Services     General                                       0              Medium               Flushing template cache due to low memory condition. Current memory used 425015, target memory used 43450368  





The last time this happened was on node01 on a Wednesday.



Around  that time at night we are indexing all of our content.  The last major thing we did in SharePoint was load a lot of new user profiles about 3 weeks ago. Both of these are now suspect.


Not seeing anything relevant in http error or iis logs for the site.

Thanks for any help or suggestions on how to troubleshoot this.






I have just installed Sharepoint 2010 and when Central Admin starts up i get a HTTP Error 503 Service is Unavailable. The Central admin app pool states that it is stopped in ISS though after starting the app pool and going back to Central Admin the App Pool crashes again

Anyone seen this error before or know how to resolve this?





i have change the application pool of the central administration with a user name and a password using this: "stsadm-o updatefarmcredentials-userlogin domain\username-password password". now i want to change it back to predefined: Network Service.

if i change it by going to iis then application pool then propeties and change it to network service after a while it change back to the configurable with username and password

how can i change it back?


Hi, I read the MS stuff stating that running ten Application pools (not web apps) on a server is roughly about the maximum you should have running on a server (okay it alls depends on the amount of RAM and the actual box) but my question is as such, when installing SP 2010 and all the services, for instance for a client and they want the services configured whether they are going to use them or not. You could end up with over well over 10 application pools, so what services are okay to share an application pool and which should have have their own application pool. Is there some info out there on best practice remember i am asking this for production builds not test as I see that the Stand Alone SP2010 Wizard Installation runs all the services under the same application pool.

Some guidence or info would be appreciated. Thanks


Hi all,

after installing Sharepoint 2010 Standard in Farm mode, application pool on FE stop working after opening the Central Administration.

Browser say :

Service Unavailable

HTTP Error 503. The service is unavailable.



Eventvwr say:

Log Name:      System
Source:        Microsoft-Windows-WAS
Date:          26/10/2010 11:00:16
Event ID:      5059
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxx

Application pool SecurityTokenServiceApplicationPool has been disabled. Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" />
    <EventID Qualifiers="49152">5059</EventID>
    <TimeCreated SystemTime="2010-10-26T09:00:16.000000000Z" />
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Security />
    <Data Name="AppPoolID">SecurityTokenServiceApplicationPool</Data>


Installation done following the technet least-privilege model (http://technet.microsoft.com/en-us/library/cc678863.aspx)

Any ideas?





<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure