Home » .Net Framework

SQL Management studio for Azure & Editing

I am transitioning from a dedicated server sql instance to Azure and beginning to realize how spoiled I have come to having the complete SQL Management Studio to edit tables, indexes and such. So my question when will we get those features for editing SQL Azure databases? And is there an alternative that we can use for now?

7 Answers Found


Answer 1

I too would like to know how to add or modify fields in a table in a SQL Azure database.  How is this done?  I see that I can view my Azure database from within SQL Server 2008 R2 Express.  But I see no option there for going into design mode.  How do you make changes to a SQL Azure database table? 

Answer 2

Design mode (using GUI for editing) is presently limited to deleting only. Time you brush up a few T-SQL vocabulary and usage. There is the SQL Azure template available in SSMS.

You can use ADD, REMOVE columns using Alter Table statements.


Answer 3


Currently, we don’t have this GUI feature when working with sql  Azure databases  using SQL server  Management Studio 2008 R2. As a workaround, we can use T-SQL statements to manage our SQL azure  databases.

I don’t know when we will have it but you can vote for the following suggestion in our SQL Azure Feature Voting Forum:


I think this feature will be included in a future release.


Answer 4

I'd recommend keeping on on-prem version of the DB schema. With this, you can attach to it, make changes with the GUI, and then export "update scripts" which you should then be able to run on SQL Azure.

Personally, I recommend keeping a copy of the schema on-prem anyways and using change scripts to help with versioning. :)


Answer 5

I think an on Prem version of the db is a good idea.  I am still new to Azure but my understanding is that it is fairly easy to make a backup of the Azure database to a local db.  It sounds like a good idea to make changes using the GUI locally.  However, getting those changes up to Azure (without affecting the data that's already in the db) sounds a little hairy. 

I am an Access developer and literate in a number of areas, but not a sql  Server DBA.  I am familiar enough with SQL Server to create tables  etc and use it as a back-end to other tools.  If I have to, I can brush up on T-SQL with regard to changing, adding or modifying fields, but management  Studio does spoil you.  I would like to find the easiest way possible, I'm not sure if what you're suggesting is any easier than just boning up on T-SQL.

Sure hope SQL Azure will make this management studio  addition in the futurel


Answer 6

essentially you'll be using the managment studio  to do the t-sql for you. The upside is that you always will have a local version that's up to date as well as a set of versioning scripts that you can use to apply changes to your DB on.

Either way, boning up on t-sql is something I'd recommend. You don't have to take it as far as being a DBA. But knowing your way around t-sql will help you be a better sql  Server developer. :)


Answer 7


Please take a look at Project Houston: https://manage.sqlazurelabs.com/ . I haven't tried it personally but from the blog post by David Aiken (http://www.davidaiken.com/2010/07/21/manage-your-sql-azure-databases-with-project-houston/ ), I believe it has GUI based editor for managing tables, views etc.

Hope this helps.


Gaurav Mantri

Cerebrata Software





When I choose Modify to edit my table using SSMS 2005, I can edit certain attributes but not others such as the identity column. It is not bolded so I can edit it unlike allow nulls which is bolded. Can someone explain why?


I'm connected to my SQL Azure database. When I right click on the Tables node of my database and ==> New Table, a text query window opens with a generic text template and common CREATE TABLE commands.  

If I am connected to a local SQL database, New Table displays a fill-in-the-column grid and, by the way, the tables created all start with dbo.[TableName].

Why the difference, and can the fill-in-the-Grid approach be made to work with SQL-Azure tables?

Thanks in advance for any help...

I have read the other posts on this forum about connecting to SQL Azure from SQL Server Management Studio 2008 and I believe I am doing everything that is required, including forwarding port 1433 through my router and firewall. But I am still getting error code 18456.

The full error message is:

Cannot connect to xxx.ctp.database.windows.net.
Additional Information:
Login failed for user 'yyy'. (Microsoft SQL Server, Error: 18456)

Where xxx is the server name that I get from the portal and yyy is the name which the portal labels the "Server Admin".
Does anyone have any insight into this error? Thanks!



I am new in SQl Azure.

I have created SQl Azure Database in Windows Azure Control Panel and the Test connection was Sucess.

And i tried connect it from Sqlserver 2008 Enterprise Edition Client (sp1) Management studio. I coud see the Master and [Test Database](My database) .

If i select [Test Database] i am getting the "Database is not Accessible" error.

Can any one help me



Liyasker Samraj K


I have created a database on SQL Azure and configured firewall as mentioned at the URL: http://msdn.microsoft.com/en-us/library/ee621783.aspx. However, when I try connecting to my database from management studio (I am using Windows7), I get the following error:

TITLE: Connect to Server

Cannot connect to xxxxx.database.windows.net.


A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=53&LinkId=20476

Error Number: 53
Severity: 20
State: 0

Program Location:

  at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
  at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
  at System.Data.SqlClient.TdsParser.Connect(ServerInfo serverInfo, SqlInternalConnectionTds connHandler, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject)
  at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
  at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
  at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
  at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
  at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
  at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup)
  at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
  at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
  at System.Data.SqlClient.SqlConnection.Open()
  at Microsoft.SqlServer.Management.SqlStudio.Explorer.ObjectExplorerService.ValidateConnection(UIConnectionInfo ci, IServerType server)
  at Microsoft.SqlServer.Management.UI.ConnectionDlg.Connector.ConnectionThreadUser()

Please note that I have also done the following things:

Opened TCP port in firewall (Inbound Rule) as mentioned at URL: http://msdn.microsoft.com/en-us/library/ms175043.aspx When I do telnet command : telnet xxxx.database.windows.net 1433 I get the following message:
Connecting To xxxx.database.windows.net...Could not open connection to the host, on port 1433: Connect failed

Please advise what I should do?




Consider that I have 2 tables and I want to create many to many
relation between them.
Customer table and Address Table.

we need to create a
relation between them (many to many)

A Customer can have many Addresses, and many Customers can live at the same Address. 
How can we do that using tables - keys?? The only relation that I can see is 1 to n

Thank you



I am new to this developing on this platform and having problems at work and home but different problems. 

At work when i try and view the aspx page it says unable to connect to the asp.net development server and also can't add the database to the app_data folder.  Are there problems with visual studio 2008 /Sql server 2008?

set up at  work is below

L-06914  server

Microsoft SQL Server Enterprise Edition

Microsoft Windows NT 5.1 (2600)

At home, I was making a connection and almost bringing up the page  but had an error the next day could not connect inside of sql server 2008. 

At home it is the same except for standard version

server is my computer name

Let me know if more information is needed. Thanks,  SB


Dear folks

Am learning SQL Server at a company where I work.

I was curious as to what were the pros and cons of using Visual Studio or SQL Server Management Studio for our development on the database side (i.e. table creation, stored procedure writing, etc.).

What constraint does each choice pose? Pliz advise me.




Help -

I had been using SQL Management Studio, from sql server 2005, reciently I installed Visual Studio 2008 on my machine.  I use it for VB coding.  I still use the same Management studio.  It all works fine except when I try and Export or Import a table in Management Studio using the wizard.  I get the following error:

TITLE: Microsoft SQL Server

This wizard will close because it encountered the following error:

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=9.00.3042.00&EvtSrc=Microsoft.SqlServer.Management.UI.WizardFrameworkErrorSR&EvtID=UncaughtException&LinkId=20476


Exception has been thrown by the target of an invocation. (mscorlib)


Specified method is not supported. (System.Data.SqlServerCe)



Any help would be appreciated.

Thank you


I cannot figure it out.

same error as this one.


Has this been resolved.  I do not have the ability to edit the msi, this is a msdn iso.


Please help.



I'm newbies in microsoft SQL

I did try to create a new login using "SQL server authentication" option and it failed

According to the error message the "SQL server authentication" is not supported by Microsoft SQL Server Management Studio Express. Is it true?

Also When I did install SQL 2005 express I did check The "SQL server uthentication" and supply user and password but it does not appear in Microsoft SQL Server Management Studio Express under security/logins.

Here the error message. Can someone help me?

TITLE: Microsoft SQL Server Management Studio Express

Create failed for Login 'lebeluet'.  (Microsoft.SqlServer.Express.Smo)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=9.00.1399.00&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Create+Login&LinkId=20476


An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.Express.ConnectionInfo)


The MUST_CHANGE option is not supported by this version of Microsoft Windows. (Microsoft SQL Server, Error: 15195)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=09.00.1399&EvtSrc=MSSQLServer&EvtID=15195&LinkId=20476




I have recently formatted my hard drive and over the past few days I've been reloading my software.  I have installed on my machine SQL Server Express 2005 SP3.  I prefer to have SQL Express running on my development machine because that is what my customers primarily use.  I also have a full MSDN license, and I would need to install SQL Management Studio 2005.  However, when I download the SQL Server 2005 Developer ISO from MSDN, and run the setup file I get an error message that states:

Installation of Microsoft SQL Server Native Client failed because a higher version already exists on the machine.  To proceed, uninstall the higher version and then run Microsoft SQL Server Native Client Setup.

I would assume the problem is that the copy of SQL Server - Dev Edition that is available through my MSDN subscription is using an earlier version of SQL Server 2005 (most likely the version prior to SP1.)  I would just unistall SQL Server Express 2005 SP3 and reinstall it with out any service pack updates.  The problem is that I also see within my Add or Remove Programs list  four SQL Server 2008 R2 entries, that I believe were installed when I installed Visual Studio Pro 2010 (they are, Microsoft SQL Server 2008 R2 Data-Tier Application Framework, Microsoft SQL Server 2008 R2 Data-Tier Application Project, Microsoft SQL Server 2008 R2 Managment Objects & Microsoft SQL Server 2008 R2 Transact-SQL Language Services)  I have no idea of what those SQL 2008 entries are for and I'd rather not uninstall them if I will potentially be using them in future projects that I create in VS2010.  I assume it is a possibility that they are clashing with my installation attempts, rather than my installation of SQL Express 2005 SP3 but I'm not sure.

What I need is to be able to install some full version of SQL Management Studio 2005, while having any version of SQL Server Express 2005 on my machine.  I have found in the past that SQL Server can start to act "finicky" if you uninstall and reinstall a bunch of versions.  In fact, I had to reformat my HD because I could not install any version of SQL Server under a mandatory instance name.  I have nothing against an un-installation and re-installation of software.  My fear, though, is that lingering registry entries will prevent a clean, usable installation from taking place, especially when I specify a SQL Server instance ID that I had previously used.  I've tried to swith SQL Server versions in this manner before and, well, it screwed the registry so badly I had to reformat the computer...

Expert comments are appreciated.  I need assurance that this won't happen again but I understand that all suggestions are offered without warranty. :)

I created an sql query file in SQL Server Management Studio and saved it onto my hard drive. 
I then moved that file into a Sharepoint Document Library so others on my team could use that query.
I opened the file from within sharepoint, it launched SSMS.
I made a change to the file and pressed save.
here is the error message that comes up.
"The operation could not be completed.  The process cannot access the file because it is being used by another process"

Am I doing something wrong?

I have two UPDATE queries, when executed together in SQL Command, takes about 5 minuts. but when executing together in management studio,totally takes about only 1 minute.

I have indexes on all the fields used in join. Have done some research and tries some suggested ways such as use various SET options. not quite useful.



n Set

FITokenCount = b.TokenCount

, FISignificantOPTotal = b.SignificantOPTotal

, FIInsignificantOPTotal = b.InsignificantOPTotal



@ScanDataScanResultsTableName n


INNER HASH JOIN @ScanDataTableName b


ON n.InstitutionNumber = b.InstitutionNumber and n.DataItemUniqueID = b.DataItemUniqueID





n Set

WLTokenCount = wn.TokenCount

, WLSignificantOPTotal = wn.SignificantOPTotal

, WLInsignificantOPTotal = wn.InsignificantOPTotal



@ScanDataScanResultsTableName n


INNER HASH JOIN WatchListEntryNames wn


ON n.WatchListEntryNameID = wn.WatchListEntryNameID --and wn.Type = 1;


Any inputs will be greatly appreiated.










Hi all,

I've installed SQL Server 2008 SP1 CU9 developer edition and SQL Server 2008 R2 Express side by side on my machine.

When I try to open/expand SQL server logs node under Management on developer edition instance, I get the following error message:


TITLE: Microsoft SQL Server Management Studio

Failed to retrieve data for this request. (Microsoft.SqlServer.Management.Sdk.Sfc)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&LinkId=20476


An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)


A severe error occurred on the current command.  The results, if any, should be discarded. (Microsoft SQL Server, Error: 0)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.00.2789&EvtSrc=MSSQLServer&EvtID=0&LinkId=20476


The SQL Server Management Studio version is 10.50.1600.1

SQL Server 2008 SP1 CU9 version: 10.0.2789.0

SQL Server 2008 R2 express edition version: 10.50.1600.1 RTM


I don't get that error when expanding SQL Server Logs on express instance, only on the developer edition.

Any ideas how to solve this issue or hints what the cause might be, will be appreciated.






I would like to be able to use SQL Management Studio on the passive node in our cluster if there's a failover and Passive Node becomes Active Node.  It seems like the Add Node install didn't load SQL Management Studio on our passive node.

Any help is appreciated.

Thanks,  Morrisos



I have problem connecting to reporting services from SSMS, it used to work before, but recently in the rsreportserver.config file <UrlRoot>http........</UrlRoot> was changed to a different one. After that I had problem connecting to reporting services. We need that URL retained in the config file, if anyone know any work around to get into SSRS, please let me know.

I am getting an error that, the remote name could not be resolved: 'xxxxx.xxx.com' (Here it is showing the new URL that is in the config file)

We are using Reporting Services 2005

Is it OK to SQL Management Studio 2008 to administer databases on a SQL 2005 server?

This is probably an easy one, but can I use SQL Server Management Studio Express to work on a regular SQL Server database? If I can, are there any gotchas I should be aware of?


I just installed the 64bit version of SQL Server using the Developer edition CD for SQL Server.  The problem I'm having is that I cannot connect to SQL Server using SQL Server Management Studio.  I’m getting the message “a network-related or instance specific error occurred while establishing a connection to sql server. the server was not found or not accessible. verify that the instance name is correct and that sql server is configured to allow remote connections.”.  I’ve done a lot of Google searches but yet to find a solution.  I've checked to be sure it is started and enabled all protocols except VIA.  I have remote connections allowed.  I used the default name MSSQLSERVER which is what I'm using to connect to in Management Studio.

Can someone help, I have no idea what to check now.  BTW, I've also installed SP3.

Thank You,



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure