Home » SQL ServerRSS

SSRS 2008 R2 Error - Unsupported RPL stream version detected: 34.62.1836345404. Expected version: 10

Hello,

Development Server

Recently, I have upgraded SQL Server 2008 Reporting Services (Integrated Mode) with SQL server 2008 R2 (Enterprise version). This reporting services configured with Share Point 2007 (MOSS) farm. Successfully upgraded the SQL 2k8 R2( Microsoft SQL Server Reporting Services Version 10.50.1600.1 ).  Before upgrade i can able to run report without any error but after upgrade when i tried to deploy report, report deployed fine, but when i tried to run report i got following error.

An error occurred during client rendering. Unsupported RPL stream version detected: 34.62.1836345404. Expected version: 10.3.

 

I can run report successfully directly from the RS server without going from Share point site.

 

 

http://Has1de01/<report name>

 

 

Configuration Topology

 

Moss 2007 Application Server

WFE server 1 (MOSS 2007)

WFE server 1 (MOSS 2007)

Reporting Server 2008 R2 with RS add ins 2008 ( Just upgraded only this server, RS add-ins not upgraded)

 

Problem/Questions

 

Report is not working after upgrade, old reports nor new reports, why?

Report is working directly from RS server without going to Share point, so do i need to upgrade the RS add-ins OR am i missing something?

Can Share Point MOSS 2007 work with SQL server 2008 R2 OR do we need Share Point 2010?

 

 

If you need more information about Topology, please let me know . Please help me out. I also need to upgrade my Production server too.

 

 

RS log

 

 

 Library!ReportServer_0-6!84c!05/26/2010-10:19:30:: Call to GetSystemPropertiesAction().
library!ReportServer_0-6!84c!05/26/2010-10:19:30:: Call to GetPermissionsAction(http://server.com/reporting/DataSources/TestReport.rdl).
library!ReportServer_0-6!84c!05/26/2010-10:19:32:: Call to GetItemTypeAction(http://server.com/reporting/DataSources/TestReport.rdl).
library!ReportServer_0-6!84c!05/26/2010-10:19:32:: i INFO: RenderForNewSession('http://server.com/reporting/DataSources/TestReport.rdl')
webserver!ReportServer_0-6!84c!05/26/2010-10:19:35:: i INFO: Processed report. Report='http://server.com/reporting/DataSources/TestReport.rdl', Stream=''

Looks like Srtream is empty

Regards,

 

 

Mit

 

6 Answers Found

 

Answer 1

Hi Mit,

The RS Sharepoint add-in contains a version of the Report Viewer control. In order for the viewing in Sharepoint to work correctly, you will need to install the most recent add-in.

 

Answer 2

Brad,

Thanks for quick reply.

I found following RS-add ins from MS but that's a CTP version, Is it MS released the new version for production server?

SQL Server® 2008 R2 November CTP Reporting Services Add-in for Microsoft SharePoint® Technologies 2010

http://www.microsoft.com/downloads/details.aspx?FamilyID=16bb10f9-3acc-4551-bacc-bdd266da1d45&displaylang=en

Regards,

Mit

 
 

Answer 4

Hi Mit,

Just add to Brad's response, SQL Server Reporting Services 2008 is supported to integrate with SharePoint 2007.

Please see the Prash Shirolkar's blog for more information about this:
http://blogs.msdn.com/b/prash/archive/2010/05/05/integrating-ssrs-2008-r2-rtm-with-sharepoint-2007.aspx

Thanks,
Jin Chen

 

Answer 5

I am getting the same kind of error on two reports only but we are not using RS in Sharepoint Integrated mode. Any ideas?
 

Answer 6

Hi,I have thesameproblem and I think it isany componentof office,any of youfoundthe solution?
 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter