Home » .Net FrameworkRSS

TF255329 Error: Connecting TFS 2010 to SP 2010 Failure

Hey, folks.

We are trying to finalize the installation of TFS 2010. The last piece is to connect TFS 2010 to SharePoint 2010. We were able to successfully connect SharePoint to TFS but we simply cannot connect TFS to SharePoint. It gives us the TF255329 error when connecting to the SP admin site. The main site is successful (we think) because the error only shows a problem connecting to the SharePoint Admin site.

QUESTION: What exactly is the TFS Administration tool doing when we try to connect to SharePoint? Is it using a different port? How is it verifying the admin site? We get the error message when we click the "Verify" button or the "OK" button. What code is running behind the dailog box?

Important points:

TFS 2010 and SharePoint are new clean installs. The TFS extensions are installed on our SharePoint 2010 Server A dedicated site has been created in a Site Collection for TFS VS 2010 successfully connected from remote machine on port 8080 to TFS 2010. Team Project created and checked in to Default Collection.

Any help will be greatly appreciated.

Thank you!

Davin Mickelson

 

4 Answers Found

 

Answer 1

UPDATE:

Well - after working with Microsoft Support for a few hours, it was determined that we needed to add the TFSSETUP and TFSSERVICE accounts (one of the accounts enabled the process) to the SharePoint 2010 Site Collection Administrators group in SharePoint. They were members of the "Farm Administrators" group - but that is not good enough!

The only account that we had set up in this group was the admin account used to install SharePoint 2010.

This was a terrible error  message (TF255329) for the actual solution. I hope this tip helps others out with connecting  TFS to SharePoint 2010. Best wishes and best of luck to all.

PROBLEM SOLVED.

 

Answer 2

Hi Davin,

Thank you for your kindly sharing here!

I'm so glad to hear that your issue is solved for a few hours.

Have a nice day!

Best regards,
Yichun Chen
MSDN Subscriber Support in Forum
If you have any feedback on our support, please contact msdnmg@microsoft.com
 

Answer 3

Hi Guys,

 

I'm suffering from the same issue. However, I'm using WSS 3.0 SP2 instead.

Seems like configurations are slightly different in WSS and MOSS, but tried to add service accounts to sharepoint administrators group but it does not solve the problem.

What is the procedure to find what is the real cause? Is there a way to analyse some log files? 

Any ideas?

 

Thank you very much!

Ruben

 

 

Answer 4

Hi all,

I get the same error and have almost the same issue.

I have clean installs of both TFS 2010 and SharePoint 2010. I can connect to TFS from a remote VS. I installed the TFS extensions on the SharePoint server and successfully connected it to the TFS server. I also made sure the TFSSERVICE account is both farm admin and site collection admin. Also, I can open both the sharepoint web application and the central admin from my TFS server using IE with no problem.

But when I try to add the Sharepoint Web Application from the TFS admin console, I get the TF255329 error message. In my case, it refers to the web application, not the central admin.

I think I did everything right, but apparently I haven't. There's not much information around on this error message, so any help reagrding this is very much appreciated.

Thanks in advance!

Jeroen Swart

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter