Home » Silverlight

Unable to find a volume...

trying to install Silverlight 2.0 I get this message:

"Unable to find a volume for file extraction. Please verify that you heve the proper permissions."

I am the only user on this pc and have admin permissions.

Somebody has a solution?


2 Answers Found


Answer 1

Hi Jboelaert,

Please redownload its install file and right click on the exe file choose "Run as Administrator".  If it doesn't work, please follow smcwhorter's reply on this thread.  It is for Blend but similar with Silverlight.  We need to copy all its exacted files.

Best regards,



Answer 2

Extracted files? What extracted files? The error message clearly states that it could not find a volume to extract to. 



trying to install Silverlight 2.0 I get this message:

"Unable to find a volume for file extraction. Please verify that you heve the proper permissions."

I am the only user on this pc and have admin permissions.

Somebody has a solution?


Hello there,

When i try to login to https://www.microsoft.com/licensing/servicecenter/home.aspx?, I am getting the following error message. I have tried reaching the respective team via email but left with no solution. So I am posting here hope someone can help me with this. As I am stuck to go further.

I have tried all - clearing cookies, tried in different computer, static IP and dynamic IP but no luck. So I am really looking for a solution here.

We apologize for the inconvenience, but we are unable to retrieve your licensing information because there are over 2000 agreements associated with this business e-mail. A customer support representative has been notified and will contact you to assist you with retrieving your licensing information.



Beside providing an interface to my players (not all MediaElements) I would like a PC master volume. because while my player may be set to 100% my PC may still be at 50%.

Can Silverlight access the main volume? read it and set?

If it has not been exposed.  Why not? would it cause a security concern?  (AYAK, Webcam/Mic have been exposed).

Do you know if this is planned for SL5?

Thanks for any insights.


Hi there everybody,

today it's a quick question. I have to build (quite fast) a Volume Control Application and have problems with some of the Volume Properties thing.


I have the following:

A highly complex Visual appearance (too much to describe) 2 Buttons (Two of many)

My application should do the following at one stage:



1) Check if the Volume is muted or unmuted.

2) If the Volume is muted, mute it.

3) If the Volume is unmuted, set the volume percentage to 100%


1) Set the master volume to 0%.

2) Check if the volume is muted or unmuted.

3) If volume is unmuted, mute it.


These two options are only two of hundreds more. I do not have any 'Volume' related source code yet and Google only gives 1/5 of the information or the found code is in C++/C#. I do not have the time to convert those now.


A big thank you for all the (speedy) answers in advance.




I wrote a function and a sub procedure to iterate through selected mail items and determine if a dollar amount exists.  I use the WordEditor and the Find method to identify the dollar amount because Word supports regular expressions, which allows me to find "$30.00" in the body of the mail items.  Note that the mail items are HTML-based.

The Find method returns inconsistent results when executed on the same selected mail items.  Sometimes, the Found property returns True and sometimes it returns False.  In other words, running the code after a failure then succeeds.  This odd behavior leads me to believe that the some background operation (e.g., formatting, repagination, etc.) is running asynchronously, perhaps, and that the Find method isn't waiting for that operation to complete.

What can I do to ensure the Find method is guaranteed to locate the text?  Thanks in advance.

Here is the code:

Private Function GetCheckAmount(ByVal MailItem As Outlook.MailItem, ByRef CheckAmount As Integer) As Integer

' Purpose.......: Returns the check amount contained within a mail item

' Return Values.: 0 (success) or 1 (failure)

' Notes.........: If function fails, make sure the calling method reviews the Err object

'                 for information about error.

'                 If function succeeds, parameter CheckAmount contains the dollar value of check


On Error GoTo GetCheckAmountErrorHandler


   Dim objMailDocument As Word.Document

   Dim objRange As Word.Range


   Dim lngErrorNumber As Long

   Dim strErrorDescription As String

   Dim strErrorSource As String


   strErrorSource = "GetCheckAmount"


   Set objMailDocument = MailItem.GetInspector.WordEditor

   Set objRange = objMailDocument.Range

   With objRange

      With .Find


         .Forward = True

         .Text = "$^#^#.^#^#"


         If .Found Then

            CheckAmount = objRange.Text

            GetCheckAmount = 0


            lngErrorNumber = vbObjectError + 150

            strErrorDescription = "Unable to find the check amount."

            strErrorSource = strErrorSource & ".1"


            With Err

               .Number = lngErrorNumber

               .Description = strErrorDescription

               .Source = strErrorSource

            End With


            GoTo GetCheckAmountErrorHandler

         End If

      End With

   End With


   Exit Function




   GetCheckAmount = 1


End Function   ' GetCheckAmount


Private Sub TestCheckAmount()

   Dim intSelectionItemIndex As Integer

   Dim intReturnValue As Integer

   Dim intCheckAmount As Integer


   For intSelectionItemIndex = 1 To ActiveExplorer.Selection.Count

      Select Case TypeName(ActiveExplorer.Selection.Item(intSelectionItemIndex))

         Case "MailItem"

            intReturnValue = GetCheckAmount(MailItem:=ActiveExplorer.Selection.Item(intSelectionItemIndex), CheckAmount:=intCheckAmount)

            If (intReturnValue = 0) Then

               If (intCheckAmount = 30) Then

                  Debug.Print "Check amount of $30 found"


                  Debug.Print "Check amount of $30 was not found"

               End If


               Debug.Print "Something went wrong. (Error: " & Err.Description & " (" & CStr(Err.Number) & ")"

            End If

      End Select

   Next intSelectionItemIndex

End Sub



My solution consisted of two projects:MyFirstProject (set as startup) and MySecondProjrct. It worked fine on emulator. Than I added MyCabProject as described here:


After I built MyCabProject I got a couple of dozens warnings like this:

Unable to find dependency 'mscorlib'  of assembly 'OpenNETCF.Drawing.dll'  

Where in left side of this statement  'mscorlib', 'System.Windows.Forms', 'System.Drawing', 'System.Data', 'Microsoft.WindowsCE.Forms', 'System.Xml',  'System' are present and in the right side 'OpenNETCF.Drawing.dll', 'OpenNETCF.Windows.Forms.dll', 'OpenNETCF.dll', 'OpenNETCF.Configuration.dll', 'MySecondProject.dll' are present.

And to more warnings:

Two or more objects have the same target location ('%InstallDir%\MyFirstProject.exe')

Two or more objects have the same target location ('%InstallDir%\MySecondProject.dll')

I also found MyFirstProject.exe and MySecondProject.dll in Application Folder.

I have no idea why I encountered this problem. I thought that if solution works there are no reasons for it to have troubles with deployment. It seems that I was wrong.

I removed MyFirstProject.exe and MySecondProject.dll from Application Folder. After next build I had no warnings.

But when I run app on SmartDevice I got an exception.

I should also note that MyFirstProject.exe, MySecondProject.dll, 'OpenNETCF.Drawing.dll', 'OpenNETCF.Windows.Forms.dll', 'OpenNETCF.dll', 'OpenNETCF.Configuration.dll' are present in Application Folder on SmartDevice.

How can I deploy my app?




I migrated a solution from VS2005 to VS2010.  Everything works but I get warnings for three Interops.  A typical warning is:

Warning1 Unable to find dependency 'INTEROP.NOVAS' (Signature='(null)' Version='') of assembly 

I even tried copying the corresponding interop files from the working VS2005 solution to the VS2010 project without success.  I've tried removing and adding the appropriate dll's to the reference tab without success.

Can anyone give me any ideas on where to begin to resolve this?



Hi, I am trying to gain access to a local Access database.   I tried using "Add a new datasource" which activates the Data Source configuration Wizard.  I select New connection,

Select Microsoft Access Database File (.Net Framework Data Provider for OLE DB)

Hit Continue

Browse to my MDB file.

When I select "Test Connection"  I get a Test connection succeeded message

When I OK out of the Add Connection Box

 I get then following message:

Unable to find the requested .Net Framework Data Provider.  It may not be installed.

My question is.. what is it, where is it and how do I get it?



I tried googling this issue and many people seem to have this problem with .Net framework 1.1/2.0 side by side configurations, and there are no real solutions I've come across.

I've developed a console application in my Windows 7 x64 Professional machine with VS 2010 (C# express) (I have just run another windows update and it reports I am fully up to date). I've tried compiling the program targetting .Net Framework versions 4.0 Client Profile, 4.0, and 2.0.

Each time I've compiled it the program works fine on the development machine. However if I move the application to my Windows XP x64 Professional machine (no VS 2010) I get the "Unable to find a version of the runtime to run this application". I've tried putting the config file beside the file in all instances, and this problem never disappears.





Edit: forgot to mention that I did check, and the Window XP machine is also FULLY up to date as of the time of writing this.


I recently installed the RTM VS2010 and Pex and Moles .91. When running tests attributed with [HostType("Moles")], I get the following error:

"The host type 'Moles' cannot be loaded for the following reason: The key 'Moles' cannot be found."

In ProcMon, I can see that it is looking for:


which is not there.

However, I do have:


Not sure what the cause is, but I thought someone else might run into it, and it may be worth looking into.



We have a VB .Net application that is targeted to the .Net Framework version 2, over the past couple of days users have been reporting that they are getting the following error message when running the program:

'Unable to find a version of the runtime to run this application'

After some investigation it transpired that Windows Update had installed version 4 of the .Net Framework (Client Profile) on their PC's and this had resulted in the error message above.

The only way we have been able to get around this problem is to create an app.config file that contains the following text:

<?xml version="1.0"?> 
    <supportedRuntime version="v2.0.50727">

Why do we need to create/issue the app.config file when we have specified the target framework in the Project options within Visual Studio?

This is obviously a major problem as we now need to issue app.config files to our users to prevent them from getting the above error.

As an aside I installed .Net 4.0 on an XP system and that did not display the error, our tests and users have only encountered the problem on Windows 7 (although it could affect Vista).



I have earlier successfully configured the ESB Toolkit. But, I had the ESB.Portal problem and so I thought that if I re-configure, I might rectify the situation. I unconfigured the ESB from the ESBConfigurationTool.exe and then I tried to re-configure. Under "Exception Management", I configured the Database part by checking the option "Use Existing Database" and it went smooth. However, In "Exception Web Services", it keeps on throwing the error that "<my machine>\BizTalk Isolated Host Users" doesn't exist". Has anybody tackled this problem earlier?

Praveen Behara
MCST : BizTalk Server 2006 R2


I would like to connect my wmv file to a WMVideo Decoder DMO like in graphedit in C++ code. However, I am unable to find the pins to connect to. Below are some of the code I have tried but when I try to GetPin, it always jumps out of the while loop " while(pEnum->Next(1, &pPin, 0) == S_OK) ". 


IBaseFilter *pWMVideoDecoderDMO;

  hr = CoCreateInstance(CLSID_DMOWrapperFilter, NULL,

    CLSCTX_INPROC, IID_IBaseFilter, (void **)&pWMVideoDecoderDMO);


if (SUCCEEDED(hr)) 


    IDMOWrapperFilter *pWrap;

    hr = pWMVideoDecoderDMO->QueryInterface(IID_IDMOWrapperFilter, (void **)&pWrap);


    if (SUCCEEDED(hr)) {     // Initialize the filter.

        hr = pWrap->Init(CLSID_WMVideoDecoderDMO, DMOCATEGORY_VIDEO_DECODER);




    if (SUCCEEDED(hr)) {     // Add the filter to the graph.

        hr = pGraph->AddFilter(pWMVideoDecoderDMO, L"WMVideo Decoder DMO");


   // pWMVideoDecoderDMO->Release();



I have tried the below code as well but I face the same problem. No pins found. 

 CComPtr<IBaseFilter> pWMVideoDecoderDMO;

    hr = pWMVideoDecoderDMO.CoCreateInstance(CLSID_WMVideoDecoderDMO);

    CHECK_HR(hr, "Can't create WMVideo Decoder DMO");

    hr = pGraph->AddFilter(pWMVideoDecoderDMO, L"WMVideo Decoder DMO");

    CHECK_HR(hr, "Can't add WMVideo Decoder DMO to graph");


I am using the below code to connect the pins..

//connect MediaLooks Smart Tee and WMVideo Decoder DMO

    hr = pGraph->ConnectDirect(GetPin(pMediaLooksSmartTee2, L"Preview"), GetPin(pWMVideoDecoderDMO, L"in0"), NULL);

    CHECK_HR(hr, "Can't connect MediaLooks Smart Tee and WMVideo Decoder DMO");


And my GetPin code is as below: 

CComPtr<IPin> GetPin(IBaseFilter *pFilter, LPCOLESTR pinname)


    CComPtr<IEnumPins>  pEnum;

    CComPtr<IPin>       pPin;


    HRESULT hr = pFilter->EnumPins(&pEnum);

    if (hrcheck(hr, "Can't enumerate pins."))

        return NULL;


    while(pEnum->Next(1, &pPin, 0) == S_OK)


        PIN_INFO pinfo;


        BOOL found = !wcsicmp(pinname, pinfo.achName);

        if (pinfo.pFilter) pinfo.pFilter->Release();

        if (found)

            return pPin;



    printf("Pin not found!\n");

    return NULL;  


The GetPin code works for other filters but just not the WMVideo Decoder DMO filter. 

Please help. 

Thank you 

Best regards,





Is anyone having problems accessing the virtual labs on this site?  I'm going through the Introduction to Visual C# Language step (step #2 in the aspiring developer track) and am trying to open the Virutal Lab called "Introduction to Visual C# Language" but keep getting redirected to a Windows Live Search page saying the page I requested cannot be found. 

I think it worked at first because I was originally taken to a registration page to register for the virtual labs, but once I registered, I started getting this error when trying to access the labs. 

I've also tried accessing the labs directly through Microsoft Learning (rather than through the MSDN Ramp Up site) and still have the same issue.

Any ideas?

Thanks -

After installing Gemini, I ran Excel 2010 and get this error message:

Name: Microsoft.AnalysisServices.Modeler.FieldList - Microsoft.AnalysisServices.Modeler.FieldList
From: file:///C:/Program Files/Microsoft Analysis Services/AS Excel Client/10/Microsoft.AnalysisServices.Modeler.FieldList.vsto

************** Exception Text **************
System.EntryPointNotFoundException: Unable to find an entry point named 'MsoFRequireSignedAddins' in DLL 'mso.dll'.
at Microsoft.VisualStudio.Tools.Office.Runtime.NativeMethods.MsoFRequireSignedAddinsamd64()
at Microsoft.VisualStudio.Tools.Office.Runtime.NativeMethods.MsoFRequireSignedAddins()
at Microsoft.VisualStudio.Tools.Office.Runtime.OfficeAddInDeploymentManager.VerifyAddInTrust(ClickOnceAddInTrustEvidence evidence)
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.VerifySecurity(ActivationContext context, Uri manifest, AddInInstallationStatus installState)
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()

I try to add ''C:\Program Files\Microsoft Analysis Services\AS Excel Client" to the trusted location (subfolders included) . But nothing change.

If I try to execute the vsto, I get this error message:
System.Deployment.Application.DeploymentDownloadException: Downloading file:///C:/Program Files/Microsoft Analysis Services/AS Excel Client/10/makefile.inc did not succeed. ---> System.Net.WebException: Could not find file 'C:\Program Files\Microsoft Analysis Services\AS Excel Client\10\makefile.inc'. ---> System.Net.WebException: Could not find file 'C:\Program Files\Microsoft Analysis Services\AS Excel Client\10\makefile.inc'.

Hi Team,

I have installed VS2010 Professional edition and I couldnot find the Microsoft Test Manager.

I want to connect to MTM.What should I do.? Is it possible to install only MTM ? If yes,Can you please provide the steps.




I am working with client who has a MOSS 2007 install. Everything has been working well for some time. However, there is one particular user who keeps getting access denied when viewing the history or incoming links pages for a wiki page.

Here is some permissions structure (which is normal for other users in a similar role):

Site Permissions - Limited Access List Permissions - Limited Access Item Permissions - Design

All users in the clients domain are members of a domain group which has the following permissions

Site Permissions - Limited Access List Permissions - Contribute Item Permissions - Read Thanks in advance for any help with troubleshooting this issue.

I am unable to understand the error that I'm getting

Error:Unable to find manifest signing certificate in the certificate store. 

Plz help me out...

Thanks in advance:)


Greetings fellow builders!


I have pieced together a mega-solution consisting of 56 projects – 54 C# and 2 C++ with a ton of interdependencies. 


I have stripped out ALL file references to our own assemblies and replaced them with the appropriate project references, including one C++ project that has 2 C# references.


The solution builds perfectly from Visual Studio 2010, as well as directly with an msbuild call.


Team Build however is failing to compile the C++ project with the 2 C# references with errors akin to this one:


BackendCopy.cpp (6): could not find assembly 'DataTypes.dll': please specify the assembly search path using /AI or by setting the LIBPATH environment variable


The lines that these errors link to are #using statements that reference our C# assemblies. 


I’ve confirmed that the DataTypes.dll (one of our C# assemblies) is correctly being compiled prior to this C++ project and is output to the Binaries directory (on dev machines this is built to ..\..\..\netbin).

The .cpp and .h files going after these assemblies are using correct #using clauses;  ..\..\..\netbin was a listed value for the “Resolve #using references” setting.


If it matters, my Additional Library Directories settings is: $(OutDir);%(AdditionalLibraryDirectories).


I’d first tried adding the relative path to the Binaries directory as it’s appearing on the build server (..\..\..\..\..\Binaries)  to LIBPATH but got the same errors.

I then added this relative path to the AI setting (Resolve #using references under General C/C++ properties), and this finally allowed it to build.

This doesn’t seem to be the cleanest solution though, as this relative path could change once we begin branching.


Does anyone have any advice as to how to better steer Team Build to C# references?







Hi All,

I am trying to connect to an iSeries database using .NET. The server I am trying to connect from is a 64 bit Windows Server 2008 machine. I have iSeries Access v5r4 installed and a DSN entry(64 bit ODBC) created with the iSeries Access ODBC Driver. In my C# class, the connection and data retrieval works fine if I use OdbcConnection and OdbcCommand. But if I try and use IBM.Data.DB2.iSeries.iDB2Connection then I get the error - Unable to find an entry point named '#507' in DLL 'CWBDC.dll' error. I have referenced IBM.Data.DB2.iSeries.dll in my project. Anyone run into this issue before? I found a couple more people who asked this question when I did a google search but there were no answers listed. Any help would be appreciated.



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure