Home » .Net Framework

wic 32

when i m

Blocking Issues:

You must install the 32-bit Windows Imaging Component (WIC) before you run Setup. Please visit the <A HREF="http://go.microsoft.com/fwlink/?LinkId=162643&clcid=0x409">Microsoft Download Center</A> to install WIC, and then rerun Setup.



atrying to install .net this dialogue appears please help me.

3 Answers Found


Answer 1


Could you please offer more detailed information about your scenario so the community members could help you better and quicker?

Thanks for your understanding.

Please remember to mark the replies as answers if they help and unmark them if they provide no help

Answer 2


Could you please offer more detailed information about your scenario so the community members could help you better and quicker?

Thanks for your understanding.

Please remember to mark the replies as answers if they help and unmark them if they provide no help


Answer 3


Could you please offer more detailed information about your scenario so the community members could help you better and quicker?

Thanks for your understanding.

Please remember to mark the replies as answers if they help and unmark them if they provide no help

Search for  wic 32


I've seen many post close to this question but none that actually address the problem I'm having.

I have an IE extension which works perfectly well with several version of IE on several different OS versions.  That is, the 32bit version of the extension works with the 32bit version IE7 and IE8 on the 32bit version of the Windows - (XP, Vista, and 7).  The 64bit version of the extension works with the 64bit version of IE8 on Windows-7 (haven't tested on Vista... but figure it would work the same).

But I have a specific issue with the extension to the 32 bit version of Internet Explorer running under Windows-7 64 bit OS.

If I understand how Wow64 works on the 64 bit OS:

My 32bit extension would go in a folder: \program files (x86)\<Name>

I would then create the following registry entires:

HKLM\Software\Classes\Wow6432Node\CLSID\{My32bitGUID} with subkeys (1) InprocServer32 pointing to my DLL in \progarm files (x86)\<Name> with string ThreadingModel="Apartment" and (2) Implemented Categories with subkey {00021493-0000-0000-C000-000000000046} (for a vertical extension bar)

HKLM\Software\Wow6432Node\Microsoft\Internet Explorer\Extensions\{My32bitButtonGUID} with strings: BandCLSID={My32bitGUID}, CLSID={E0DD6CAB-2D10-11D2-8F1A-0000F87ABD16}, ButtonText, Default Visible, and Icon

Other than the Wow6432Node in the registry keys this is basically the same (but with different GUIDs) as what I use for the 64bit extension in the 64bit Internet Explorer.

When I do this, the custom tool button appears in the 32bit IE8 window as normal - but when I click the button IE8 does not access my extension in anyway that I can tell.  No window is created and as best I can tell none of the window creation routines are called.

It seems I'm missing something trival and simple... but I can't seem to find any reference that points me in the right direction.  I've read everything I could find in the extensions guides.

Any help/input appreciated.





I'm currently using WIC (indirectly via WPF's BitmapSource-derived classes) and recently saw this quote somewhere:


"Expression Design doesn't support color management, but WPF and WIC do, so it's possible to build color-managed imaging software with these components"


Could someone say a few words on how one goes about creating a "color-managed" application via WPF/WIC? Thanks in advance.



Is there a registry key you can check to see if the WIC is installed on the system. The .Net Framework 4.0 doesn't seem to automatically install it for you, which is a problem because my program uses 4.0. So it launches the .net installer if they don't have it but then it just fails and my customers are not going to understand why I can already see the log of calls from people saying the installer doesn't work. After searching around I can't seem to find a registry key for it. I'm going to check on start up if it exists if I can find the key.

I'm new to Image processing, so if this is the wrong place I would appreciate directions to the right place (better place).

Thinking of building an application to read/modify the metadata contained in Win7/ *.wmv files.  Since I have a large number of these I want to build a data driven app that takes data from a current data base and puts it into the *.wmv files (all the tags (or ones that can be modified, seen when one clicks on the file/properties/detail page in win 7).  To date I have built a similar application to do the same with *.jpeg files but there I used the System.Image library (vs 2008), and don't see a similar set of functions for the *.wmv files.


Thanks to anyone who can point me in the right direction, and/or tell me this is  a "lost cause".


Ed Warren.

I am writing a WIC Image decoder for a special image format. The format includes XMP data with people tagging information. I can view the images including all metadata in WICExplorer. The people names are also shown in Explorer (using my implementation of IPropertyStore / Property "System.Photo.PeopleNames" = {E8309B6E-084C-49B4-B1FC-90A80331B638} / 100). 

In Windows Live Photo Gallery (Windows 7 x64) the Thumbnail of my images are shown (using my implementation of IThumbnailProvider). I can also open the images by doubleclick to view them.

To get the metadata WLPG calls the IPropertyStore interface for the "normal" properties. These are shown as expected.

WLPG also creates my IWICBitmapDecoder implementation. 
The first call is to QueryCapability wich returns WICBitmapDecoderCapabilityCanDecodeAllImages|WICBitmapDecoderCapabilityCanEnumerateMetadata.
Then the decoder is initalized and WLPG calls GetContainerFormat wich returns my own format id.
And then nothing else happens. There ist no QueryInterface for IWICMetadataBlockReader or a call to GetMetadataQueryReader. How does WLPG access the WIC metadata?

When returning a well known container format (e.g. TIFF = {163BCC30-E2E9-4F0B-961D-A3E9FDB788A3}) then WLPG calls GetFrame(0) / GetMetadataQueryReader as expected. The IWICMetadataQueryReader is then call with "/ifd/xmp/..." or "/xmp/..." depending on the container format id.

Therefore I think I have to register an association of my container format with a query key (like "ifd" for TIFF) - but I can't find anything like this in the documentation and as TIFF and JPEG are well known container formats I can't find any registry entries for these formats.


WIC ships with Windows 7/Server 2008 R2, Windows Vista/Server 2008, and Windows XP SP3.

Windows XP SP2 and Windows Server 2003 can obtain WIC at the Microsoft download center:

Windows 7/Server 2008 R2 shipped with improvements to WIC; see this post for more information: http://social.msdn.microsoft.com/Forums/en-US/windowswic/thread/7ba7a1eb-56a0-414c-b24f-2de2d56b0913

The improvements described above are available to Windows Vista/Server 2008 as part of a Platform Update: http://support.microsoft.com/kb/971644


A good high-level introduction to WIC and how to use it can be found on the DirectX blog:

More information about WIC development can be found using the following links:
WIC MSDN documentation: http://msdn.microsoft.com/en-us/library/ee719902(v=VS.85).aspx
Photo Metadata Policy: http://msdn.microsoft.com/en-us/library/bb643802.aspx
Metadata Query Language overview: http://msdn.microsoft.com/en-us/library/ee719796(v=VS.85).aspx
Writing a WIC codec or component: http://msdn.microsoft.com/en-us/library/ee719869(v=VS.85).aspx

Additional WIC tools (WICGrinder, WICExplorer, AIT sample codec) are available here. Note that you must select “WIC Tools v1” from “All Releases” to download the AIT codec:

These blogs provide additional information about WIC development and digital imaging at Microsoft:
Robert Wlodarczyk’s blog: http://blogs.msdn.com/rwlodarc/
Bill Crow's HD Photo Blog: http://blogs.msdn.com/billcrow/
Photo Blog: http://blogs.msdn.com/pix/
Pro Photo Blog: http://blogs.msdn.com/prophoto/



I'm trying to implement a WIC codec for a university project using Visual Studio 2010 and targeting Windows 7, 64 bit. I've read through the documentation and tried building the AitCodec, but end up with WINCODEC_ERR_COMPONENTINITIALIZEFAILURE when testing it using either the new version of WIC explorer or WicCop. I've tried what I thick is obvious, i.e. that it is registered properly (at least I think so), signed (using SignTool and a local certificate) and compiled as 64 bit, but am sure I'm doing something wrong. The most obvious thing I can think of is that the COM threading model is wrong, as currently it is "apartment" and I believe it must be "both" under Windows 7.

Has anyone else dealt with such problems? Basically I'm looking to extend a sample to support a very simple custom format.

What I'm also wondering is, is there a newer version of the AitCodec sample or another sample that compiles for Windows 7, 64bit?

Thanks :)



I have images from a scientific CCD.  They are 12 bit Tiffs.  WIC recognizes them as TIFF files, but displays them simply as black.

I believe that the 12 bit data is encoded in a 16 bit Tiff format, but evidently not in a way the WIC is able to recognize (perhaps written in the high 12 bits of the 16 bit format or the low 12 bit of the 16 format?)

Is there a way to tell WIC to:

a)treat these TIFFs a different way?

b)set WIC to automatically rescale these TIFFs (to 8 bit perhaps)

Any suggestions?


An Attempt to gather our experiences in migrating pre-dino era VC++ /c++ code on to VS2010.

We try to will find time to write on specific error and remidiations


However Socket based,CGI,Perl codes on client servers may follow this pattern of remidiation

Issues Usually raise with Lib,h and Socket calls



comment(lib, "ws2_32.lib")


Check for Character set and Subsystem, And if its relevant for your project use the following

Go to - Project Menu,<proj> Property Pages, Linker, System,Subsystem - > change to Windows (/SUBSYSTEM:WINDOWS)
Go to -Project Menu,<proj>  Property Pages, Configuration Properties ->General ->Character Set - Multi-Byte Character Set


Sample error list

ws2def.h ( ): error C2011

MSVCRTD.lib(crtexe.obj) : error LNK2019





Hi all

It is basic installation question Please help regading

Is it possible Installing "MSSQL 2005 32 bit  or SQL Server 2008  32 bit on windows 2003 server 64 bit ?

If it is possible share some links .



I am planning to install 32-bit VS 2010 Professional on Windows 7 Professional on a 64-bit machine with 12 GB of memory.  Will this be able to use memory beyond 4GB or will I need a 64-bit version?  This was the only version available thru the MS WebSiteSpark program.



Steve Shier



We are devloping a server application in .Net the production environment is 64 bit. the developers are working in the 32 bit Os versions .

My question is if we compile the solution by targeting any CPU will it be able to access more memory provided by 64 bit environment when it is deployed in a 64 bit environment? since 32 bit os has 4 GB memory limitation for processes , and  even in 64 bit environment the code might be running in a 32 bit simulated envirnment right? or we need to build the code specifically targeting 64 bit environment  so that the process has aceess to more memory , we need a lot of RAM

Cheers ,



I'm working on a WPF application that requires displaying 32 bit RGB images as well as 16 bit grayscale TIFF images. To determine whether the input image is 32 bit or 16 bit, I wrote the following code :

BitmapImage Image = new BitmapImage(new Uri(ImageFile));

string Resolution = Image.Format.BitsPerPixel.ToString();


However, I observed that I get the output as "32" even for a 16 bit grayscale .TIFF image. Is this a bug in WPF or am I doing something wrong ? PLEASE HELP !!!



We have an application containing several unmanaged DLLs that has been built in a 32-bit environment. I recently added a .NET remoting module (packaged in a DLL which I cleverly called Remote.dll) to allow our customers to develop applications that can connect to and control our application. As part of our delivery, I created a sample C# .NET application. All of this works fine on 32-bit machines.

Our main application works just fine on Vista 64 and Windows 7. However, I tried to get my sample .NET remoting application to work on Vista 64 and it crashes. So I transferred my sample application code to the 64-bit machine and built it. When running in the debugger, I get

"An unhandled exception of type 'System.BadImageFormatException' occurred in MySampleApp.exe"

"Additional information: Could not load file or assembly 'Remote, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format"

I had been building the sample application with the Platform Target as Any CPU. If I change this to x86, I get the following error when I try to run:

"An unhandled exception of type 'System.IO.FileNotFoundException' occurred in MySampleApp.exe"

"Additional information: The specified module could not be found. (Exception from HRESULT:0x8007007E)"

I have tried moving the main application to the 64-bit machine and building. The main application runs fine, but the sample application still crashes.

I even changed the output location of my sample application to be in the folder where the main application resides, just in case there was a dependency on the main application that I wasn't aware of. Still no go.

Also, in the development environment (VS2008), after adding a reference to my .NET remoting DLL, I can browse it just fine. So this doesn't seem to me to be a build-time problem.

But what do I know? I'm the one who can't get the stupid thing to work!

Thanks for any help!




Hi All,

 I'm trying to call a .bat files through MSBuild in the build script file that i'm using in Cruise Control. this is run on Windows Server 2008 (32bit) platform. When i run the bat file manually on command prompt or just double click it, it works. But when its run through MSBuild on cruise control it doesn't work. It just returns with different exit codes. eg (errorMSB3073: The command "run-reports.bat" exited with code 9009)

I noticed that the bat file actually fails on lines such as del /F logs\test.log etc. I have disabled UAC on the machine also, since i'm assuming this has something to do with permission on the server 2008.  i checked this link http://www.binarywar.com/2009/11/problems-running-batch-files-in-windows-server-2008/, but the advices there on running the shortcut didnt work :(

please let me know if you know a solution for this.





hi every one

help me i have windows7 ultimate 32 bit

i downloaded netframework 4 , but when i try to install it failed with this error:

Installation failed with error code: (0x00000424), "The specified service does not exist as an installed service.

i am not getting the problem please help me to installing .netframework 4.





  We have .net dlls which supports 32 bit version. The same dll need to run under 64 bit
environment(windows server 2008 Server). I tried with corslagflag.exe which didnt work. Any
thoughts will be really a great favour. This is critical for me.  Thanks in advance, you can
mail me the solution at  ydineshbabu2000@yahoo.com

I am trying to access few files from C:\Windows\System32\Winevt on Windows 7 - 64 bit machine through .net application.

When I build my application in 32 bit , I am not able to access this Winevt directory. It complians about directory not found.
But If I build my application in 64 bit mode, I am able to access this directory without any problem.

Do I have to do anything special to access this directory using 32 bit application on 64 bit machine?


I have an CSharp application that calls a C++ DLL.  I am able to compile the DLL as 32 or 64 bit and run the application on the respective system.  If the 64 is run on 32 or the 32 is run on 64 of course there is an error.

Currently when I release a new version of my code I set the 3 setup files to 32 bit and attach the 32 bit DLL and compile.  I then set the setup files to 64 bit and attach the 64 bit DLL and compile.  This works again a long as someone does not install the 32 bit on a 64 bit machine which is an increasing problem.

I am looking for a better way...

1) I would like to have the application run and detect 64/32 (this is done via int size it seems) and then change DLL.  This to date has not worked because of the linking.

2) I would like to do batch builds where I build one time and I get a 32 bit version and a 64 bit version in two different directories.  I am not seeing how to set the 64/32 flag from the command line.  Coping the correct DLL in place before the compile would be nice.

Any suggestions?


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure