Home » SQL ServerRSS

Windows CE 6 CAB File for SQL Compact

Hi Guys , I need CAB for a PDA with Windows CE 6 , on Windows CE 5 i use this CAB: NETCFv2.wce5.armv4i.cab sqlce30.dev.ENU.wce5.armv4i.CAB sqlce30.repl.wce5.armv4i.CAB sqlce30.wce5.armv4i.CAB for the sqlce file i have a warning about version compatibility but after install my program its working. I need CAB file for CE 6, anyone knows where i can find it? Thank you, Giuseppe
 

13 Answers Found

 

Answer 1

no one can help me?
 

Answer 2

SQL Server Compact 3.0/3.1 is not supported on Win CE 6. SQL Compact 3.5 SP2 is, however, just use the wce5 files:  http://www.microsoft.com/downloads/en/details.aspx?FamilyID=38ED2670-A70A-43B3-87F3-7AB67B56CBF2
 

Answer 3

Hi ErikEJ,

i have downloaded yet the "Server Compact 3.5 for Devices Windows Installer" but i don't found the cab i expect i need like sql.ce600.xxxx,ecc.

 

So my question now is : I'm expecting something wrong?could you tell me the right way to insert in my program (for ce6) the sdf dll & cab for distribution?

 

Thank's for all,

 

Giuseppe

 

Answer 4

there are now wce600 files for version 3.5, just use the wce500 files.

For example: C:\Program Files (x86)\Microsoft SQL Server Compact Edition\v3.5\Devices\wce500\armv4i\sqlce.wce5.armv4i.CAB

 

Answer 5

Great It's working! but now i have problem with the sdf , the program seems not work properly with the sdf.

I have to change something in the db?

 

 

 

Answer 6

ok the error is on the pda : please upgrading using sqlCeEngine.Upgrade() method.

 

But with this version i'm back-compatible with ce5?

 

Answer 7

YOu must upgrade, 3.5 uses a new file format. (You can also use SSMS 2008 for the Upgrade). Yes, this version supports CE 5 and CE 6.
 

Answer 8

In my program i have to add a different System.Data.SqlServerCE?

Now i'm using VS2005 the file version is 9.0.242.0 from c:\programmi\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies\System.Data.SqlServerCE.dll

 

 

 

 

Answer 9

Yes, you must add a ref to C:\Program Files (x86)\Microsoft SQL Server Compact Edition\v3.5\Devices\System.Data.SqlServerCE.dll
 

Answer 10

so i have different client with sql 2005 and sql 2008, i can use always the 3.5 dll?or for 2005 i have some incompatibility error?

 

 

 

Answer 11

Do you mean for Merge replication? Then yes, but the 3.5 SP2 server tools must be installed on the web server.
 

Answer 12

Hi again Erik,

there is some way to create a sdf file (3.5 version) on a desktop machine with sql 2008 R2 ?

Because my database its with a lot of data and  i need to create it on a desktop machine.

Thk,

Giuseppe

 

 

Answer 13

Yes, you can create it programatically or with SQL Server 2008 Managment Studio or another 3rd party tool: http://erikej.blogspot.com/2009/04/sql-compact-3rd-party-tools.html
 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter