Home » Microsoft Technologies

Work offline/online button is greyed out in outlook 2010

I have several clients in which the button is greyed although "cached mode" is selected in our exchange/client config. Any ideas why? button should be available to the users in order for them to work offline etc.




1 Answer Found


Answer 1

Hello Stefano,

Thanks for posting. This is a forum for programmers. Your question is more an end-user level question, not a developer (programming) question. You're more likely to find people knowledgeable in this area on the Answers site:

Microsoft Office Outlook:

If you have any concern for this post, just feel free to follow up. Thanks for your understanding and have a nice day.

Best regards,
Bessie Zhao - MSFT
MSDN Subscriber Support in Forum
If you have any feedback of our support, please contact msdnmg@microsoft.com.




The Ribbon button is disabled for the List, i am using Sharepoint 2010 Enterprise Edition and all the Services are running as well. Outlook 2010 is also installed in it.

Any help will be appreciated.





I started working with Visual Studio 2010 Ultimate (german). When I first used the help, it asked me wether to use online or offline help content (I dont remember the exact wording). Without thinking I chose "offline", realizing afterwards that I dont have installed any local help content. Now I want to switch back to online. In another thread (click ) the suggested solution was to run the helplibmanager and select online help again. Unfortunately all that my helplibmanager shows is a text box for entering the local help content path. There is no option to switch to online mode. A repair installation of the Help Viewer did not change anything. I'd like to avoid complete reinstallation of VS if possible, especially as I dont know if that would work. Any Ideas?

This is my helplibmanager window: click


I have a list definition that is built upon the standard contact list template in Visual Studio 2010. When I deploy this to sharepoint 2010 everything works except connecting it to outlook. This icon is grayed out. If I create a standard contact list within my sharepoint installation it works perfect.

So what am I doing wrong? Is there any setting I need to set etc to get this to work?



I have installed an outlook client with offline access on a computer and configured my outlook. Everything seems to work fine except that I could not go offline. When I click the "Go Offline" button, it starts to run the checking and stops on the task called "propagating customizations" and the Errors tabs only says "Invalid Argument". There's no further information on what went wrong.

I tried to uninstall and re-install the client but I still see the same error. Does it have anything to do with my data? I couldn't find any solutions online. Does anyone know what might be the problem?


I have a clients laptop that will not work with Outllok 2007 and CRM 4.0 offline.  First when syncing I would get a general error message and telling me to restart outlook or contact my system administrator. Well now with the newest version and latest rollup and it appears to be going offline but the button never changes to go online. Then when I click it again it appears to go back online. However, when I shut down Outlook and restart it offline, it gives me an error that it cannot find the crm server and never starts the CRM addin which clearly is the whole idea behind CRM offline. I've searched everywhere online and it seems that nobody can figure out what the problem is or how to fix it. I was able to install CRM 4.0 offline on my laptop with CRM admin rights. Is it a permission thing??? A quarter million dollars of software and installation and it doesn't work? Is displeased the right word? Any help is greatly appreciated.


Hi Folks,

I have a COM Outlook addin which implements a ribbon button in Outlook 2010. It's been working just fine for quite some time. Until someone tried to load the addin in the Korean version of Outlook. The ribbon buttons show up but do not do anything when clicked.  In the debugger, I see the error message below whenever I click on the ribbon button "ERROR : Unable to load Typelibrary. (HRESULT = 0x8002801d)
 Verify TypelibID and major version specified with
 IDispatchImpl, CStockPropImpl, IProvideClassInfoImpl or IProvideCLassInfo2Impl".

I never hit my break point in the callback for this button, so something is going on in the event layer above my code I think. But I don't know what and I don't know why using the Korean version of Outlook should make any different. Anyone have any ideas?

(Sice this addin has been around awhile, it also has command bars and buttons to do the same thing. These still work (though they're shunted to the addins tab))



One user is on 2 domains.(two different profiles + two Emails. One on an Exchange 2007 server and one on a BPOS "server". Now the two different organizations wants to see his calender.He wants to use only one calender! We tried to use the function "publich Online" but it seems that it doesn't work between two domains whereas one is a BPOS server. Can anyone help me?


I am having a similar issue with CRM 4 for Outlook (CRM Online Add-in) failing with the Add Contacts from Outlook wizard.  It seems that the Outlook Hotmail connector is causing an issue.


I am using Windows 7 and Office 2010 Pro Plus.


Can someone please assist me, as this is a major issue for me using the CRM Online tool.

President, MTS Consulting Group
I tried to install the plugin with Outlook 2010 64 bits. The message came back said it does not work with 64 bits Outlook. Is there a 64 bits Plugin for this?

Having a look at " offline " feature in Google Docs ( which is now under upgrade ), one could sync ( automatically ) between the file online and the one offline whenever any of them was edited. That is, the offline feature could find which file was edited last and replace the old file with the new edited one.

I can't find this feature for office live and I need to replace the old file with the new one which is edited.

Any way I can have both file sync whenever any of them has changed?


Dear "Windows Live Messenger" Programmers:

I'm using Windows Live Messenger 14.0.8089.726
Recently, there is a bug with MSN server or client, that some of my contacts see me online and some see me offline when I'm actually online. If I switch to use Pidgin messenger in Linux/Ubuntu, there is no such problem.

Not just me, a lot of other people are having the same problem as me. Deleting and re-adding contacts may solve the problem according to them.  From the Ubuntu Pidgin messenger, I can see my actually online but apparantly offline friends, "last seen 131 days and 22 hours and XX minutes ago", which is completely ridiculous because he turns on MSN everyday. However, those who are indeed offline or using other messenger don't have such a line of information. I suspect you might have messed up your contact status database because the data information seems to be corrupted.

Please fix the bug as soon as possible! Thanks!

Wang Xuancong
National University of Singapore




I have created 2 groups on Managed Metadata Service. I've created some TermSets.

In a .NET application I can connect to sharepoint admin site using SPSite, but when I ask for TermStores the store.count is allways == 0, but I am sure they really exist.



using (SPSite site = new SPSite(url))
     TaxonomySession session = new TaxonomySession(site);
     TermStore store = session.TermStores["Managed Metadata Service"];



José Cruz


Hello All,

I have one doubt, can we create .exe for silverlight application, i heard that we can work on offline mode(without internet) and online mode(with internet) for silverlight application, i am new to silverlight can any one hepl me out, great appriciation in ADV.

I am using the new version of windows live messenger, and it keeps saying that my status is "offline" even though I am clearly "available".  Even when it is changed to "busy" it still says it is "offline".  Is there a way to fix this?

When trying to install local help content through Help->Manage Help Settings i had this error:
An exception has occured. See event log for details.

I can't install help files for Visual Studio 10 Express Edition from offline becouse the file /ProductDocumentation/HelpContentSetup.msha is not in the dowloaded ISO that i used to install VS.


I have already registered the product.
Product version:
Microsoft Visual Studio 2010
Version 10.0.30319.1 RTMRel
Microsoft .NET Framework
Version 4.0.30319 RTMRel
Installed Version: C# Express
Microsoft Visual C# 2010   01014-169-2560017-70456
Microsoft Visual C# 2010.

How can I fix this problem?

Thank you for your help.


Hiii all,

I want to know that is there any way, that I can set the printer online or offline using coding... I have code that check the printer is online or offline, but I want to do that if the printer is offline than I must set it to online using coding... is there any way then please tell me....



I have to architect a new application in silverlight which needs Online/Offline capability. User should be able to work on a part of funtionality while offline and these changes should be synchronised and updated with the server once the user is online.

2 years back, i read somewhere that silverlight will have a small database attached with it to save local data and synchronise it with server later when online.

Can anybody implemented this kind of funtionality in any of your projects. If yes, please share the components and technologies used to implement this




Hi ,

 I am new to VSTO , I have a problem

I have developed Outlook 2010 addin using Visual Studio 2010 Where in i have  created a Ribbon using Ribbon Visual Designer and i have deployed using msi setup project also

In which i have written some button click events upon which a window form will open

i have come across with a problem

My Addin Installs successfully in Xp Machines having outlook 2010 and also loads ... and ribbon is visible but when i click button no form is being shown... 

In SQL Server 2005, I tried to take a database offline by selecting "take offline."  My computer had a problem during this now I get the following error... ALTER DATABASE failed because a lock could not be placed on database 'CJISData'. Try again later.ALTER DATABASE statement failed. (Microsoft SQL Server, Error: 5061) I can't bring the database online or take it offline.  I am not sure where to go from here.  Any help will be appreciated.  Thanks. Bernie

<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure